LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2004, 04:45 AM   #1
kpachopoulos
Member
 
Registered: Feb 2004
Location: Athens, Greece
Distribution: Gentoo,FreeBSD, Debian
Posts: 705

Rep: Reputation: 30
Can't install RPMs in graphical environment


I set up successfully my Mandrake Linux system a few weeks ago. I had started installing RPM packages (a lot of them),by double-clicking on them, but suddenly the following happened: when i double-clicked on an RPM instead of asking me if i wanted to be installed, a menu appeared asking me with which application i wanted to open the file. I don't know if this has anything to do with this, but something had happened previously and the Console option from the KDE menu had dissapeared(thread:"Console option in KDE menu disappeared...").What has happened? How can i fix that?
 
Old 02-15-2004, 04:59 AM   #2
VincentB
Member
 
Registered: Jun 2003
Location: Brussels, Belgium
Distribution: Ubuntu 6.10
Posts: 139

Rep: Reputation: 15
You should anyway install RPM via command line (logged as root).

rpm -V *.rpm (to verify if already installed)
rpm -U *.rpm (to update / install).

Vincent
 
Old 02-15-2004, 05:10 AM   #3
kuba
Member
 
Registered: Feb 2004
Posts: 39

Rep: Reputation: 15
Quote:
Originally posted by VincentB
You should anyway install RPM via command line (logged as root).

rpm -V *.rpm (to verify if already installed)
rpm -U *.rpm (to update / install).

Vincent
Acutaly i installed it in Command line and i got a strange problem...

I tiped:
Code:
rpm blablabla.rpm -i
Then i wanted to uninstall it... i read "man RPM" and i tiped
Code:
rpm blablabla.rpm -e
Then linux said:
Code:
The RPM package is not installed
What should i do now??
 
Old 02-15-2004, 08:03 AM   #4
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
no .rpm on the end

try

rpm -e blablabla
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
which ISO's i need to install Sid with graphical environment extigyro Debian 6 08-10-2004 05:06 PM
graphical environment not working mouse46 Mandriva 11 08-09-2004 09:33 AM
Will my Graphical ENvironment not start automatticly? fedivh Slackware 19 08-08-2004 04:09 PM
Graphical Desktop Environment Gerardoj Linux - General 3 10-30-2003 08:00 PM
can't log in graphical environment abd_bela Debian 3 09-12-2003 08:43 AM


All times are GMT -5. The time now is 02:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration