LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2004, 11:24 AM   #1
Cavenaghi
LQ Newbie
 
Registered: Apr 2004
Location: Ghent, Belgium
Distribution: Slackware 10.1
Posts: 24

Rep: Reputation: 15
Can't install rpms anymore!


Hello, i have quite a serious problem i think, i can't seem to install rpms anymore.

I tried to install a .tar.gz, which required zlib version 1.1.4. I had version 1.2.x. installed but that didn't work, so i removed version 1.2.x and installed 1.1.4. The install succeeded, but since then - for some reason i do not know - i can't use the command "rpm" anymore.

Here's what i get when i enter "rpm" in console:

rpm: error while loading shared libraries: libz.so.1: cannot open shared object

My distro is SuSE 9.1, and i can't open YaST either

What should i do know?

Hope someone can help me with this, i would appreciate it!!
 
Old 07-30-2004, 11:49 AM   #2
Kanaflloric
Member
 
Registered: Jun 2004
Location: Canada
Distribution: Slackware 10.0
Posts: 80

Rep: Reputation: 15
You could try this (under root) :

# ldconfig

wich is necessary when installing something new.
 
Old 07-30-2004, 12:08 PM   #3
Cavenaghi
LQ Newbie
 
Registered: Apr 2004
Location: Ghent, Belgium
Distribution: Slackware 10.1
Posts: 24

Original Poster
Rep: Reputation: 15
I solved my problem: i installed the newer version from .tar.gz and made links to the right directories, now it's working again

But thanks for the tip!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot install a tar.gzi file anymore for Netscape izquierdista Linux - Software 1 07-10-2005 07:19 PM
firefox theme install - cannot use my browser anymore byen Linux - Software 6 07-09-2005 12:57 AM
I can't install Windows anymore...? EliasAlucard General 29 06-17-2005 05:07 AM
synaptic worked before, but won't install anymore marsonist Linux - Software 1 03-25-2004 04:04 AM
Can't install rpms!! Jojo87 Linux - Newbie 1 02-10-2004 01:22 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration