LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-27-2005, 03:44 PM   #1
haora
Member
 
Registered: Mar 2005
Distribution: SuSE 9.1, Ubuntu 5.10
Posts: 69

Rep: Reputation: 15
can't install gimp 2.2!!!


I need help, people!!!

I've tryed everything I can think of, and nothing as worked....

Let me fill you in...

I'm trying to install Gimp 2.2, in my box (SuSE 9.1), first of all, it ask for Gtk 2.4.4 or grater..., which I don't have (I have 2.4.0), so...I downloaded the rpm from a ftp, this is for a suse 9.2, but I guess I should work..., and I try to install it...

rpm -i filename.rpm

But I get a lot of conflicts like this:

file /opt/gnome/bin/gdk-pixbuf-query-loaders from install of gtk2-2.4.9-10.1 conflicts with
file from package gtk2-2.4.0-9

Just to show you one....

I've tryed to use YaST, but it doesn't show me the new version..., so, it doesn't let me update it...

What can I do???

What are those conflicts I get????, how can I not get them???

Any help will be greatly apreciated!!!!

Thanks in advance!

Haora
 
Old 06-27-2005, 05:23 PM   #2
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
You're getting dependency conflicts aka dependency hell. Basically what it's telling you is the package you're trying to install has a dependency conflict or causes a dependency conflict with another package.

Try adding the repositories you're downloading from to your YAST sources list and do upgrades and installs of what you need using YAST and see if that helps.

This is one of the biggest reasons I dislike RPM distros. LOL
 
Old 06-27-2005, 10:57 PM   #3
Harlin
Member
 
Registered: Dec 2004
Location: Atlanta, GA U.S.
Distribution: I play with them all :-)
Posts: 316

Rep: Reputation: 30
Slackware users quit rpm-based distros before they learned about urpm . Haora, take a look at urpm and give that a go (if it's installed on Suse). You will be surprised how easy that will make it to install packages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to install GImp 2.0 allelopath Linux - Software 5 11-14-2004 12:25 PM
Error when trying to install GIMP 2.0 Thaidog Linux - Newbie 3 09-21-2004 09:09 AM
Gimp 2.0 Install Help xsive Linux - Software 1 03-28-2004 02:39 PM
Gimp 2 install HOW-TO Hammett Linux - Software 9 03-28-2004 01:33 PM
need help with GIMP install rythomas Linux - Software 0 03-16-2004 07:32 PM


All times are GMT -5. The time now is 01:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration