LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2005, 09:08 PM   #1
ckm000
LQ Newbie
 
Registered: May 2005
Posts: 3

Rep: Reputation: 0
Can't install g++-3.3


Hello,

I'm trying to install phat, which is a requirement of specimen, a MIDI controlled audio sampler. I'm using Ubuntu.

When I do ./configure with phat, I get:

Code:
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See 'config.log' for more details.
After some Googling, I discovered that the problem might be that I don't have gcc, cpp, or g++ installed. After doing sudo apt-get install gcc cpp g++, I am told that gcc and cpp are already the latest versions. However:

Code:
g++: Depnds: g++-3.3 (>=1:3.3.4-1) but it is not going to be installed
E: Broken packages
So I sudo apt-get install g++-3.3, but I'm told:

Code:
The following packages have unmet dependencies:
g++-3.3: Depends gcc-3.3 (< 1:3.3.5) but 1:3.3.5-12 is to be installed
E: Broken packages
So, I sudo apt-get install gcc-3.3, but I'm told that gcc-3.3 is already the latest version.

Anybody have any ideas? It would be greatly appreciated!
 
Old 05-19-2005, 09:55 PM   #2
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
sudo apt-get install build-essential with the ubuntu cd in the drive an mounted
 
Old 05-19-2005, 10:44 PM   #3
ckm000
LQ Newbie
 
Registered: May 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy

Hmmm... when I try that I get:

Code:
The following packages have unmet dependencies:
build-essential: Depends: g++ (>=3:3.3) but it is not going to be installed
E: Broken packages
 
Old 05-20-2005, 04:16 PM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
use synaptic to repair broken packages. then try above
 
Old 05-21-2005, 06:56 PM   #5
ckm000
LQ Newbie
 
Registered: May 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Nope, it didn't work. Same error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fc3 install doesnt install grub properly onto sata drive sabo Linux - Newbie 4 02-03-2007 04:04 PM
make install does not install daemons (clamd snortd). Is this a feature of tarball? Emmanuel_uk Linux - Newbie 3 11-15-2005 01:29 AM
Error: Unable to boot /install/2.6/linux when starting Etch Install BuckRogers01 Debian 4 08-06-2005 06:40 PM
How do I re-install an operatingsystem? Corrupted install. Yast wont load. URGENT.thx CrewXp SUSE / openSUSE 5 05-09-2005 12:07 AM
knoppix liveCD install works great, HD install not so good stephanie_k Linux - Newbie 3 05-10-2004 09:41 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration