LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2014, 07:54 PM   #1
alemoo
Member
 
Registered: Nov 2013
Location: Sudbury, Ontario
Distribution: SuSE 13.1
Posts: 34

Rep: Reputation: Disabled
Can't Get Win7 to See Fedora's Shares


I've been struggling with this on and off for several weeks when I have time after work and am unable to get Win7 to see any shares that I have in Fedora.

Both are part of the workgroup "workgroup" without quotes
I have disabled SELinux as I know nothing of this and it will likely take me several months of studying to understand how to work it.

smb and nmb are currently running.
I have installed system-config-samba
I set up a share name and directory
Under the Security tab, the Authentication Mode is set to User
Authentication Server and Kerberos Realm values are both blank.
Encrypt Passwords: Yes
No Guest account

I have set up a user with the same name as on my Windows PC.
Permissions on my share in system-config-samba are set to Read Only.
Visibility is set to Visible.

Windows 7 Firewall is dropped.
I went into Firewall Configuration and under both the Trusted and Home sections, checked off samba and samba client.

Under /etc/fstab I have my drive's ntfs-3g dmask set to 022,fmask is 133 and umask is 0022.

When I browse Windows Explorer to the Network icon, only my own Windows PC shows up.
It's definitely not a firewall issue as I dropped the firewall service and refreshed the Windows Explorer window and nothing shows up.
Re-enabled the Fedora firewall immediately after since it was not the cause of the problem.
I can ping the server from my desktop.
I should mention they're both on the LAN, in the same subnet.
I'm not sure what else I am missing.

I'm guessing that since I am using system-config-samba, I no longer need to configure the /etc/samba/smb.conf file?
I've noticed that some values in it have been commented out with a ; after I installed system-config-samba.
Regardless, I do see for example:

[global]
hostname lookups = yes
hosts allow = win7pc
workgroup = workgroup
server string = Samba Server Version %v
bind interfaces only = True
interfaces = lo p33p1 10.0.0.0/24
hosts deny = ALL
security = user
;encrypt passwords = yes
smb passwd file = /etc/smbpasswd
guest ok = no
;guest account = nobody

[music]
netbios name = music
path = media/g/music
;read only = yes
;browseable = yes
valid users = alemoo

Last edited by alemoo; 03-05-2014 at 08:07 PM.
 
Old 03-06-2014, 11:45 AM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,923

Rep: Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824
Your smb.conf file is a bit of a mess.

Quote:
[global]
hostname lookups = yes
hosts allow = win7pc
workgroup = workgroup
server string = Samba Server Version %v
bind interfaces only = True
interfaces = lo p33p1 10.0.0.0/24
hosts deny = ALL
security = user
;encrypt passwords = yes
smb passwd file = /etc/smbpasswd
guest ok = no
;guest account = nobody

[music]
netbios name = music
path = media/g/music
;read only = yes
;browseable = yes
valid users = alemoo
netbios name belongs in the global section and your path is not absolute. Try the following:

[global]
workgroup = workgroup
netbios name = music
server string = Samba Server Version %v
bind interfaces only = True
;interfaces = lo p33p1 10.0.0.0/24
security = user
passdb backend = tdbsam
guest ok = no
;guest account = nobody

[music]
path = /media/g/music
browseable = yes


testparm is a command line tool to check the syntax of your smb.conf file.
 
1 members found this post helpful.
Old 03-06-2014, 01:57 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,107

Rep: Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478
as for SE
LEAVE IT ENABLED !!!!!
set it to "permissive"
look to see if there are any warnings
if any fix them

then set it to ENFORCING !!!

SE has come a long way in the last 8 years

there are almost NO issues any more
the tools for working with it also have come a VERY long way in the last 8 years

and the last 6 or so versions of fedora have almost not had any issues

so for fedora 19 or 20

leave it on and set to ENFORCING

Fedora and Redhat have it installed for a very good reason
YOUR and hence the REST of the webs SECURITY

Last edited by John VV; 03-06-2014 at 01:58 PM.
 
1 members found this post helpful.
Old 03-06-2014, 02:51 PM   #4
alemoo
Member
 
Registered: Nov 2013
Location: Sudbury, Ontario
Distribution: SuSE 13.1
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
Your smb.conf file is a bit of a mess.



netbios name belongs in the global section and your path is not absolute. Try the following:

[global]
workgroup = workgroup
netbios name = music
server string = Samba Server Version %v
bind interfaces only = True
;interfaces = lo p33p1 10.0.0.0/24
security = user
passdb backend = tdbsam
guest ok = no
;guest account = nobody

[music]
path = /media/g/music
browseable = yes


testparm is a command line tool to check the syntax of your smb.conf file.
I noticed you wanted me to use music for the netbios name but is it not asking me for my computer's hostname which is orion?
Also, testparm only gave me one warning about having one of the shares with a name longer than 12 characters, but I'm assuming that won't cause the entire share process to break.
Here's what I have now.

[global]
workgroup = workgroup
netbios name = music
server string = Samba Server Version %v
bind interfaces only = True
;interfaces = lo p33p1 10.0.0.0/24
security = user
passdb backend = tdbsam
guest ok = no
;guest account = nobody

[music-ro]
browseable = yes
path = /media/g/music

[video-ro]
browseable = yes
path = /media/v

[training-ro]
browseable = yes
path = /media/g/training/Tech

[finished-dl-ro]
browseable = yes
path = /media/g/finished downloads

I restarted smb and nmb, but still can't see anything showing up.

Last edited by alemoo; 03-06-2014 at 02:53 PM.
 
Old 03-06-2014, 02:57 PM   #5
alemoo
Member
 
Registered: Nov 2013
Location: Sudbury, Ontario
Distribution: SuSE 13.1
Posts: 34

Original Poster
Rep: Reputation: Disabled
Thanks Michaelk, it shows up.
I just had to wait a bit for it to refresh.
It says it can not access the path, so I'll have to see what that's about now...
 
Old 03-06-2014, 03:12 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,923

Rep: Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824
Then replace
netbios name = music
with
netbios name = orion

Be sure to restart samba.
Can you access any of the shares on windows PC?

Last edited by michaelk; 03-06-2014 at 03:14 PM.
 
Old 03-06-2014, 03:29 PM   #7
alemoo
Member
 
Registered: Nov 2013
Location: Sudbury, Ontario
Distribution: SuSE 13.1
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
Then replace
netbios name = music
with
netbios name = orion

Be sure to restart samba.
Can you access any of the shares on windows PC?
No, it shows up the computer name under Network, so I can see Orion there.
When I try to get in, it says Windows can not access \\orion.
Diagnostics simply said to make sure it allows incoming connections for file and printer sharing.
I think I'm going to drop the firewall on the server (orion) real quick to try it out and see if that's where the issue is.
 
Old 03-06-2014, 03:30 PM   #8
alemoo
Member
 
Registered: Nov 2013
Location: Sudbury, Ontario
Distribution: SuSE 13.1
Posts: 34

Original Poster
Rep: Reputation: Disabled
Yep. It's the firewall!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
UEIF Dual Boot Win7 & CentOS only boots Win7 wigglytoes Linux - General 3 12-30-2013 05:53 AM
[SOLVED] problem with samba , can't access shares in win7 nor ubuntu ali.abry Linux - Newbie 6 06-23-2013 12:39 PM
[SOLVED] Samba file shares & Security: WinXP connects, Win7 fails ShadowCat8 Linux - Server 1 01-05-2013 03:18 AM
Need help upgrading Samba B.C. Win7 Cant access shares davide123 Linux - Software 9 12-06-2010 03:13 PM
[SOLVED] After Upgrading from Win7-32 to WIN7-64 can't mount cifs shares pobrika Linux - Networking 2 07-21-2010 08:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration