LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-19-2003, 07:36 PM   #1
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
Can't get to console!!


Since a couple of weeks or so, I just can't get to the console by holding Ctrl + Alt + Fx no more... I could do it, but now it doesn't work... It just does nothing... From the login screen (in X) pressing Ctrl + Alt + Fx takes me to the console, but as soon as I log in (with any of the existing users, or as root), this sequence of keys does just nothing, so I suppose that I or some program I installed have changed something in the configuration of the X session, but I don't know what... Does anybody now how to get this working back again?

Thank you very much!!!
 
Old 10-19-2003, 08:32 PM   #2
rakriege
Member
 
Registered: Oct 2003
Location: San Deigo, CA
Distribution: FC3, Win2k Server, XP Pro & 2003 Server
Posts: 198

Rep: Reputation: 30
try Ctrl+Alt +F2
 
Old 10-20-2003, 12:33 AM   #3
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
When it started to be like that? What did you do in this period of time. Any particular things like editing conf files, install program, or upgrade kernel? What run level do you use for default logon? Try editing init.conf and change run level to 3. Just try anything you can think of.
 
Old 10-20-2003, 11:18 AM   #4
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
I said "Ctrl + Alt + F1" to give an example... none of them works.. (F2, F3, F4...).
I think it happened since I tried to activate num Lock by default at startup... (I copied a script from a page that used "setleds +num (....)" but it didn't work for X, since as soon as X started, Num Lock was turned off again. Since it was some weeks ago, and I was looking how to do it in many places at the same time, I don't know if I installed a program (as numlockx) or changed some conf file... I've tried "rpm -qa | grep numlock" but none of my packages has "numlock" in its name (I've even tried "rpm -qa > rpms.txt", and then opening that with gedit and searching for "numlock"), and if I modified a conf file, I didn't keep a record of that, so I don't know which one it was, and what changes did I make (though I don't remember changing conf files...)

I boot up by default in runlevel 5. Another thing I don't understand and that maybe it's connected somehow with my problem, is that if I switch to runlevel 3 ("/sbin/telinit 3"), and then I log in and from the console I type "startx", it seems as if the X-Windows were starting (i even see the cursor as an X for an instant) and then I get back to the console and I get something like:

Quote:
/home/kn0t/.Xclients: line 8: /home/kn0t/.Xclients-default: No such file or directory
/home/kn0t/.Xclients: line 8: exec: /home/kn0t/.Xclients-default: cannot execute: No such file or directory
And I DO remember that "before" (when Ctrl +Alt + Fx worked), I could do it that way, or even, having the X in the F7 terminal, open a new X-Windows from the console in other terminal (either by typing all the parameters, or by using a program called "x" that calls those parameters automatically depending on how many X you have already open)
 
Old 10-20-2003, 11:35 AM   #5
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
this is a shot in the dark but what does your
/etc/inittab
look like?
 
Old 10-20-2003, 11:42 AM   #6
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
Taking out the initial comments, my /etc/inittab looks like this (copied and pasted)

id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:respawn:/etc/X11/prefdm -nodaemon

Last edited by kn0t; 10-20-2003 at 11:44 AM.
 
Old 10-20-2003, 12:05 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
hmmmmm, your inittab looks all right. My guess is that the thing you tried to do with num-lock somehow disabled the key-combination ctrl-alt-Fn. You should find out first what you did and see if you can reverse it.

As for the startx from runlevel 3, I'm not sure what ~/.Xclients is for but I don't think it's needed. You could temporily rename it and see if you can then startx.
 
Old 10-20-2003, 12:19 PM   #8
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks, I'll check... is there a "start-of-session" conf file, or something like that? Maybe the changes are in there...
 
Old 10-20-2003, 12:31 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
for users, the X related ones are the the one named .xsomething in the home directory. There are also global ones in /etc/X11. Then there are .bashrc and .bash_profile in the home directory and their global counterparts in /etc. And then there are the init scripts.

If you can use CTRL-ALT-Fn in run level 3 (have you checked? you should get 6 different login screens), then the problem is most likely with the X config files.
 
Old 10-20-2003, 05:12 PM   #10
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
Yes, I've checked... It works in runlevel 3, and also in runlevel 5, from the (X) login screen. (That's were you can change the language for the next session, shutdown the computer, and so). From there, Ctrl-Alt-Fn works for the six different login screens (console). But when I log in an X-session (that's, when I introduce my user and pass) from that moment, Ctrl-Alt-Fn doesn't work... in fact, if I press them with a terminal window open, i get this:

[kn0t@localhost kn0t]$ ;7~

The NumLock led is off, but I can use the numpad and I get numbers... and if I press the num Lock button, the led doesn't turn on... I always have numbers there, and the period doesn't work... (the period in the numpad).... that's why I think it has something to do with the config files... I'll look for something "unusual", but the problem is that I might not find something "unsual" even though it is, so if someone has any ideas on what to look for...

Thanks again!!!
 
Old 10-20-2003, 05:55 PM   #11
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
you could try getting rid of all the files/directory in your home directory that start with an .x or .X; all of these are hidden files (except, ones you know are for programs like xine an xmms) - or just move them somewhere else. X should recreate the files with the default settings if it does not find them.
 
Old 10-20-2003, 07:28 PM   #12
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
In my home dir I don't have any files/directories that start with .x or .X, except xmms, xemacs, xscorch (a game) and xscreensaver... So I must have changed the system-wide conf files, and I don't know what their names are, so I can't just go and delete them (well... move them, better, just in case), and I don't think It'll be a good idea to move away ANYTHING that starts with x or X under /etc/X11... or should I? I

I could post here a copy of my /etc/X11 tree, if that helps, but until you say it could be helpful, I don't think it's a good idea to fill this thread with "ls"'s... ;-)
 
Old 10-20-2003, 10:35 PM   #13
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
how about deleting every folder that starts with '.' in your home folder. backup everything first. your settings for all programs will be back to default.
 
Old 10-25-2003, 11:08 AM   #14
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
I didn't think that would work, and it didn't It happens to the three users I have in the machine (also root), so I think it must be one of the system-wide config files, but I've looked through them and haven't found anything (it's possible though, that the problem has been under my nose and I haven't seen it, since I don't know much about lots of those config files...)
 
Old 10-25-2003, 12:18 PM   #15
bolinux
Member
 
Registered: Oct 2003
Distribution: Fedora Core 1 with KDE 3.2
Posts: 257

Rep: Reputation: 30
This happened to me except my screen was black and I could not do anything. It sort of fixed itself over a month or I could suspend and resume and it would work fine. Is this what is happening to you?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Run Win32 Console App in linux Console Lokie Linux - Software 2 08-12-2004 11:00 PM
console term789 Red Hat 2 09-30-2003 01:11 PM
X server in console 1 crashes on return from console 2 fieldmethods Red Hat 4 09-05-2003 01:12 AM
Getting into console Pixel Linux - Newbie 2 03-01-2003 02:22 PM
console jayakrishnan Linux - General 3 08-24-2002 12:12 PM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration