LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-02-2010, 08:49 AM   #1
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Rep: Reputation: 0
Smile Can't get Supertux to work.


Hi,
I installed Supertux from here but whenever I want to run it it console mode I get this message an tux wont start.
Code:
korbes@linux-ouow:~> supertux2
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:200 [/home/korbes/.supertux2] is in the search path
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:200 [/usr/bin//] is in the search path
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'controller' finished after 0.2 seconds
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:62 Couldn't load config file: Couldn't open file 'config': No such file or directory, using default settings
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'config' finished after 0 seconds
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'addons' finished after 0.042 seconds
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'tinygettext' finished after 0.001 seconds
[INFO] /usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'commandline' finished after 0 seconds
AL lib: pulseaudio.c:386: Context did not get ready: Connection refused
Can someone help me please cause the kids really love this game.
Thanks in advance.

Last edited by korbes; 02-02-2010 at 08:49 AM. Reason: subscr
 
Old 02-02-2010, 09:33 AM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
How did you install it?

If you use YAST it will install the necessary dependencies.

http://en.opensuse.org/Package_Management/Tools
 
Old 02-02-2010, 01:53 PM   #3
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by craigevil View Post
How did you install it?

If you use YAST it will install the necessary dependencies.

http://en.opensuse.org/Package_Management/Tools
I installed it using yast. oneclick install.
And during installation it installed dependencies too. But still Supertux won't work.
Any Ideas?......
 
Old 02-02-2010, 02:24 PM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,877

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Quote:
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:200 [/home/korbes/.supertux2] is in the search path
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:200 [/usr/bin//] is in the search path
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'controller' finished after 0.2 seconds
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:62 Couldn't load config file: Couldn't open file 'config': No such file or directory, using default settings
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'config' finished after 0 seconds
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'addons' finished after 0.042 seconds
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'tinygettext' finished after 0.001 seconds
/usr/src/packages/BUILD/supertux-0.3/src/supertux/main.cpp:517 Component 'commandline' finished after 0 seconds
These look like paths to source code. It seems you have installed the source code for supertux, and now need to compile the code to get an executable binary file.
 
Old 02-02-2010, 03:02 PM   #5
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
bigrigdriver: Yes, they are paths to the source, but no, it doesn't really mean anything. It's just so that I'd know where in the source the message comes from.

It does seem odd that /usr/bin is in the search path rather than /usr/share/games/supertux2.

The main, fatal problem is with OpenAL and PulseAudio not liking each other. I know that OpenAL and PulseAudio have an unpleasant history with each other.. I don't use PulseAudio, so I'm not sure how to fix this.. maybe upgrade both and see what happens?
 
Old 02-03-2010, 03:53 AM   #6
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Hi,
I updated OpenAL and PulseAudio but stil same problem.
Anyone any Ideas on how to get this supertux to work?
 
Old 02-03-2010, 12:11 PM   #7
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
hmm.. I do remember now that if you use "pasuspender", that'll take PulseAudio out of the equation
 
Old 02-03-2010, 05:14 PM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
The link in post # 1 : http://software.opensuse.org/search

Please choose supertux-0.1.3-46.4.i586.rpm
( or supertux-0.1.3-46.4.x86_64.rpm if you have a 64 bit OS.)
And do not choose the package marked src,
is source code only.

Example supertux-0.1.3-46.4.i586.rpm : Click the package
http://download.opensuse.org/reposit...-46.4.i586.rpm
.. and when it has been downloaded, you can click the file,
Yast2 will then install it.

Works OK in Suse 11.2, sound etc.
.....

The supertux files, you have in /usr/src/ , suggest :
delete them all.
.....
 
Old 02-05-2010, 05:05 AM   #9
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by knudfl View Post
The link in post # 1 : http://software.opensuse.org/search

Please choose supertux-0.1.3-46.4.i586.rpm
( or supertux-0.1.3-46.4.x86_64.rpm if you have a 64 bit OS.)
And do not choose the package marked src,
is source code only.

Example supertux-0.1.3-46.4.i586.rpm : Click the package
http://download.opensuse.org/reposit...-46.4.i586.rpm
.. and when it has been downloaded, you can click the file,
Yast2 will then install it.

Works OK in Suse 11.2, sound etc.
.....

The supertux files, you have in /usr/src/ , suggest :
delete them all.
.....
Dear knudfl:

I deleted everything from my system with the name supertux. Also the files in /usr/src

Now I installed "supertux-0.1.3-46.4.x86_64.rpm" from the software page. It installed with yast.
And now I get this error message:

Code:
korbes@linux-ouow:~> supertux
Datadir: /usr/bin/../share/supertux
Warning: No joysticks are available.

Error: Couldn't load musicfile
/usr/bin/../share/supertux/music/SALCON.MOD

Aborted
korbes@linux-ouow:~>
Is there a way to solve this problem.
I checked and the file SALCON.MOD is there!

With the command
Code:
supertux --disable-sound
it works perfect. But I really really want it with sound.
Thanks in advance.

Last edited by korbes; 02-05-2010 at 05:12 AM.
 
Old 02-05-2010, 07:26 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
I never touched the sound settings,
using default worked OK. Nice sound.

.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
opensuse supertux svn ieatsplaydoh Linux - Software 0 04-14-2007 12:53 PM
LXer: SuperTux: Reloaded LXer Syndicated Linux News 0 02-06-2007 05:54 PM
supertux was working, but now... foustware Linux - Games 3 05-03-2005 03:06 PM
How do I configure Supertux to use my joypad? Phathead Linux - Games 1 01-21-2005 11:39 PM
SuperTux won't start MagiNegi Linux - Games 4 11-07-2004 01:32 PM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration