LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2006, 11:43 PM   #1
theknowledgeist
LQ Newbie
 
Registered: Jan 2006
Distribution: Knoppix
Posts: 17

Rep: Reputation: 0
can't get resolution higher than 1024x768 using knoppix w/ ati mobility radeon 200m


I am running Knoppix (installed on the hard drive) on an HP Pavilion zv6000 with an Ati mobility radeon 200m graphics board. I've installed the ati drivers but I can't get the resolution above 1024x768. I want to run Linux at 1280x800 b/c I have a widescreen display.

When I right-click on the desktop and go to configure desktop:display, the highest resolution I can select from the pull down menu is 1024x768. Any thoughts on how to get it to run at 1280x800?

I've done a few google searches on the topic, but all the hits I got explained the process using language and terms above my knowledge level (I'm new to Linux).

Thanks.
 
Old 01-23-2006, 11:54 PM   #2
Centinul
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 552

Rep: Reputation: 30
Well it looks like you will have to edit the following file: /etc/X11/xorg.conf
This file controls the configuration of your graphical X server. In most cases this problem is when the proper resolutions that you want to use are not listed in this file. Here is an excerpt from my xorg.conf file.

Code:
Section "Screen"
        Identifier "Screen0"
        Device "Card0"
        Monitor "Monitor0"
        DefaultDepth 24

        SubSection "Display"
                Viewport 0 0
                Depth 24
                Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
The settings under "Modes" is most likely what you'll have to change. Add the resolutions that you would like to use (sometimes there are more than 1 subsection so add them there as well). Restart X and then you should be able to select the resolution that you want. I hope this helps and post back with your results.
 
Old 01-24-2006, 03:18 PM   #3
theknowledgeist
LQ Newbie
 
Registered: Jan 2006
Distribution: Knoppix
Posts: 17

Original Poster
Rep: Reputation: 0
Centinul,

I can't locate the /etc/X11/xorg.conf file. I opened the X11 folder and didn't see a xorg.conf file. I also did a find file search for xorg and nothing came up.

Should I be using terminal? Once I find the file, how do I edit it? I don't know anything about Linux.

Thanks.
 
Old 01-24-2006, 03:26 PM   #4
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,114

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Quote:
Originally Posted by theknowledgeist
I can't locate the /etc/X11/xorg.conf file.
Then try looking for /etc/X11/XF86Config-4 instead. You may be running XFree86, not xorg.
 
Old 01-24-2006, 03:34 PM   #5
Centinul
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 552

Rep: Reputation: 30
Thanks haertig, I forgot about XFree86.

theknowledgeist,

I don't use the KDE environment so I do not know what is installed on your system as far as graphical editing tools. Any text editor would work for this purpose. Typically though if you open a file that requires root priveleges under the username you won't be able to change the file. I would recommend that you go to your terminal, su to root, and open up the file with your text editor of choice from there. I hope this helps,
 
Old 01-24-2006, 03:35 PM   #6
theknowledgeist
LQ Newbie
 
Registered: Jan 2006
Distribution: Knoppix
Posts: 17

Original Poster
Rep: Reputation: 0
I found /etc/X11/XF86Config-4. I added "1280x800" but when I tried to save the file, it said the document could not be saved b/c it wasn't possible to write to /etc/X11/XF86Config-4.

The error box said check that you have write access to this file. How do I check that?
 
Old 01-24-2006, 03:38 PM   #7
theknowledgeist
LQ Newbie
 
Registered: Jan 2006
Distribution: Knoppix
Posts: 17

Original Poster
Rep: Reputation: 0
Centinul,

How do I open the /etc/X11/XF86Config-4 file with a text editor? (I don't have a preferred text editor b/c I don't know about any of the text editors).
 
Old 01-24-2006, 03:57 PM   #8
Centinul
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 552

Rep: Reputation: 30
I'm not completely sure if this is true or not but since you are in KDE I believe the default text editor is Kedit.
So if you go into the terminal and type
Code:
kedit /etc/X11/XF86Config-4
it should open up. It might need to be Kedit and not kedit but I'm not sure. If that doesn't work try the command with nano which is another text editor. Another text editor is vi or vim. Give those a shot. I recommend searching for vi/vim tutorials if you use that because it's not apparent how to use it when you open it. Make sure you su to root before you edit the file. I hope this helps.
 
Old 01-24-2006, 05:16 PM   #9
theknowledgeist
LQ Newbie
 
Registered: Jan 2006
Distribution: Knoppix
Posts: 17

Original Poster
Rep: Reputation: 0
I opened the XF86Config-4 file using nano and edited it. This is what an excerpt of it looks like now:

Code:
Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultColorDepth 16
	SubSection "Display"
		Depth     1
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     15
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     32
		Modes "1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
However I still can't get the resolution higher than 1024x768.
 
Old 01-24-2006, 07:05 PM   #10
Centinul
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 552

Rep: Reputation: 30
Just a quick question. Did you restart the X server after you made those changes? If you did and you still can't select a higher resolution I'm really not sure what to do next. Maybe someone else can help?
 
Old 01-24-2006, 08:01 PM   #11
theknowledgeist
LQ Newbie
 
Registered: Jan 2006
Distribution: Knoppix
Posts: 17

Original Poster
Rep: Reputation: 0
Yes, I restarted the whole computer. I don't know how to just restart X server.
 
Old 01-24-2006, 08:05 PM   #12
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
ctrl+alt+backsp will kill x. With knoppix, it should restart on it's own. otherwise type startx at teh prompt to restart x
 
Old 01-24-2006, 08:25 PM   #13
sunpascal
Member
 
Registered: Jan 2005
Distribution: Debian
Posts: 104

Rep: Reputation: 15
I used to have that problem too. I had to play around with all sorts of options in the config file.
However I believe there is a tool that does that.
base config?
something like: dpkg reconfigure-x-free86
does anyone know?
 
Old 01-24-2006, 08:30 PM   #14
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
dpkg-reconfigure xserver-xfree86 ????
 
Old 01-24-2006, 08:36 PM   #15
sunpascal
Member
 
Registered: Jan 2005
Distribution: Debian
Posts: 104

Rep: Reputation: 15
yeah, that's it. It will ask a few questions and then write the conf file. This might be easier to run a few times with different options and check which one works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get Resolution higher than 1024x768 with NVIDIA driver AntWarrior Ubuntu 3 03-17-2007 10:30 PM
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 08:52 PM
I can't set the resolution higher than 1024x768 Prism Slackware 5 08-27-2004 01:45 PM
[Debian (Knoppix)] ATI Radeon Mobility 9600 Proprietary Drivers? Do they work? false-hopes Linux - Laptop and Netbook 0 08-23-2004 12:19 AM
Dual head second monitor resolution problem ATI Radeon Mobility 7500 Redhat 9 kragemp3 Linux - Hardware 0 05-06-2004 10:05 PM


All times are GMT -5. The time now is 02:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration