LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2003, 08:28 PM   #1
ehc1951
LQ Newbie
 
Registered: Mar 2003
Location: Alabama
Posts: 3

Rep: Reputation: 0
Can't Get Printer to Work


New user to Linux, just installed RH 8.0 to an 80 Gig Slave drive. The install came off without a hitch, almost. RH found my video card, (Nvedia 440 64 Meg DDR), mouse, keyboard, and soundcard.9soundblaster live 5.1) I ran the print config and it found my printer, HP 940C on USB. I choose my printer and driver and clicked apply. LPD restarted but when I try to print a test page I get an error, no number, just tells me information can't be sent to printer. Can anyone help? Have read all that I can find.

Thanks

Ernie Cromwell
 
Old 03-03-2003, 08:38 PM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Check your log files for a little more detail as to what it could be. Post the error messages. It could be a lot of things but we could narrow it down if we saw the exact error messages.
 
Old 03-03-2003, 09:41 PM   #3
ehc1951
LQ Newbie
 
Registered: Mar 2003
Location: Alabama
Posts: 3

Original Poster
Rep: Reputation: 0
There is no error message number, just say information can't be sent to the printer. wish I could be of more help. really enjoying linux, just pretty stupid.
 
Old 03-03-2003, 09:52 PM   #4
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I find it hard to believe that you are stupid. You were smart enough to install Linux and thats an accomplishment compared to the Windows installer.(i.e. Next...Next...Next...Next...Yes...Next...Next)

Anyway what are you using for printing? CUPS? Whatever you are using check the conf file for it. There should be an option for log levels. For instance in the CUPS conf file(/etc/cups/cupsd.conf) there is a section that looks like this:

#
# LogLevel: controls the number of messages logged to the ErrorLog
# file and can be one of the following:
#
# debug2 Log everything.
# debug Log almost everything.
# info Log all requests and state changes.
# warn Log errors and warnings.
# error Log only errors.
# none Log nothing.
#

LogLevel info

Mine is set to info because its working but you would wan't to change it to debug so there is more info in your log files.

Restart CUPS, or whatever your using, clear the log files, and try to print something again. Then you will get a nicely detailed, almost too detailed, log of whats going on.
 
Old 03-03-2003, 10:28 PM   #5
ehc1951
LQ Newbie
 
Registered: Mar 2003
Location: Alabama
Posts: 3

Original Poster
Rep: Reputation: 0
cups isn't installed. When I ran print config from the command line I got the same config window as when I used the print config form systems. It allows me to go all the way through
1. I get a choice to pick dev/usb/ibo, or dev/ibo. At his point I choose dev/usb/ibo because my priner is hooked up usb.
2. I'm allowed to pick my printer. HP 940c. Then I'm given a choice of 3 drivers and I choose hpijs, it seems to be the best according to what i've read..
3. I'm asked to hit apply and at this time I'm told the lpd has restarted and everything is OK. When I choose to hi est page I'm told no information is being snet o the priiner. I've tried every combo there is with no luck. My printer and drivers are listed, don't kniw what I'm doing wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to get my printer to work true_atlantis Linux - Newbie 3 10-01-2006 04:09 AM
printer modules not loaded; parallel printer doesn't work blinux1 Linux - Newbie 7 06-24-2004 10:59 PM
Can't get printer to work, HELP! newbix Linux - Hardware 4 10-13-2003 11:55 PM
Getting printer to work? zsejk Slackware 16 04-27-2003 09:40 PM
getting my printer to work caleb Conectiva 18 10-09-2002 04:42 PM


All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration