LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2004, 06:49 PM   #1
scary
LQ Newbie
 
Registered: Nov 2003
Posts: 4

Rep: Reputation: 0
can't get philips lcd to work


hi,
I can't get my philips 190b4cg 19" lcd monitor to work under XFree86. The same problems occours when I try to switch to higher resolutions in the console with framebuffer etc., the screen becomes black and tells me to switch to a compatible video mode, in particular 1280x1024@60 hz. Now, I have already tried to force Xwindows to that particular video mode by calculating somewhere on the web the "Modeline" correct string and putting it into XF86Config, nothing changed.

If needed, I can attach my whole XF86Config, XFree86.0.log etc. - any ideas?
Radeon 7200, Philips 190B4CG
thanks for your help!
 
Old 04-16-2004, 06:57 PM   #2
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
did you check that Horiz and Vert settings in XF86Config match those in the monitor documentation?
 
Old 04-17-2004, 04:13 AM   #3
scary
LQ Newbie
 
Registered: Nov 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Yes I've checked in the manual.. I'm quite clueless at this point. Isn't there any way to force monitor to 1280x1024@60hz ??
 
Old 04-17-2004, 05:51 AM   #4
jib2
Member
 
Registered: Sep 2003
Location: Paris, France
Distribution: Arch x86_64
Posts: 221

Rep: Reputation: 30
maybe you could post your XF86Config(-4) or at least the Monitor and Screen sections.
 
Old 04-17-2004, 07:44 AM   #5
scary
LQ Newbie
 
Registered: Nov 2003
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for your help, here goes XF86Config

Section "Monitor"

Identifier "phil"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

HorizSync 30-82

# HorizSync 30-64 # multisync
# HorizSync 31.5, 35.2 # multiple fixed sync frequencies
# HorizSync 15-25, 30-50 # multiple ranges of sync frequencies

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

VertRefresh 56-76
Modeline "1280x1024@60" 114.98 1280 1312 1744 1776 1024 1045 1055
1076
EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"

# The chipset line is optional in most cases. It can be used to override
# the driver's chipset detection, and should not normally be specified.

# Chipset "generic"

# The Driver line must be present. When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module. Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.

Driver "vga"
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for. When this line isn't present, a device
# section can only match up with the primary video device. For PCI
# devices a line like the following could be used. This line should not
# normally be included unless there is more than one video device
# intalled.

# BusID "PCI:0:10:0"

# VideoRam 256

# Clocks 25.2 28.3

EndSection

# Device configured by xf86config:

Section "Device"
Identifier "rade"
Driver "radeon"
# unsupported card
#VideoRam 65536
# Insert Clocks lines here if appropriate
EndSection


# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen 1"
Device "rade"
Monitor "phil"
DefaultDepth 24

# Subsection "Display"
# Depth 8
# Modes "1280x1024" "1024x768" "800x600" "640x480"
# ViewPort 0 0
# EndSubsection
# Subsection "Display"
# Depth 16
# Modes "1280x1024" "1024x768" "800x600" "640x480"
# ViewPort 0 0
# EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024"
ViewPort 0 0
EndSubsection
EndSection


Since the monitor always asks for 1280x1024@60hz, I commented out any lower resolution..

besides, at the moment I cannot even boot my gentoo linux since I've tried to enable vesafb and now the screen goes into sleep mode just after lilo selection. Even setting the vga=normal boot parameter won't allow me to boot, guess I'll have to recompile the kernel after booting from the liveinstallation CD (which by the way has no problem in setting high resolution + bootsplash images in the console ...)
 
Old 04-19-2004, 11:04 AM   #6
hooloovoo_83
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
I have the same problem. I have a philps 150S and it displays the same message as scarys. I have one additional problem however. I am complete Linux newbie, hoping to learn all there is to know as quickly as possible. I would greatly apprechiate any help, in very basic newbie terms. Thanks
 
Old 04-19-2004, 01:56 PM   #7
scary
LQ Newbie
 
Registered: Nov 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Looks like I partially solved my problem: now XFree86 seems to start quite correctly if I put in the video card section the option

Option "DDCMode" "on"


The fun thing is, when I try to revert to console - either by closing X or by switching to another virtual console - the screen becomes black and blah blah please switch to ...
I can only switch back to X to have images back ..

besides, framebuffer doesn't work. I see people complaining because the standard vesafb driver only supports 60Hz but if I use it setting the boot param
vga=0x31A (1280x1024@16bp) I have the same problem, please switch to 1280x1024@60Hz.

Of course the radeonfb driver doesn't work either...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Philips 170S LCD Screen magoot Linux - Hardware 2 10-02-2005 03:57 PM
Please help: my LCD monitor doesn't work with Linux malb Linux - Hardware 1 07-30-2005 11:45 AM
Philips USB webcam doesn't work on Suse 9.1 Haldrik Linux - Distributions 2 08-11-2004 05:45 PM
Problem with philips 150s lcd monitor feder4 Linux - Hardware 0 08-05-2004 10:30 AM
Tv-tuner with PHILIPS SAA7130. How to make it work? buboleck Slackware 4 04-30-2004 04:30 AM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration