LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-10-2015, 06:44 PM   #1
joeinslw
Member
 
Registered: Oct 2015
Posts: 35

Rep: Reputation: Disabled
Can't get my Dell or HP printers to load drivers or work.


Hello,
I am new to Linux Questions, and I know there might be an answer to this in one of these threads, but I am using Ubuntu 15.04 which as you know is beta, and I have had internal error messages when I start up and when I change to another program. So I wonder if this distribution has anything to do with my problems?

Thanks
 
Old 10-10-2015, 07:12 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,185
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by joeinslw View Post
So I wonder if this distribution has anything to do with my problems?
Hi...

Welcome to the forum

First, please read the information posted here and here. It's very important that you provide us with the information we need to help you.

What are the error messages you're receiving? What is the brand and model (and model number) of your computer. Did you install Ubuntu 15.04 from scratch or did you upgrade from a previous version?

Also, please open a terminal and post the entire output of...

Code:
lspci -nnk
Regards...
 
1 members found this post helpful.
Old 10-10-2015, 08:47 PM   #3
joeinslw
Member
 
Registered: Oct 2015
Posts: 35

Original Poster
Rep: Reputation: Disabled
I bought the Ubuntu 64bit disc 15.04 online, but this OS won't accept any Microsoft software even though I installed Wine software from the Ubuntu software center.
Don't know if this is related but it also won't load anything after it has been sitting for a few hours, I have to restart the computer before anything will work.

Thanks for the reply.
 
Old 10-10-2015, 09:03 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,419
Blog Entries: 6

Rep: Reputation: Disabled
Hi: & Welcome to Linux Questions!

Install HPLIP (if it's not already installed) from your 'Ubuntu Software Center' and reboot.-
http://hplipopensource.com/hplip-web/index.html

Synaptic Package Manager should show you if it's already installed or not.
 
Old 10-10-2015, 09:58 PM   #5
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,185
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by Ztcoracat View Post
Install HPLIP (if it's not already installed) from your 'Ubuntu Software Center' and reboot.-
Whoops, missed that one!

@joeinslw: In addition to the information I requested above, what is the model of your HP printer?

Regards...
 
Old 10-10-2015, 10:15 PM   #6
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,352
Blog Entries: 12

Rep: Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731
Note that in many distros, hplip and the hplip-GUI (hp-toolbox on the command line) interface are two separate packages.
 
Old 10-10-2015, 11:43 PM   #7
joeinslw
Member
 
Registered: Oct 2015
Posts: 35

Original Poster
Rep: Reputation: Disabled
Hello, and thanks to everyone that is trying to help.

First of all I have a Lenovo Thinkserver ts440 for my computer.
I bought this computer new and installed 4 new 2tb hard drives, and after I did the raid configuration I installed Ubuntu 15.04 and it's the only OS on here.

I have an HP Laserjet 1018 printer that won't print at all, and I understand there are no drivers for it on this computer.
I also have a Dell C1765nfw all in one laser printer that I managed to get working, however only at times, then I loose the driver and it won't work, until I go through the process again, and load the driver.

I am getting internal error messages on this computer but there is no number, just an internal error message, which I have no idea what that means or why I'm getting it.

I did find the HPLIP in the software center (thanks) installed it and tried to download and install using the instructions on the screen, but at the end it said there is a bug, and could not go any further, even though I tried different scripts but the message is can't install, so I'm stuck. Anyone have any further help?

Last edited by joeinslw; 10-10-2015 at 11:48 PM.
 
Old 10-10-2015, 11:53 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,419
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
I am getting internal error messages on the computer but there is no number, just internal errors message, which I have no idea what that means or why I'm getting it.
Please post the exact error message.

http://hplipopensource.com/hplip-web...rjet_1018.html

Did this not work?
Quote:

Download the file to a convenient location (e.g., home directory or desktop, etc).
Open a console/terminal and cd to the location where the installer was downloaded. (e.g., cd ~/Desktop)
Type in and run this command: 'sh hplip-3.15.9.run'


Last edited by Ztcoracat; 10-10-2015 at 11:55 PM.
 
Old 10-11-2015, 12:09 AM   #9
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,185
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by joeinslw View Post
I am getting internal error messages on this computer but there is no number, just an internal error message, which I have no idea what that means or why I'm getting it.

I did find the HPLIP in the software center (thanks) installed it and tried to download and install using the instructions on the screen, but at the end it said there is a bug, and could not go any further, even though I tried different scripts but the message is can't install, so I'm stuck. Anyone have any further help?
Hi...

Please understand that what you provided above doesn't give us anything to go on. Please copy, paste and post here the specific error messages you're getting. Please also post the information requested using the command I gave you in my previous post, as well. If you're not sure how to do this, please ask.

Also, did you install the required plug-in for your HP printer, as mentioned on the page that Ztcoracat linked to?

Regards...
 
Old 10-11-2015, 08:25 PM   #10
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Actually I've got an HP1020 which used to work when I installed Centos 6 originally, but at some point (possibly the update to C6.7) it seemed to lose the ability to print google maps content - effectively the various shades of grey for the roads/buildings.
I tried the HPLIP stuff but kept getting errors.

In the end I went back to this http://foo2zjs.rkkda.com/, which is what I used to have to use for Centos 5.x. Now it works fine.

This is all background to saying that that page has working solns for many similar printers, inc HP 1018.

HTH
 
Old 10-12-2015, 05:13 PM   #11
joeinslw
Member
 
Registered: Oct 2015
Posts: 35

Original Poster
Rep: Reputation: Disabled
Sorry guys,
But until I can figure out how to get rid of the bug in the HPLIP software I downloaded, this printer will never work, guess I'll have to keep looking and trying but if I can't find a solution for this bug, it will never work & the only thing it would be good for after that, is a door stop.

Thanks for trying,
joeinslw
 
Old 10-12-2015, 07:56 PM   #12
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Which printer?
The HP 1018 should work with the link I supplied.
 
Old 10-13-2015, 10:29 AM   #13
joeinslw
Member
 
Registered: Oct 2015
Posts: 35

Original Poster
Rep: Reputation: Disabled
Chris,
Thanks for trying but I couldn't download http://foo2zjs.rkkda.com/, when I tried all I got was several pictures of printers that are supported. My HP Laserjet 1018 is listed, and when I tried to download it told me that my browser is not supported, and I do have Firefox.
Maybe it's because I have Ubuntu 15.04 and this browser came with this distro, and it doesn't recognize this browser I don't know why or understand, but thanks for trying. If you have any other recommendations I am willing to try.

Thanks again,
Joe

Last edited by joeinslw; 10-13-2015 at 10:32 AM.
 
Old 10-13-2015, 10:52 AM   #14
joeinslw
Member
 
Registered: Oct 2015
Posts: 35

Original Poster
Rep: Reputation: Disabled
Chris and everyone in this thread,
Got this email from Ubuntu about this bug, does this mean anything to you, or how to get rid of it?
--------------------------------------------------------------------
"package linux-image-3.19.0-29-generic (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 128 Edit"

Bug Description

The Bug might have been in a NY Dime Bank ad I was reading, but not sure, all I know is the server froze up three times and each time I had to do a force shut down, and restart the server.
--------------------------------------------------------------------
ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-29-generic (not installed)
ProcVersionSignature: Ubuntu 3.19.0-27.29-generic 3.19.8-ckt5
Uname: Linux 3.19.0-27-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.4
Architecture: amd64
AudioDevicesInUse:
USER PID ACCESS COMMAND
/dev/snd/controlC0: joeinslw 1726 F.... pulseaudio
Date: Mon Sep 14 16:01:03 2015
DuplicateSignature: package:linux-image-3.19.0-29-genericnot installed):subprocess new pre-installation script returned error exit status 128
ErrorMessage: subprocess new pre-installation script returned error exit status 128
HibernationDevice: RESUME=UUID=59d4d870-6596-4daa-bdec-d2d0c6e4d2f0
InstallationDate: Installed on 2015-08-14 (31 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
IwConfig:
eth0 no wireless extensions.

lo no wireless extensions.
MachineType: LENOVO ThinkServer TS440
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-27-generic root=UUID=1db83ae2-a976-41b2-969e-03c7db20824b ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 2.02~beta2-22ubuntu1.1
RfKill:

SourcePackage: linux
Title: package linux-image-3.19.0-29-generic (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 128
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/19/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: FBKT99AUS
dmi.board.name: ThinkServer TS440
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.type: 7
dmi.chassis.vendor: LENOVO
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnLENOVO:bvrFBKT99AUS:bd09/19/2014:svnLENOVOnThinkServerTS440vr70AQ0009UX:rvnLENOVO:rnThinkServerTS440:rvrNotDefined:cvnLENOVO :ct7:cvrToBeFilledByO.E.M.:
dmi.product.name: ThinkServer TS440
dmi.product.version: 70AQ0009UX
dmi.sys.vendor: LENOVO
--------------------------------------------------------------------
Below is Linux's answer:

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

I have noticed they note amd for the processor, I have Intel, would that make a difference?

Last edited by joeinslw; 10-13-2015 at 10:55 AM. Reason: Forgot to mention that the error says it's a CUPS error, do you know how to fix that?
 
Old 10-13-2015, 02:26 PM   #15
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,185
Blog Entries: 3

Rep: Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694Reputation: 694
Quote:
Originally Posted by joeinslw View Post
Chris,
Thanks for trying but I couldn't download http://foo2zjs.rkkda.com/, when I tried all I got was several pictures of printers that are supported. My HP Laserjet 1018 is listed, and when I tried to download it told me that my browser is not supported, and I do have Firefox.
Maybe it's because I have Ubuntu 15.04 and this browser came with this distro, and it doesn't recognize this browser I don't know why or understand, but thanks for trying. If you have any other recommendations I am willing to try.
Hi...

You don't need the browser to install the driver, simply follow the instructions under the section that says "Download and Install." You will need to use the terminal for this, not Firefox. Simply copy and paste the different commands to your terminal one at a time, pressing "Enter" on your keyboard between each command.

The bug is an entirely different issue which you will need to create a different thread for.

Regards...

Last edited by ardvark71; 10-13-2015 at 02:29 PM. Reason: Changed/Added information.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I load balance 2 printers? AWSmith AIX 5 01-17-2014 04:25 AM
where can i find drivers for the following printers Brian1234 Linux - Newbie 5 11-20-2010 12:09 PM
Ndis drivers for printers newbiesforever Linux - General 4 01-26-2008 05:39 PM
someone help me get dell resource drivers to work in fedora. larrywaswa Red Hat 1 05-20-2005 03:33 AM
USB, printers, drivers, graphics.. goldfish Linux - Hardware 12 09-18-2003 11:42 AM


All times are GMT -5. The time now is 06:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration