LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2004, 05:21 PM   #1
Amethye
LQ Newbie
 
Registered: Jun 2004
Distribution: mandrake 10
Posts: 3

Rep: Reputation: 0
Can't get GNOME to work, among other things


I cant seem to start a session with GNOME with my normal account. It works well when I try it with the root account, but when I try using any other account, it just crashes and takes me back to the login screen. No error messages, no nothing. I *think*(heh) I screwed the permissions up, 'cos when i create any other account i cant use *neither* KDE nor GNOME(KDE gives out an error message out though, saying that I dont have write access to the home directory of the account).
I had the same KDE problem with my primary account(admin), but i fixed it logging in with root and editing the owner and permissions on /home/admin.
I think it happenned 'cos i reinstalled linux again, without uninstalling the old one(hoping for a repair heh) or reformatting the drive(I had some problems with WinXP on another HD).
So, is there a way to fix this?(Say, kill off *all* of the user accounts, refreshing the list)
Or am I screwed and should do a reinstall, with reformat?

Also, is the user account number and user account name make a difference when entered as the "owner"(Say my account is number 502, accountname is admin, so owner: 502 = owner: admin?)

And another thing, is there a way to edit the account number?(assuming its unused)

Uh, and sorry if these questions are too obvious(and for my bad english), i just have a whopping 7 hours of experience with linux
 
Old 06-19-2004, 05:50 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
If you only have 7 hours invested I would start over with a fresh install.
 
Old 06-19-2004, 05:54 PM   #3
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
You should change the permissions of the user directories(/home/username) and the home(/home) directory. Home directory must be set to 755 (rwxr-xr-x root:root). It will work either way, but it is safe to have it with these permissions. When changing the user directory permissions, set them with the command:

chmod -R 700 /home/username
chown -R username:username /home/username

the -R makes it change all the files permissions in that directory also.
the chown makes the users home directory owned by the user.

Probably GNOME wants to write the config files .gnome-xxxxxx and cannot. If this is the case, then these commands should help you. Don't worry, changing permissions to home directory, cant mess anything up.

Peace!
 
Old 06-19-2004, 05:56 PM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Log in as root and change the ownership of your home folder.
chown -R username:group /home/username

If the problem is permissions, like you say, then
chmod -R 755 /home/username

That's a bit of a blunt instrument changing the permissions of everything in the directory to 755 makes every file executable and allows any user to read it. I don't think I'd do that. If it was unfixable, what I'd do is move it out the way by renaming it and then make a clean, empty, home folder. Then you can copy individual files into your new home.

mv /home/username /home/usernameo
mkdir /home/username
chown username:group /home/username
 
Old 06-19-2004, 05:59 PM   #5
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
account #? do you mean userid? the userid is the third column if you "cat /etc/passwd"

no permissions on home dir? I assume you're in runlevel 5 - booting to a login manager? try

ctrl-alt-F1 (or F2-6)

then login as root, and check that permissions/ownership are right:

ls -l /home

also do "ls -la /home/username" (substitute your user for username) - make sure the user owns all the stuff listed there (owner is third column)
 
Old 06-19-2004, 06:03 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Re: Can't get GNOME to work, among other things

Quote:
Originally posted by Amethye

I had the same KDE problem with my primary account(admin), but i fixed it logging in with root and editing the owner and permissions on /home/admin.
I think it happenned 'cos i reinstalled linux again, without uninstalling the old one(hoping for a repair heh) or reformatting the drive(I had some problems with WinXP on another HD).
So, is there a way to fix this?(Say, kill off *all* of the user accounts, refreshing the list)
Or am I screwed and should do a reinstall, with reformat?
It looks like chown or changing user id number would help. It looks like you have now diffeent numbers that there were with previous install.

Quote:
Also, is the user account number and user account name make a difference when entered as the "owner"(Say my account is number 502, accountname is admin, so owner: 502 = owner: admin?)
Number is more important. If they match in /etc/passwd, you can use them both.

Quote:
And another thing, is there a way to edit the account number?(assuming its unused)
Yes. /etc/passwd
A line looks this way
Code:
username:x:UID:GID::/home/username:/bin/bash
where
UID is user ID, GID is group ID (groups are configured in /etc/group). If you change UID in /etc/passwd, the user will chave user ID changed.
 
Old 06-20-2004, 05:54 AM   #7
Amethye
LQ Newbie
 
Registered: Jun 2004
Distribution: mandrake 10
Posts: 3

Original Poster
Rep: Reputation: 0
I solved the issue, turns out GNOME wanted permission to write its settings to /tmp/gconfd-admin, but the ownership was set to uid 501(uid of my old accout with the same name from a previous install), while mine was 502.
Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Will these things work on Ubuntu? cmlal Ubuntu 4 11-09-2005 11:09 AM
Getting Things to work TheReven Linux - Newbie 3 05-22-2005 08:41 PM
USB: some things work, some don't pconrad Linux - Hardware 1 09-11-2004 12:00 PM
Getting things to work... GhettoSmurf!? Mandriva 3 06-26-2004 11:20 PM
Some things missing in Gnome 2.6? sigma957 Slackware 10 05-25-2004 11:17 AM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration