LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2012, 07:56 PM   #1
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Rep: Reputation: Disabled
Can't get compiz to work in Ubuntu 11.10


I really never got this issue resolved. I seem to not be able to get compiz to work with my Ubuntu 11.10. I have gone to the compiz manager and tried to just get wobbly windows (this required shutting of snapping windows first), but nothing happens. I also tried to use just plane animation like water effect (cont/super) and nothing happens. The checked boxes check, but nothing happens. I would like to enable some cool desktop effects. I'm using a intel i7 processor, and a visiontek radeon hd 4670 video card.
Thank you for you time
Jonnynitro138
 
Old 04-05-2012, 08:42 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Are you sure compiz is running? What's the output of 'ps ax | grep compiz' ?

Adam
 
Old 04-05-2012, 09:58 PM   #3
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Original Poster
Rep: Reputation: Disabled
reply to Mr. Mark

I think I am not using the ps ax grep compiz properly. I get a error message:
ps ax grep compiz
ERROR: Process ID list syntax error.
********* simple selection ********* ********* selection by list *********
-A all processes -C by command name
-N negate selection -G by real group ID (supports names)
-a all w/ tty except session leaders -U by real user ID (supports names)
-d all except session leaders -g by session OR by effective group name
-e all processes -p by process ID
T all processes on this terminal -s processes in the sessions given
a all w/ tty, including other users -t by tty
g OBSOLETE -- DO NOT USE -u by effective user ID (supports names)
r only running processes U processes for specified users
x processes w/o controlling ttys t by tty
*********** output format ********** *********** long options ***********
-o,o user-defined -f full --Group --User --pid --cols --ppid
-j,j job control s signal --group --user --sid --rows --info
-O,O preloaded -o v virtual memory --cumulative --format --deselect
-l,l long u user-oriented --sort --tty --forest --version
-F extra full X registers --heading --no-heading --context
********* misc options *********
-V,V show version L list format codes f ASCII art forest
-m,m,-L,-T,H threads S children in sum -y change -l format
-M,Z security data c true command name -c scheduling class
-w,w wide output n numeric WCHAN,UID -H process hierarchy
And this happens if I try it in root as well.
Thank you
Jonnynitro138
 
Old 04-05-2012, 10:47 PM   #4
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 672

Rep: Reputation: 94
Code:
ps ax | grep compiz
There's | between ps ax and grep compiz. http://www.wolframalpha.com/input/?i=|
 
Old 04-05-2012, 11:43 PM   #5
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Original Poster
Rep: Reputation: Disabled
reply to Mr. Mark

Thank you for the tutorial. This is what the terminal told me:
2065 pts/0 S+ 0:00 grep --color=auto compiz

Thank you
Jonnynitro138
 
Old 04-06-2012, 09:18 AM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
So then, no, compiz is not running. It should be enabled by default in Ubuntu 11.10, so I'm not sure why it's not running for you. Bring up a terminal and run:

Code:
compiz --replace &
See if compiz starts. If not, show us the error(s) you receive.
 
Old 04-07-2012, 11:45 AM   #7
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Original Poster
Rep: Reputation: Disabled
reply to Adamk75

Adam,

Sorry for the delay, I had school stuff to focus on. This is what happened after I put in "compiz -- replace &"

~$ compiz (core) - Error: Couldn't load plugin 'replace'
compiz (core) - Error: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.


Thank you
Jonnynitro138
 
Old 04-07-2012, 03:09 PM   #8
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Please use the code tags when posting outputs, check out the BBCodes.
Could you post the output for:
Code:
dpkg -l | grep compiz
And also the output for:
Code:
dpkg -l | grep fusion
Regards
 
Old 04-07-2012, 03:21 PM   #9
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: LinuxMint 18
Posts: 739

Rep: Reputation: 179Reputation: 179
Quote:
Originally Posted by jonnynitro138 View Post
Adam,

Sorry for the delay, I had school stuff to focus on. This is what happened after I put in "compiz -- replace &"

~$ compiz (core) - Error: Couldn't load plugin 'replace'
compiz (core) - Error: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.


Thank you
Jonnynitro138
You have a space between the -- and the word replace. You need to use --replace without the space between -- and the word
 
Old 04-07-2012, 03:56 PM   #10
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Original Poster
Rep: Reputation: Disabled
reply to reply

Sweet thanks I now have compiz working. Phew
So now my question is how do you enable the desktop cube. I tried to enable it by checking the box and disabling the desktop wall, then I enabled cube rotation but nothing is happening.
Thank you
Jonnynitro138
 
Old 04-07-2012, 04:39 PM   #11
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Original Poster
Rep: Reputation: Disabled
Solved

Thank you all for your great support I really appreciate the help that you all have givin to me
Jonnynitro138
 
Old 04-07-2012, 05:13 PM   #12
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Quote:
Originally Posted by jonnynitro138 View Post
Thank you all for your great support I really appreciate the help that you all have givin to me
Jonnynitro138
Well it didn't work on mine so I hope yours breaks soon!

Lol just kidding
It doesnt work on mine because my graphic card is old. I am even surprised Unity is working at all.
I just upgraded last night from Ubuntu 10.04LTS to 12.04LTS Beta. Compiz was working in 10.04 but in this beta release of 12.04 is not working. I tried Gnome Shell and doesnt display correctly neither.
I knew this was going to be problematic but I was curious about the new GUI, and like they said "Curiosity killed the cat!"

So it will be Unity 2D for me until my computer dies in few more months.

Good luck to you all!

Last edited by TroN-0074; 04-07-2012 at 05:14 PM.
 
Old 04-07-2012, 05:17 PM   #13
jonnynitro138
Member
 
Registered: Jul 2011
Location: tallahasee
Posts: 253

Original Poster
Rep: Reputation: Disabled
One more question if possible

How do I get compiz to start up automatically upon start up?
Thanks
Jonnynitro138
PS how is ubuntu 12.04?
 
Old 04-07-2012, 05:27 PM   #14
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Quote:
Originally Posted by jonnynitro138 View Post
Jonnynitro138
PS how is ubuntu 12.04?
Well I just upgraded so I havent have the chance to play around with it. I do have sound and video and I have the latest applications like the latest VLC with blue ray support and transmission torrent with support for magnetic files wich is sweet, so all the applications I had installed are there but the latest releases.

the release is Beta though and is not going to be out officially until the end of April so few things might not work correctly you should aware of that if you decide to upgrade here are the steps.
Quote:
To upgrade from Ubuntu 11.10 or Ubuntu 10.04 LTS on a desktop system, press Alt+F2 and type in "update-manager -d" (without the quotes) into the command box. Update Manager should open up and tell you: New distribution release '12.04' is available. Click Upgrade and follow the on-screen instructions.
I grabed that from this link https://wiki.ubuntu.com/PrecisePango...Overview/Beta2

Good luck to you!
 
Old 06-26-2012, 09:24 AM   #15
pakito15191
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
Any idea on how to make Compiz start automatically?

Tried to add this code to startup programs but it made Unity not to start at all:

Code:
sleep 3; compiz --replace
I get this from suggested script:

Code:
 ps ax | grep compiz
 1807 ?        Sl     0:32 compiz
 1876 ?        Ss     0:00 /bin/sh -c /usr/bin/compiz-decorator
 2689 pts/0    S+     0:00 grep --color=auto compiz
I'm not sure if that means that compiz is working or not. Some features are working (woobly windows), thought the PERSONALIZED edge bindings and their actions do not work at all. They work normally if I use:
Code:
compiz --replace
NOTE: The actions associated to the edge bindings work perfectly, as one (top left) is associated to the same action as 'Super + W'. If I press the key combination, it works perfectly fine, if I touch the edge, it doesn't work at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] does compiz work in ubuntu 11.10 jonnynitro138 Linux - Newbie 6 03-01-2012 04:20 PM
Will Compiz work on Ubuntu 10.04? rreyes3000 Linux - Newbie 2 03-29-2010 05:47 PM
Skydome background doesn't work with compiz/gnome unless I use the compiz fusion icon The_Trooper Linux - Software 1 07-21-2008 02:08 PM
Compiz will not work on ubuntu 8.04 with 9600 gso running nvidia-glx latest version tekgek Linux - Newbie 4 06-16-2008 09:08 PM
Compiz Fusion will work in SUSE 10.3 but not in Ubuntu 7.10 (lag) Jason21 Linux - Newbie 1 10-29-2007 08:15 PM


All times are GMT -5. The time now is 04:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration