LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2006, 03:25 PM   #1
tekmann33
Member
 
Registered: Nov 2006
Posts: 188

Rep: Reputation: 30
Can't get apache "It works" page to come up


I have installed apache and i am able to start the apache process and get the "It works" page to come up on local host. However, when I enter the IP of the machine running Apache from a different host, the browser just hangs or quits altogether.


The server is running on a private network, and the machine accessing the server is also on this private network.


The IP address of my apache server is : 10.3.0.99


I made the following changes to my httpd.conf file:

ServerName 10.3.0.99

And that is really it. The server is listening on port 80

Listen 80

I restarted the process after the change and could not get it to come up on the remote machine that resides on the same 10.3.0.X network.

I have only configured apache once before and did not have a problem, so let me apologize if I am forgetting something basic.

Any help would be appreciated.
 
Old 12-26-2006, 03:45 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Looks like you probably have a firewall blocking access. Do an "iptables -L" on the machine running A[ache and see if port 80 is being blocked.
 
Old 12-26-2006, 04:02 PM   #3
tekmann33
Member
 
Registered: Nov 2006
Posts: 188

Original Poster
Rep: Reputation: 30
A firewall shouldn't be the issue....should it?

I mean, the Apache Server and my remote machine are all on the same network behind a firewall. My IP for the server and the remote machine are:

Apache: 10.3.0.99
Remote machine: 10.3.0.210
 
Old 12-26-2006, 04:04 PM   #4
tekmann33
Member
 
Registered: Nov 2006
Posts: 188

Original Poster
Rep: Reputation: 30
I take what I said back....

I see what you mean. I am running Fedora Core six when before I was running Red hat 9. With Red Hat 9, I was able to access the web server without a problem. \

Fedora Core 6 has additional security.
 
Old 12-26-2006, 04:08 PM   #5
tekmann33
Member
 
Registered: Nov 2006
Posts: 188

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by btmiller
Looks like you probably have a firewall blocking access. Do an "iptables -L" on the machine running A[ache and see if port 80 is being blocked.

Here is my iptable output

[root@BriansFC apache2]# /sbin/iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
RH-Firewall-1-INPUT all -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination
RH-Firewall-1-INPUT all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain RH-Firewall-1-INPUT (2 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere
ACCEPT icmp -- anywhere anywhere icmp any
ACCEPT esp -- anywhere anywhere
ACCEPT ah -- anywhere anywhere
ACCEPT udp -- anywhere 224.0.0.251 udp dpt:mdns
ACCEPT udp -- anywhere anywhere udp dpt:ipp
ACCEPT tcp -- anywhere anywhere tcp dpt:ipp
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

I could be wrong, but it looks like this should accept port 80 requests.

Last edited by tekmann33; 12-26-2006 at 04:28 PM.
 
Old 12-26-2006, 04:36 PM   #6
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
Did you enable SELinux when building the machine?
Could be a policy problem.

-Kristijan
 
Old 12-26-2006, 04:45 PM   #7
tekmann33
Member
 
Registered: Nov 2006
Posts: 188

Original Poster
Rep: Reputation: 30
In order to get apache to run, I disabled it.
 
Old 12-26-2006, 05:58 PM   #8
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
I don't see an accept http rule in your firewall -- just ssh,ipp, and mdns. Go into the firewall config and tell it to allow http traffic. SELinux should not disrupt static HTML serving but if you have dynamic content (cgi and PHP scripts) it can be a problem unless you disable it or tweak the SELinux rules to allow them to operate.
 
Old 01-05-2007, 04:23 PM   #9
tekmann33
Member
 
Registered: Nov 2006
Posts: 188

Original Poster
Rep: Reputation: 30
That was it. Works fine now. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suggestion: for "subscribed threads" & "top of page" buttons Old_Fogie LQ Suggestions & Feedback 7 07-10-2006 06:10 PM
Suse 10.1 - Apache "Access Forbidden!" on any page Danny-T Linux - Networking 4 06-01-2006 01:31 AM
Apache Server only displaying "Test" page. Fedora Core 4 Tear Syden Linux - Newbie 2 03-17-2006 08:40 PM
my web browser "mozilla fire fox" isn't rendering the page, rather opening the page amolgupta Linux - Software 2 07-26-2005 01:41 AM
Can't make Apache display anything diferent than the "test page" johann519 Linux - Networking 7 01-21-2004 07:54 PM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration