LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2013, 07:22 AM   #1
yzT!
Member
 
Registered: Jan 2013
Distribution: Debian
Posts: 168

Rep: Reputation: 2
Can't fix Pulseaudio muting sound at boot.


There is a known "bug" (or maybe it's on purpose?) with Pulseaudio muting the sound every time the system boots up. Not sure whether it's DE independent or just in Gnome.

Apparently, the problem is that alsa-utils was removed from Pulseaudio, so a fast fix is to install alsa back and it works fine. However, I have had a bad time setting up Skype with alsa, so I don't want to follow this method.

Using either pacmd set-sink-mute 1 false or pacmd set-sink-volume 1 100 works once the system is booted, so I tried to put any of these commands in a script which runs at boot time, but neither of them it's working. The working output device is on index 1.

Firstly, I put them in rc.local, but Pulseaudio daemon is user specific, in fact, running pacmd as root says "Daemon not responding". Then, I tried to add them to crontab using @reboot, but no luck.

What else can I do?
 
Old 11-20-2013, 07:37 AM   #2
TheStarLion
Member
 
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Rep: Reputation: 41
Well as long as trying to install the alsa-utils package doesn't ask you to remove any parts of PA, re-install it and tell Alsa to use Pulse. Then when setting up Skype, put it through Pulse as per usual and it should be fine.
 
Old 11-20-2013, 07:55 AM   #3
yzT!
Member
 
Registered: Jan 2013
Distribution: Debian
Posts: 168

Original Poster
Rep: Reputation: 2
Weird, just installed alsa again and Skype settings didn't change. So I have both things working now, sound enabled by default and Skype.
 
Old 11-20-2013, 08:38 AM   #4
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
yzT!

to save me searching,
-- can you provide a link to the known bug please.
 
Old 11-20-2013, 09:28 AM   #5
yzT!
Member
 
Registered: Jan 2013
Distribution: Debian
Posts: 168

Original Poster
Rep: Reputation: 2
Just found another fix while searching the bug report for you xD

The line that causes the problem is load-module module-device-restore in the file /etc/pulse/defaults.pa. Comment it out.

Just search for "Pulseaudio mute startup" and you will have tons of results reporting this issue, but generally in all of them the fix is to install alsa-utils. However in this one https://bugs.launchpad.net/ubuntu/+s...io/+bug/592016 they talk about the fix I stated above.
 
1 members found this post helpful.
Old 11-20-2013, 05:01 PM   #6
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
Hi

thanks for the link.

This should help a lot of people.

1) Don't forget to mention that /etc/pulse/defaults.pa is a system wide config and newbies will need sudo (or root powers) to edit

b) those who copied it to their home folder only need to edit their home file.

###########
Moderators
##########

Maybe you can make this a sticky until PA is fixed?

cheers


########
trivia
#######

inputting slackware (as example) with other search terms yields no meaningful hits but I still think this is worthy of a sticky status request
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Removed pulseaudio, no sound... DiskChris Linux - Desktop 3 12-29-2012 08:15 AM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 07:30 AM
[SOLVED] Sound not Muting when Headset plugged in... Asus Delusions Ubuntu 6 07-24-2009 11:04 PM
no sound after pulseaudio update russianwizard Linux - Software 7 03-19-2009 01:00 PM
LXer: How To Fix The Sound Issues Between Skype 2.0 And Pulseaudio On Fedora 9 LXer Syndicated Linux News 0 06-02-2008 06:11 AM


All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration