LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2004, 01:33 AM   #1
nefariousmonkey
LQ Newbie
 
Registered: Oct 2004
Location: Flint, Mi/Houghton, Mi (home/college)
Distribution: Fedora Core 2
Posts: 3

Rep: Reputation: 0
can't find FAT32 partition


Hi, I'm a complete newbie to Linux, obviously. I installed Fedora Core 2 a couple days ago and my friend said that it would automatically recognize my FAT32 partition from Windows XP that has all my music and movies on it, but it doesn't. I was hoping I could get some help getting Fedora to recognize that partition.

Brian.
 
Old 10-14-2004, 02:47 AM   #2
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: CLFS
Posts: 515

Rep: Reputation: 36
Well,the system can't just automatically mount the vfat partition.You've got to do the following:
edit the file /etc/fstab by adding these lines at the end:

/dev/hdx /mnt/win vfat defaults 0 0

where the hdx is the fat partition on your system.You can identify it by the command fdisk -a.It will most probably be hda1 or hda5.
Now make directory win in the /mnt folder.Now type mount /dev/hdx at the console.Now you can access your fat partition by going to /mnt/win.
 
Old 10-14-2004, 03:29 AM   #3
nefariousmonkey
LQ Newbie
 
Registered: Oct 2004
Location: Flint, Mi/Houghton, Mi (home/college)
Distribution: Fedora Core 2
Posts: 3

Original Poster
Rep: Reputation: 0
Okay. I couldn't get fdisk -a to work, but I used the disk manager and it said the partition was hdb5... so I did all that but when I typed "mount /dev/hdb5" into the console it told me "mount: can't find /dev/hdb5 in /etc/fstab or /etc/mtab" . So I tried typing in "mount /dev/hdb5/mnt/win" and it told me "mount: mount point vfat does not exist". When I'm doing this, does it matter whether I'm currently in /mnt or /mnt/win when I try to mount it to that location?

Brian.
 
Old 10-14-2004, 03:44 AM   #4
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: CLFS
Posts: 515

Rep: Reputation: 36
Certainly not.You can execute the command from anywhere.And the sysntax that you are using is incorrect.You can't type mount /dev/hdb5/mnt/win.
Did you make the appropriate changes to the fstab file?make sure that you edited the fstab right. You must specify each option under the correct heading.What exactly did you do?
 
Old 10-14-2004, 04:04 AM   #5
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: CLFS
Posts: 515

Rep: Reputation: 36
And sorry for the wrong fdisk command.It's "fdisk -ls".It lists the device name and the partition.
And the fstab needs to be in this order:
Code:
# filesystem   mount-point    fs-type    options     dump    fsck-order
where you list your options in the order:

/dev/hdb5 /mnt/win vfat defaults 0 0

This should do it alright.
 
Old 10-14-2004, 05:28 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
You need to create a directory to use as a mount point
mkdir /mnt/win

For read / write for all the /etc/fstab entry should be:

/dev/hdb5 /mnt/win vfat user,umask=000 0 0
 
Old 10-14-2004, 12:17 PM   #7
nefariousmonkey
LQ Newbie
 
Registered: Oct 2004
Location: Flint, Mi/Houghton, Mi (home/college)
Distribution: Fedora Core 2
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks guys. I finally get it to work. I was trying to change fstab in gedit because I didn't realize that Linux came with Vim. I decided to try seeing if it was the editor I was using and if Linux cane with Vim, and sure enough, that's what it was and Linux does. I edited it in Vim and saved it then tried mounting it and it worked. Once again, thank you guys. Your help is very much appreciated.

Brian.
 
Old 11-22-2004, 06:34 PM   #8
Proxy Hoar
LQ Newbie
 
Registered: Nov 2004
Location: Cape Cod, Mass
Distribution: Fedora Core 3
Posts: 2

Rep: Reputation: 0
Okay, I have the same problem, but i aim using FC3, XFce WM. I tried doing what you said in the begining, but when i open /ect/fstab with gEdit, nothgin is there. what do i do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
accessing a linux partition from a fat32 partition? abtimoteo Ubuntu 4 09-19-2005 11:41 PM
Partition mounting/KDE errors after creating Fat32 Partition BertBert Linux - General 1 07-07-2004 11:59 AM
Formating a FAT32 partition, putting the partition correctly into FSTAB, and more. squall14716 Linux - General 14 10-27-2003 11:16 PM
fat32 partition InsaneBob Linux - Software 8 08-10-2003 11:36 PM


All times are GMT -5. The time now is 07:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration