LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2005, 09:32 AM   #1
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Rep: Reputation: 0
Can't find cdrom/dvd in Suse 9.3


Hi,

I installed Suse 9.3 today and I'm not able to access my DVD player. I used a network installation and couldn't get it to work, it stopped at hardware detection. After googleing (sp?) a bit for solutions I decided to use "hdd-ide-scsi" as boot parameter. That did the trick, Suse is running but now I can't access my DVD player. Yast reports that no CD/DVD device can be found.

My /etc/fstab looks like this:

/dev/sda4 / reiserfs acl,user_xattr 1 1
/dev/hda6 /data1 auto noauto,user 0 0
/dev/hda7 /data2 auto noauto,user 0 0
/dev/hda1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda1 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda5 /windows/E vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda5 /windows/F vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda6 /windows/G vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda7 /windows/H vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda8 /windows/I ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8 swap swap pri=42 0 0
/dev/sda3 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0


Can anyone offer some advice?

Thanks,

Peter Geraedts
 
Old 08-21-2005, 01:09 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
I have a Liteon Combo cd/dvd drive. The three functions (cd-rom, cdrecord, and dvd) are symlinked to /dev/hdc.

Here's an excerpt from my fstab:

/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/cdrecorder /media/cdrecorder auto rw,noauto,user,exec 0 0
/dev/dvd /media/dvd auto ro,noauto,user,exec 0 0
 
Old 08-21-2005, 01:15 PM   #3
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
In my /etc/fstab I have a line,as follows, for my dvd-ram (slot-load) on my Ferrari laptop:

/dev/dvdram /media/dvdram subfs noauto,fs=cdffs,ro,procuid,nosuid,dodev,exec,iocharset=utf8 0 0

IIRC, I had to mount (using console as root) and I used vim to add the line to my fstab.

I believe that I will have to change 'ro' to 'rw' when I want to burn something!

HTH
 
Old 08-21-2005, 04:05 PM   #4
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for your replies.

I tried "dmesg | more" in the console as root and got this (among a lot of other stuff):

Code:
Probing IDE interface ide1...
hdd: ASUS DVD-E616P2, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
So Suse recognizes my DVD player but I still don't know how to get it to work.

Peter Geraedts
 
Old 08-21-2005, 04:26 PM   #5
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Does it appear on your desktop -> My Computer [media:/ - Konqueror (mine doesn't until a CD or DVD is inserted)]?

Does it appear in your /media directory [click on the HOME icon in the quickstart bar] (mine does - even if it is empty)?
 
Old 08-22-2005, 02:32 AM   #6
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
There is a /media/dvd directory, but it's empty even if there is a DVD in the DVD player. If I double click the DVD icon under my computer it says that it can't display the contents (after I mounted it as root).

Peter Geraedts
 
Old 08-22-2005, 09:49 AM   #7
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Okay, if you right click on the dvd icon on 'My Computer' (once a cd is recognized) what are thw permissions?

If I put in an audio cd I get the following Meta Info:

Base URL: audiocd:/?device=/dev/hdc
Device Node: /dev/hdc

What do you get?

Incidentally did you edit your /etc/fstab file yet? And if so, what did you enter?
 
Old 08-22-2005, 10:28 AM   #8
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Hi Minrich,

I'm sorry I didn't mention this but I edited my /etc/fstab to include the dvd player and this is how it looks now:

Code:
/dev/sda4            /                    reiserfs   acl,user_xattr        1 1
/dev/hda6            /data1               auto       noauto,user           0 0
/dev/hda7            /data2               auto       noauto,user           0 0
/dev/hda1            /windows/C           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/sda1            /windows/D           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/hda5            /windows/E           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/sda5            /windows/F           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/sda6            /windows/G           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/sda7            /windows/H           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/sda8            /windows/I           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8            swap                 swap       pri=42                0 0
/dev/sda3            swap                 swap       pri=42                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
proc                 /proc                proc       defaults              0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
sysfs                /sys                 sysfs      noauto                0 0
/dev/fd0             /media/floppy        subfs      noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/dvd 	     /media/dvd           subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
After I mount /dev/dvd (as root, something to do with permissions?) I can click on the DVD icon, but I get a message that the contents of the folder can't be displayed. If I check properties it says "type: folder", "contents: unreadable", "location: computer: ///", "volume: DVD", "freespace: 0 bytes". I'm using GNOME as a desktop, so it probably looks a bit different from what you're seeing in KDE.

Peter Geraedts
 
Old 08-23-2005, 03:10 AM   #9
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Added "users" to the dvd line in /etc/fstab so I can mount it without being root. The line now looks like this:

Code:
/dev/dvd 	     /media/dvd           subfs      noauto,fs=cdfss,users,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
But I still can't read it

Peter Geraedts
 
Old 08-23-2005, 03:30 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,523

Rep: Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502
What is the output of:
Code:
ls -l /dev/dvd
It must be a symlink to /dev/hdd according to dmesg. If not run:
Code:
ln -s /dev/hdd /dev/dvd
 
Old 08-23-2005, 04:31 AM   #11
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for your reply.

Quote:
Originally posted by bathory
What is the output of:
Code:
ls -l /dev/dvd
The output is:

Code:
lrwxrwxrwx  1 root root 10 2005-08-21 18:54 /dev/dvd -> /dev/cdrom
Quote:
Originally posted by bathory
It must be a symlink to /dev/hdd according to dmesg. If not run:
Code:
ln -s /dev/hdd /dev/dvd
If I try this in the console I get a message that the file already exists.

Peter Geraedts
 
Old 08-23-2005, 05:29 AM   #12
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,523

Rep: Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502
So:
Code:
rm /dev/dvd
ln -s /dev/hdd /dev/dvd
 
Old 08-23-2005, 05:47 AM   #13
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Still the same, "folder contents couldn't be displayed".

I think something goes wrong in an earlier stage. If I try "dmesg | more" I get a lot of gibberish and some lines saying "subfs: unsuccessful attempt to mount media (256)".

Peter Geraedts
 
Old 08-23-2005, 06:19 AM   #14
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,523

Rep: Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502Reputation: 1502
Quote:
subfs: unsuccessful attempt to mount media (256)
That means that there is no disc inserted, or the disc cannot be read.
Try to mount it manually (mount /dev/dvd), or use another disc and see what happens.
Also that "hdd-ide-scsi' parameter is not needed since it's a cd/dvd player. It's used for atapi cd/dvd writers when using a 2.4.x kernel.

Regards
 
Old 08-23-2005, 06:35 AM   #15
Peter Geraedts
LQ Newbie
 
Registered: Apr 2004
Posts: 11

Original Poster
Rep: Reputation: 0
I tried a couple of cd's/dvd's but I can't access them. Do you know how to get rid of the "hdd=ide-scsi" boot parameter? I can see it is still used when I boot (I found it in /var/logboot.msg) but I don't know how to disable it.

Peter Geraedts
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.2 Installation DVD can't find itself hanasi Linux - Newbie 2 07-06-2005 03:54 PM
[Suse 9.3] Automount cdrom/dvd failed PatrickV SUSE / openSUSE 1 04-19-2005 05:50 AM
9.1 install, boot from cdrom, select source as cdrom, Can't find disk jake555 Slackware 1 10-30-2003 11:34 AM
Can't find CDROM tfletcher Linux - General 2 11-29-2001 10:08 AM
cant find cdrom? prodigius Linux - Software 1 10-27-2001 08:47 AM


All times are GMT -5. The time now is 09:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration