LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2010, 01:26 PM   #1
sllinux
Member
 
Registered: Feb 2009
Posts: 31

Rep: Reputation: 15
Can't find a library


I am trying to get a 32-bit executable to run on 64-bit Ubuntu.

I had to install multilib, and then when I ran the executable, I got this error:

Code:
./x86/bin/target_base_mac: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory
So I installed libxml2, but I still get that same error. The file does exist:
Code:
test@olds:~/simulation$ ls -lrt /usr/lib/libxml2.so.2
lrwxrwxrwx 1 root root 16 2010-03-10 13:05 /usr/lib/libxml2.so.2 -> libxml2.so.2.7.5
 
Old 03-10-2010, 01:36 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 164Reputation: 164
What do you get when you type:
Code:
ls -lrt /usr/lib/libxml2.so.2.7.5
Have you run ldconfig?
 
Old 03-10-2010, 02:10 PM   #3
sllinux
Member
 
Registered: Feb 2009
Posts: 31

Original Poster
Rep: Reputation: 15
That file exists too:
Code:
test@olds:~/simulation$ ls -lrt /usr/lib/libxml2.so.2.7.5
-rw-r--r-- 1 root root 1372312 2010-01-10 05:46 /usr/lib/libxml2.so.2.7.5
I don't know anything about ldconfig, but I ran it, and then I re-ran the executable, and I still get the same error.
 
Old 03-11-2010, 10:30 AM   #4
sllinux
Member
 
Registered: Feb 2009
Posts: 31

Original Poster
Rep: Reputation: 15
Finally got it working. Turns out I did not need multilib, that didn't help. I also didn't need to reinstall libxml2, that was already on the system (although it was the 64-bit version so it wouldn't work). I just needed to install ia32-libs, and now everything's working!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
c++ compiler doesn't find library Y0jiMb0 Linux - General 7 12-27-2010 06:27 AM
install from source - unable to find the libcurl library - but library is installed pulper Linux - Newbie 2 02-23-2009 10:00 PM
cant find a library alaios Linux - Software 2 01-31-2006 05:05 PM
cant find library buffed317 Linux - Software 5 02-21-2005 10:32 PM
How To Find Out What A Library Does? nysb Linux - Software 1 05-27-2004 11:46 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration