LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2014, 03:54 PM   #1
nekocat
LQ Newbie
 
Registered: Mar 2014
Location: Las Vegas, Nevada, USA
Distribution: Debian testing
Posts: 10

Rep: Reputation: Disabled
can't erase or load music on music player


Just a small problem here: I have a basic mp3 player that loaded up just like any other usb item, but now, when I try to load any music, I get this error message:not authorized to perform operation. It's an RCA Lyra, and it shows up in the side of pcmanfm, but I can't do anything with it when I click on it. And going to root in pcmanfm doesn't help; for some reason, it vanishes from the menu. I checked mount all media in pcmanfm, and I've tried to find an option in the settings panel, but no luck. Can anyone tell me why my computer seems to think I shouldn't use my mp3 player? (my music isn't that bad, honest!)

I'm using enlightenment 17 from jessie. on a minimal install. Before, I ran bodhilinux, but I switched to debian after I could no longer get the latest versions to install. The player worked under bodhi. I tried using the ls -l command on /media, and got this:

michelle@the-cathouse:/media$ ls -l
total 8
lrwxrwxrwx 1 root root 6 Jan 11 22:03 cdrom -> cdrom0
drwxrwxrwx 2 root root 4096 Feb 27 17:13 cdrom0
drwxrwxrwx 2 root root 4096 Feb 27 17:10 cdrom1
michelle@the-cathouse:/media$

This is what I got the first time. I went in pcmanfm under root permissions, changed the owner to michelle, and this is what I get running the command again.
michelle@the-cathouse:/media$ ls -l
total 8
lrwxrwxrwx 1 michelle michelle 6 Jan 11 22:03 cdrom -> cdrom0
drwxrwxrwx 2 michelle michelle 4096 Feb 27 17:13 cdrom0
drwxrwxrwx 2 michelle michelle 4096 Feb 27 17:10 cdrom1
michelle@the-cathouse:/media$

Even though it's changed permissions, it still won't let me access it. Using pcman under root, I can access the player, but only but going to media, and clicking on cdrom (which is interesting, since it's not a cdrom). However, it shows files which aren't on it, but were there just before the ones on the device now-(that I'm trying to erase).

When I try mounting the cdrom, I get this:michelle@the-cathouse:/media$ mount /media/cdrom
mount: block device /dev/sr1 is write-protected, mounting read-only
mount: no medium found on /dev/sr1
michelle@the-cathouse:/media$

I also see that it just says: USB connected, on the player screen itself. When Im accessing it from pcmanfm root, I can delete the files (the old ones), and add new, but it doesn't show the files that replaced the original files, and which shouldn't be there anyway. The present, and last files to be added, was an audio mp3 book; the files I want to replace that with are mp3 music files that were there before I took them off for the book. It doesn't seem to do anything, even though all the right message windows come up saying the operations are being carried out. And I can't unmount it through my account, and I can only reach the player on root through /media/cdrom.

I've never seen the player do this before, even under several distros, or earlier versions of bodhi. I hope this information helps.

rolypolycat
 
Old 03-05-2014, 04:01 PM   #2
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 921

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
Off hand, I'd say the filesystem was mounted as read-only.

What does the command `mount` return?
 
Old 03-05-2014, 04:24 PM   #3
nekocat
LQ Newbie
 
Registered: Mar 2014
Location: Las Vegas, Nevada, USA
Distribution: Debian testing
Posts: 10

Original Poster
Rep: Reputation: Disabled
just a plain mount command gives this:michelle@the-cathouse:~$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=218545,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=206084k,mode=755)
/dev/disk/by-uuid/9e6e8683-e4cb-4681-aaff-8ed0b9d1a1f7 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
pstore on /sys/fs/pstore type pstore (rw,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=828920k)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda6 on /home type ext4 (rw,relatime,data=ordered)
/dev/sdb1 on /stuff type ext4 (rw,relatime,data=ordered)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
michelle@the-cathouse:~$

If there's supposed to be an entry for rca lyra, or usb, it doesn't show up in /media. Just the cdroms example above. I can't click on the device listing in the menu at all; it won't let me in normal pcmanfm, and the rca lyra entry doesn't show up in the root menu.
 
Old 03-05-2014, 04:47 PM   #4
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 921

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
OK! well, my guess was wrong.

Are there any controls in the RCA Lyra itself to set HOW it will be mounted? Some USB devices annoyingly use a mode called "MSC". If there's a way NOT to use that, then the player should mount like a normal external drive.

If the only option is mounting as MSC, you might need to go through an application that talks to MSC devices.

Also, right after you plug the player in, what does

Code:
dmesg | tail
show?
 
Old 03-05-2014, 05:54 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
you are going to have problems it you try to mount a usb mp3 music player as a cd
they are NOT 3inch flat silver disks

plug it in and see if and what it is recognized as

plug it in and run
Code:
lsusb
in that output will be the mp3 music player

also music players mount VERY differently than other things

do you have rythombox installed

you normally need to access then using a music player
or something like itunes
"GTK-pod" is a linux equivalent

Last edited by John VV; 03-05-2014 at 05:56 PM.
 
Old 03-05-2014, 07:12 PM   #6
nekocat
LQ Newbie
 
Registered: Mar 2014
Location: Las Vegas, Nevada, USA
Distribution: Debian testing
Posts: 10

Original Poster
Rep: Reputation: Disabled
I tried both suggestions. Here's the readout from both:

[13591.064137] usb 5-1: USB disconnect, device number 2
michelle@the-cathouse:~$ dmesg | tail
[13610.279119] sd 5:0:0:0: [sdc] Mode Sense: 38 00 00 00
[13610.287077] sd 5:0:0:0: [sdc] No Caching mode page found
[13610.287085] sd 5:0:0:0: [sdc] Assuming drive cache: write through
[13610.309108] sd 5:0:0:1: [sdd] Attached SCSI removable disk
[13610.335111] sd 5:0:0:0: [sdc] No Caching mode page found
[13610.335120] sd 5:0:0:0: [sdc] Assuming drive cache: write through
[13610.346112] sdc: sdc1
[13610.393079] sd 5:0:0:0: [sdc] No Caching mode page found
[13610.393088] sd 5:0:0:0: [sdc] Assuming drive cache: write through
[13610.393095] sd 5:0:0:0: [sdc] Attached SCSI removable disk
michelle@the-cathouse:~$


michelle@the-cathouse:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 069b:0713 Thomson, Inc.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
michelle@the-cathouse:~$

I recognise Thomson, Inc., as the maker-I believe-of the rca lyra. I never accessed the player before through any program other than pcmanfm. It just showed up in the bookmarks menu, and I worked with it like any other folder. That's why I'm puzzled by its present antics. I'm on Debian now, whereas before I used Bodhi linux and Xubuntu before that.

Added a new twist; now I don't even have to click on the lyra in the bookmarks menu. after a pause, the "not authorized" message shows up automatically.
 
Old 03-05-2014, 07:57 PM   #7
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 921

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
Try mounting it:

Code:
cd ~
mkdir ~/lyra
su -c 'mount /dev/sdc1 ./lyra'
If that works but you still can't access files on it, chown it to your normal user:

Code:
su -c 'chown -R your-username ./lyra'
su -c 'chmod -R 755 ./lyra'
and then try to muck around in there. If that works, a long term solution is to add yourself to the group that has permission to access external media. Are you having this problem with other external drives or is it only this device?
 
Old 03-05-2014, 09:03 PM   #8
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 276Reputation: 276Reputation: 276
How is the Lyra set - mtp or msc? It makes a difference.
 
Old 03-07-2014, 12:22 AM   #9
nekocat
LQ Newbie
 
Registered: Mar 2014
Location: Las Vegas, Nevada, USA
Distribution: Debian testing
Posts: 10

Original Poster
Rep: Reputation: Disabled
well, I finally got it to work, but only after some effort. I made the directory lyra, which it recognized. I changed ownership, and got a listing of files. However, when I deleted said files, they weren't really deleted in the .Trash-0 directory. I entered the trash directory, and found 2 directories there- files and info. deleted info- no problem. tried to delete the files in files dir. Instead of deleting, they doubled. I eventually went from 30 -155 files. Had to go in as root in the terminal and force delete them, otherwise the player complained there was no room. also found a SETTINGS.DAT file, whacked it, and the files could be deleted without them multiplying. Used pcmanfm as root, loaded my music, and can now enjoy my music.

So apparently, I'll have to manually delete the hidden files as root, since the system doesn't do it for me. But anyway, it's up and running, and I hope I can keep it that way. I saved this forum page for future reference, in case the little monster decides to act up again.

Thanks for all your help! I appreciate it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Play your Music on Linux with Music Player Daemon LXer Syndicated Linux News 0 03-03-2014 07:41 PM
my idea for getting MIDI music onto my music player newbiesforever General 2 01-27-2012 11:46 AM
[SOLVED] how to proceed to properly load Music CD's from dedicated partition to linux player texas.chef94 Linux - General 6 09-23-2011 11:12 AM
LXer: Encode and sync music to your portable music player in linux LXer Syndicated Linux News 0 09-15-2009 09:40 AM
LXer: Exaile Music Player - Music Player for GTK+ in openSUSE LXer Syndicated Linux News 0 08-31-2008 01:50 AM


All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration