LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2011, 09:10 PM   #1
ubusnake
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Rep: Reputation: Disabled
Unhappy Can't disable cups daemon on Ubuntu 10.04


Fresh install of Ubuntu 10.04 x86_64.

I've tried to disable cups service from sysvinit scripts, but why cups is still starting with the computer?

Code:
root@computer:/home/user# update-rc.d cups disable
update-rc.d: warning: cups start runlevel arguments (none) do not match LSB Default-Start values (2 3 4 5)
update-rc.d: warning: cups stop runlevel arguments (none) do not match LSB Default-Stop values (1)
 Disabling system startup links for /etc/init.d/cups ...
 Removing any system startup links for /etc/init.d/cups ...
   /etc/rc1.d/K80cups
   /etc/rc2.d/S50cups
   /etc/rc3.d/S50cups
   /etc/rc4.d/S50cups
   /etc/rc5.d/S50cups
 Adding system startup for /etc/init.d/cups ...
   /etc/rc1.d/K80cups -> ../init.d/cups
   /etc/rc2.d/K50cups -> ../init.d/cups
   /etc/rc3.d/K50cups -> ../init.d/cups
   /etc/rc4.d/K50cups -> ../init.d/cups
   /etc/rc5.d/K50cups -> ../init.d/cups
 
Old 06-09-2011, 09:26 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Ubuntu uses upstart, not sysvinit.

You need to edit /etc/init/cups.conf


and comment out the start on lines

Code:
start on (filesystem
          and (started dbus or runlevel [2345])
          and stopped udevtrigger)
 
Old 06-09-2011, 10:21 PM   #3
ubusnake
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by andrewthomas View Post
You need to edit /etc/init/cups.conf
Ubuntu 10.04 doesn't have /etc/init/cups.conf -file

Code:
user@computer:~$ ls -A1 /etc/init/
acpid.conf
alsa-mixer-save.conf
anacron.conf
apport.conf
atd.conf
console-setup.conf
control-alt-delete.conf
cron.conf
dbus.conf
dmesg.conf
failsafe-x.conf
gdm.conf
hostname.conf
hwclock.conf
hwclock-save.conf
irqbalance.conf
module-init-tools.conf
mountall.conf
mountall-net.conf
mountall-reboot.conf
mountall-shell.conf
mounted-dev.conf
mounted-tmp.conf
mounted-varrun.conf
networking.conf
network-interface.conf
network-interface-security.conf
network-manager.conf
plymouth.conf
plymouth-log.conf
plymouth-splash.conf
plymouth-stop.conf
procps.conf
rc.conf
rcS.conf
rc-sysinit.conf
rsyslog.conf
screen-cleanup.conf
tty1.conf
tty2.conf
tty3.conf
tty4.conf
tty5.conf
tty6.conf
udev.conf
udev-finish.conf
udevmonitor.conf
udevtrigger.conf
ufw.conf
upstart-udev-bridge.conf
ureadahead.conf
ureadahead-other.conf
What's next?
 
Old 06-09-2011, 11:00 PM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
http://ubuntuforums.org/showthread.p...t=cups+disable

You really should refrain from simultaneously posting the same question on different forums.

You could put the following script in /etc/rc.local

and then
Code:
sudo chmod +x /etc/rc.local

Code:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

service cups stop

exit 0

Last edited by andrewthomas; 06-09-2011 at 11:10 PM.
 
Old 06-10-2011, 09:06 AM   #5
ubusnake
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Your solution doesn't work, after reboot cups is still alive.

Code:
$ ls -l /etc/rc.local 
-rwxr-xr-x 1 root root 324 2011-06-10 15:57 /etc/rc.local
$
$ cat /etc/rc.local 
#!/bin/sh -e
service cups stop
exit 0
after reboot:
Code:
$ ps -ae | grep -i cups
 1301 ?        00:00:00 cupsd
I'd like to know what config/program forces cups to autostart?
?

Last edited by ubusnake; 06-10-2011 at 09:17 AM.
 
Old 06-10-2011, 11:37 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Ubuntu 10.04 is in a bit of a muddle with upstart at the moment.

Try this:
Install bum
System - Admin - Boot-Up Manager.
Click the Services tab
Find cups and deactivate it.
Click Apply.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS Daemon died drmjh Linux - Newbie 17 11-11-2005 10:43 AM
CUPS daemon died during initialization mcolodzin SUSE / openSUSE 1 03-11-2005 12:34 AM
CUPS daemon died during initialization kpachopoulos Linux - Newbie 2 09-15-2004 12:13 PM
cups Error "CUPS daemon has died" susesarus Linux - Software 2 08-21-2004 04:43 PM
CUPS daemon died during initialization engineerwell Linux - Software 1 07-07-2004 07:17 AM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration