LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-08-2006, 04:39 PM   #1
yinglcs
LQ Newbie
 
Registered: Jan 2006
Posts: 27

Rep: Reputation: 15
Can't create symbolic link on my external hard drive


I am running Fedora 4, and I have an external hard drive and I format it to 'vfat'.
But when I try to create an symbolic link, it said 'Operation not permitted'.

Any idea how to fix it please.
Thank you.


[yinglcs dir]$ ln -s tags t
ln: creating symbolic link `t' to `tags': Operation not permitted
 
Old 01-08-2006, 05:06 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
FAT doesn't support symbolic links. Unfortunately.
 
Old 01-08-2006, 05:08 PM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Is the external drive mounted to someplace on your directory structure?

Your example command would create a link to tags in the same directory as where tags is---is that what you intended?

Operation not permitted likely means that you dont have permissions. Try it as root (su, followed by the root password---or sudo command (you will be prompted for the root passwd))
 
Old 01-08-2006, 05:23 PM   #4
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
As far as I know the fat32 file system doesn't support symlinks so you won't be able to do that.
 
Old 01-08-2006, 06:46 PM   #5
yinglcs
LQ Newbie
 
Registered: Jan 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks for all the responses.

Can I change the type of file system of my partition so that it supports symoblic links? If yes, what type? and how can I change that?

Thank you.
 
Old 01-08-2006, 07:07 PM   #6
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
You can change the file system type, but do you need to access the file system with a non-Linux OS and have you backed up the data?

The steps are:

1 Confirm you're only using Linux to access this drive
2 Back up the data
3 Run mount to get the device id where the file system is
4 Unmount the file system
5 Find out what file system your Linux partitions are currently
using by looking in /etc/fstab. There will be a line something
like the following, note the file system type:

Code:
/dev/hda1   /  ext3   defaults   1   1
6 Create the new file system based on the following example,
substitute your values - I'm using ext3 because of the fstab
output above

Code:
mkfs.ext3 /dev/???? <- use the value from step 3
You may want to check the disk for errors first with

Code:
mkfs.ext3 -c /dev/???? <- use the value from step 3
7 Mount the file system
8 Restore the backed up data
9 Add the information to /etc/fstab so it's available automatically
10 Create symbolic links
 
Old 01-08-2006, 07:16 PM   #7
yinglcs
LQ Newbie
 
Registered: Jan 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks. But I have a question about step 6:

In step 6, you mention:
mkfs.ext3 /dev/???? <- use the value from step 3

Is that a command I type at the prompt? or I put that line in some configuration file?

When I run 'mkfs.ext3', it said 'Command not found'
[yinglcs@localhost etc]$ mkfs.ext3
bash: mkfs.ext3: command not found
 
Old 01-08-2006, 07:34 PM   #8
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
On a Slackware 10.2 system, the full command is /sbin/mkfs.ext3 and needs to be run by root at the command prompt. For example, to create an ext3 file system on partition /dev/hdb9 (with disk checking):

Code:
/sbin/mkfs.ext3 -c /dev/hdb9
 
Old 01-08-2006, 08:46 PM   #9
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Just don't use ext3, pick reiser or xfs instead :}



Cheers,
Tink
 
Old 01-09-2006, 12:19 PM   #10
yinglcs
LQ Newbie
 
Registered: Jan 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks. I have trouble in step #7. I get this error:
Thank for any other pointers.

Code:
[root@lxp-cheung scheung]# mount /dev/sda5
mount: wrong fs type, bad option, bad superblock on /dev/sda5,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
Code:
[root@lxp-cheung scheung]# /sbin/mkfs.ext3 /dev/sda5
mke2fs 1.37 (21-Mar-2005)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
6209536 inodes, 12408196 blocks
620409 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=12582912
379 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
        4096000, 7962624, 11239424

Writing inode tables: done
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 28 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.


[root@lxp-cheung scheung]# mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
/dev/proc on /proc type proc (rw)
/dev/sys on /sys type sysfs (rw)
/dev/devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda6 on /boot type ext3 (rw)
/dev/shm on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid2528) on /misc type autofs (rw,fd=4,pgrp=2528,minproto=2,maxproto=4)
automount(pid2574) on /net type autofs (rw,fd=4,pgrp=2574,minproto=2,maxproto=4)/dev/sda1 on /media/Windows type ntfs (rw,nosuid,nodev,_netdev,user=scheung)
[root@lxp-cheung scheung]# mount /dev/sda5
mount: wrong fs type, bad option, bad superblock on /dev/sda5,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

[root@lxp-cheung scheung]#
 
Old 01-09-2006, 12:48 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
What does the fstab entry for that drive look like?
And you don't want to use ext3, honest. Use xfs or
reiser, better performance, particularly with smaller
files (and less waste of space and faster disk-checks
in case you accidentally unplug it or hard-reboot the
box).


Cheers,
Tink

Last edited by Tinkster; 01-09-2006 at 12:49 PM.
 
Old 01-09-2006, 01:54 PM   #12
yinglcs
LQ Newbie
 
Registered: Jan 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Okay, what should I do now to switch from ext3 to 'xfs or
reiser'?

I did this:
Code:
 
mkfs.ext3 /dev/???? <- use the value from step 3
 
Old 01-09-2006, 02:25 PM   #13
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
mkreiserfs or mkfs.xfs

But what did you put in your fstab? :}



Cheers,
Tink
 
Old 01-09-2006, 02:45 PM   #14
yinglcs
LQ Newbie
 
Registered: Jan 2006
Posts: 27

Original Poster
Rep: Reputation: 15
In my /etc/fstab, I have:

Code:
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
Can I have "ext3" there but "xfs or
reiser" in my external hard drive?
 
Old 01-09-2006, 03:14 PM   #15
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
None of these are your external device, I don't think :}

Post the entire fstab?



Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
create a symbolic link in Mozilla drevil666 Linux - Software 2 07-04-2005 02:48 PM
How do I create a symbolic link so vi opens up vim? blk96gt Slackware 4 06-14-2004 04:53 AM
How do I create a symbolic link? Arenba Linux - Newbie 4 09-29-2003 11:40 AM
How to create a Symbolic Link? sikandar Linux - Software 6 09-09-2003 12:41 PM
how do I create a symbolic link? rdaves@earthlink.net Linux - Newbie 2 05-23-2001 02:28 PM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration