LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-26-2010, 03:48 AM   #1
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Rep: Reputation: 0
can't create files in windows partition.


Hi,
I have Suse 11.2 installed. In Dolphin file manager I can see read files in my windows partition.
But I cant create or delete any of these files as a user.
I opened Dolphin as root and changed the permission rights of this windows folder so that all groups and users can view and Modify content. But when I try to create something I get the message access denied, "check your permission rights".
What am I doing wrong?
And how can I change these permission right for my user in console mode?
Maybe that will work?
Thanks in advance.
 
Old 01-26-2010, 05:24 AM   #2
vrmartin2
Member
 
Registered: Dec 2009
Location: NE Ohio
Distribution: Open SUSE
Posts: 43

Rep: Reputation: 19
What type of file system is your windows partition? If it's NTFS, it will be read-only.
 
Old 01-26-2010, 05:52 AM   #3
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
I suspect you do not have the fuse ntfs-3g drivers what are required for writing to an NTFS partition. These drivers should be available off of rpmforge but I am not certain about how their installation goes on Suse.
 
1 members found this post helpful.
Old 01-26-2010, 08:23 AM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Please, open a terminal, type this command and paste the output here:

Code:
mount
This will tell us what type of partition you are using, and whether it's mounted via fuse (and hence using ntfs-3g) or the regular in-kernel ntfs driver. It's the first step before proceeding any further.
 
Old 01-26-2010, 08:24 AM   #5
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Original Poster
Rep: Reputation: 0
OK,
Now I have installed ntfs-3g and in 'system info' I can see that the filesystem of my windows partitions are called now "ntfs-3g".
but I still can't write to them?
Do I have to still activate ntfs-3g or something?
please help.
 
Old 01-26-2010, 08:26 AM   #6
korbes
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by i92guboj View Post
Please, open a terminal, type this command and paste the output here:

Code:
mount
This will tell us what type of partition you are using, and whether it's mounted via fuse (and hence using ntfs-3g) or the regular in-kernel ntfs driver. It's the first step before proceeding any further.
Ok this is the outcome of the command 'mount':
Code:
korbes@linux-b8pz:~> mount
/dev/sda6 on / type ext4 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda7 on /home type ext4 (rw,acl,user_xattr)
/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda2 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1 on /windows/E type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
/dev/sdb1 on /mnt/windows type fuseblk (rw,allow_other,blksize=4096)
korbes@linux-b8pz:~>
 
Old 01-26-2010, 08:29 AM   #7
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Code:
/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda2 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1 on /windows/E type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
This means that now your drives are using ntfs-3g, and they are mounted with the "rw" option (read/write), so they should be writable. Did you try to "touch" a new file as root on the said drives? For example:

Code:
touch /windows/C/foo
Should create an empty file called "foo" inside /windows/C/. Do it as the root user, so you can make sure that it's not a permissions issue, and see if it works.
 
Old 01-26-2010, 08:53 AM   #8
ongte
Member
 
Registered: Jun 2009
Location: Penang, Malaysia
Distribution: Mandriva, CentOS, Ubuntu
Posts: 456

Rep: Reputation: 69
Not familiar with Suse, so I'm not sure what default_permissions means. But this definitely is a permission problem. Can you show us your fstab?
Quote:
# cat /etc/fstab
You might need to specify a umask here.

Also might help showing us the permission in the Windows partition.
Quote:
# ls -l /windows/C
 
Old 01-26-2010, 08:56 AM   #9
vrmartin2
Member
 
Registered: Dec 2009
Location: NE Ohio
Distribution: Open SUSE
Posts: 43

Rep: Reputation: 19
And normally I would not be trying to write to the root of any file system. I'd try writing to some sub directory.

ALSO: ls -ld /windows/C would be helpful too. That would show the permissions on the top level directory (what I'm calling the root of the file system).

Last edited by vrmartin2; 01-26-2010 at 08:58 AM. Reason: Add more info
 
Old 01-26-2010, 09:11 AM   #10
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Originally Posted by ongte View Post
Not familiar with Suse, so I'm not sure what default_permissions means.
Well, the distro is nothing to do here. The mount options relate only to either the mount command itself or the chosen driver. In this case, this is ntfs-3g specific, so it's the ntfs-3g man page what you need to look at.

Setting an umask might help, setting the UID and GID as mount options might as well. I have not that much experience with Windows stuff these days so I can't really be sure.


Quote:
Originally Posted by vrmartin2 View Post
And normally I would not be trying to write to the root of any file system. I'd try writing to some sub directory.
Any particular reason? The root directory is not special in this regard, as long as you don't go randomly overwriting system files without any care.

Quote:
ALSO: ls -ld /windows/C would be helpful too. That would show the permissions on the top level directory (what I'm calling the root of the file system).
Note however that permissions might be completely emulated at mount time. At least this is what VFAT does (the FAT fs can't store the permissions, simple as that), I am not sure at all how ntfs-3g handles the things though I know that NTFS can handle ownerships and permissions. Reading this might help with this issue:

http://pagesperso-orange.fr/b.andre/permissions.html

The key point is to understand how this works in conjunction with umask, gid and uid.
 
Old 01-26-2010, 09:50 AM   #11
vrmartin2
Member
 
Registered: Dec 2009
Location: NE Ohio
Distribution: Open SUSE
Posts: 43

Rep: Reputation: 19
The root directory in all systems should be treated as special, meiner Meinung nach (imho). I don't like anyone but root to write to the top most directories of a partition and when I create immediate sub dirs I create them with root and then assign them to some standard user. And in windows in particular, over the years, they have tried to make the root directory special (especially the C drive) to avoid attacks. It's good practice, and I'd be surprised if the windows system isn't trying to enforce extra restrictions on the top level directory.

Last edited by vrmartin2; 01-26-2010 at 11:19 AM. Reason: spelling correction
 
Old 01-26-2010, 09:51 AM   #12
vrmartin2
Member
 
Registered: Dec 2009
Location: NE Ohio
Distribution: Open SUSE
Posts: 43

Rep: Reputation: 19
AND YES: VFAT is another story. It's wide open, but not NTFS.
 
Old 01-26-2010, 09:57 AM   #13
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You can configure how your NTFS partitions are mounted in YaST2's Disk module.

You can also edit your /etc/fstab file and add the "uid=<yourusername>,gid=<yourusername>". Also use the "dmask=" option and "fmask=" option to control the permissions.

Here is an example:
Code:
/dev/disk/by-id/ata-TOSHIBA_MK2049GSY_48CYT01OT-part1 /windows/C           ntfs-3g    users,noauto,uid=korbis,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
Because the NTFS filesystem doesn't use Linux permissions, you need to determine that when you mount it. All files and all directories will have the same permissions after mounting.

Last edited by jschiwal; 01-26-2010 at 09:58 AM.
 
Old 01-26-2010, 10:10 AM   #14
slightlystoopid
Member
 
Registered: Jan 2010
Distribution: Arch, Gentoo, FreeBSD
Posts: 64

Rep: Reputation: 16
setting uid and umask appropriately is essential to mount rw on ntfs.

My fstab entry looks like this:

Code:
UUID=62AC6C71AC6C41A1 /home/jschmidt/windows ntfs user,noauto,allow_other,uid=1000,gid=100,umask=22,noatime 0 2
aside: I've yet to get user mount privileges working on an ntfs-3g device, but once it's sudo mounted, you can certainly write so long as uid and umask are correct.

EDIT: jschiwal beat me

Last edited by slightlystoopid; 01-26-2010 at 10:11 AM.
 
Old 01-26-2010, 01:40 PM   #15
vrmartin2
Member
 
Registered: Dec 2009
Location: NE Ohio
Distribution: Open SUSE
Posts: 43

Rep: Reputation: 19
Samba

And if this happens to be a network drive (it's more likely something on your local system), Samba is much easier than all of this.
 
  


Reply

Tags
fstab, mount, permissions, umask, umount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to create a partition from Linux to Windows spartanz Linux - Newbie 2 12-19-2009 01:14 AM
Cannot create root partition on Windows 7 rcmonroig Linux - Newbie 5 11-12-2009 12:31 PM
create partition from linux where windows can be installeda sagsriv Linux - Newbie 1 03-24-2009 04:06 PM
unable to create or delete files on fat32 partition Barrett Linux - Newbie 9 12-21-2005 04:19 PM
How can I access files in my Windows 98 partition from my Linux partition, /w BASH? Fabyfakid Linux - Newbie 4 09-17-2004 11:05 PM


All times are GMT -5. The time now is 11:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration