LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2006, 04:23 AM   #1
mkalalms
LQ Newbie
 
Registered: May 2006
Posts: 7

Rep: Reputation: 0
Can't connect to localhost:8080


I've been all through the FAQs and docs... But nothing it suggests to do
helps me connect to the //localhost:8080. All I get is a popup window
saying "The connection was refused when attempting to contact
localhost:8080."
 
Old 05-24-2006, 04:27 AM   #2
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Hi

This sounds like a firewall issue. It would help if you show the distro you are using. But basically the port is beling blocked by either your firewall or your router. That is where I would look.

Hope this helps

Bob
 
Old 05-24-2006, 04:35 AM   #3
debulu
Member
 
Registered: May 2006
Location: India
Distribution: Redhat
Posts: 49

Rep: Reputation: 15
There are many reasons that lead to your problem. I m listing some of the checks that should be done.

1. Make sure that your apache is running and listenning on the port 8080... or some other port
check by giving 'apachectl -V' command .... Tells whether apache runs and the Apache Config file path also...
Check for the Listen directive in httpd.conf file
Something like this must be there
Listen <some ip address>:80
Make it to listen in port 8080 as you require it
2.check the apache configuration is alright or not(syntax) by giving apachectl -t command
3. restart apache server


I think it should work....
 
Old 05-24-2006, 05:52 AM   #4
mkalalms
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
For reason I don't know the command 'apachectl -V' is not know. I install tomcat on /usr/local/apache.
 
Old 05-24-2006, 06:27 AM   #5
debulu
Member
 
Registered: May 2006
Location: India
Distribution: Redhat
Posts: 49

Rep: Reputation: 15
ok then type /usr/local/apache/bin/apachectl -V

You will get the informations
 
Old 05-24-2006, 08:34 AM   #6
mkalalms
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
The apachectl command is not in /usr/local/apache/bin/apachectl -V . I got a command not found error
 
Old 05-24-2006, 09:30 AM   #7
towy71
Member
 
Registered: Oct 2003
Location: Carmarthen, Wales
Distribution: Ubuntu and whatever is new kid on the block
Posts: 70

Rep: Reputation: 18
You still haven't told us which distro you're using?
 
Old 05-24-2006, 09:48 AM   #8
mkalalms
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I don't know what distro is. I am running Suse 9.3 and install apache-tomcat-5.5.17.I hope one of the two is the answer to you question
 
Old 05-24-2006, 10:01 AM   #9
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 903
Blog Entries: 13

Rep: Reputation: 122Reputation: 122
Suse 9.3 is the distro.
Are you trying to connect to http://localhost:8080 from the same computer on which the server is running? If not, you have to either forward the port on your router as well as on the system-integrated firewall and give your external IP adress (to connect from Internet), or forward the port on the system firewall (possibly on the router, depends on the latter)and give your internal network IP adress (for intranet connection).
 
Old 05-24-2006, 10:08 AM   #10
mkalalms
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I am trying to connect to http://localhost:8080 on the same computer the server is running
 
Old 05-24-2006, 10:40 AM   #11
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 903
Blog Entries: 13

Rep: Reputation: 122Reputation: 122
In that case, check that you haven't changed the hostname, or simply try to connect to http://127.0.0.1:8080 (the loopback interface). If that doesn't work, really check your firewall settings (can't help with that since I don't use Suse), if it still doesn't work, check that your server is running (don't know how to do that; should be explained in the server's documentation).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
connection refused when attempting localhost:8080 mkalalms Linux - Newbie 3 05-22-2006 04:50 AM
Tomcat: Refused localhost:8080 manudath Linux - Software 1 03-31-2005 04:32 AM
can't connect to localhost acidblue Fedora 0 12-05-2004 08:20 PM
Tomcat, cannot connect to 8080 briansy Linux - Software 2 03-03-2004 07:22 AM
Stopping Tomcat causes java.net.ConnectException and also unable to connect to 8080 simonh Linux - Software 3 07-21-2003 05:49 AM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration