LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2012, 05:52 PM   #1
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Rep: Reputation: Disabled
Can't connect to internet suddenly


Using linux mint 11 installed on new Shuttle computer (one month). I was able to go online for 2-3 weeks, but now I cant. When I boot up or restart as either user (I have two set up) I get the message that there are wireless connections available and to go to the network menu.

however, when I go there and select network connections and go to the wireless tab no connections appear for me to select from. My modem is called 2WIRE006 and when I try to add the new connection it asks for info I'm ignorant about. Any help with adding a new connection? I would expect it to be a simple procedure.

I've had several glitchy things with this new computer. I'm wondering if the original installation was incomplete or something. I got Linux mainly because it is so stable and will install V12 as soon as soon i can. i might have to download V12 to this PC, burn it to DVD and install that way.

So,
1) does this sound like a software glitch? If so, how to fix.
2) If I need to download V 12 to DVD and install, will I encounter problems that you know about
3) Could this be hardware related? I'm fixing to call Shuttle

Thanks for your time and help.

Maggie Rose
 
Old 01-23-2012, 09:13 PM   #2
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 470

Rep: Reputation: Disabled
Maggie,

Start by looking for buttons on the computer itself. Sometimes there are switches to physically turn off the wireless adaptor. If ths is the case simply switching it on should do the trick

If this isn't the case, try this. Open your programs menu and look for an option called terminal, or gnome terminal, or xterm. If you can't find it try holding alt and pressing F2, this will probably bring up a run box, type in "xterm" no parenthesis"
That should bring up a command shell. Type "ifconfig"
This should bring up a list of confusing things that you don't understand. Just look on the left for something called "wlan0"

If not what do you see? If you don't see it try typing this "sudo ifconfig eth0 up"
and type in your password when it asks for it. Look for any error messages. Post them if there are any Then type "ifconfig" again and see if it's still not there.

I'm sure it's something small. Just try that first and if you still don't have a connection, let us know what happens. Remember, we need details
 
1 members found this post helpful.
Old 01-24-2012, 08:07 AM   #3
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
Thanks for the terminal command. I'm just learning how to use terminal and needed the command to input. I agree this may be a small fix.

So, when i went into "ifconfig" I saw the wlan0. This is what it said:

Link encap:Ethernet HWaddr e0:91:53:51:91:77
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
Tx packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:17 Memory:f8610000-f8610100

Looks like all is okay. What now? Is there a terminal command that can list available links? The screen message when i boot up says wireless connections are available, but no possible connections listed in "network connections".
 
Old 01-24-2012, 10:00 AM   #4
vickyk
Member
 
Registered: Dec 2009
Posts: 38

Rep: Reputation: 6
Hi mrmorrighan,

Open the terminal as mreff555 told you. Try this

Quote:
/etc/init.d/networking restart
If the above doesn't work, then
Quote:
/etc/init.d/network restart
While executing the above command, open another terminal and check the output of
Quote:
tail -f /var/log/messages
You can give the output here.

Secondly,
you can check this link
http://www.wikihow.com/Set-up-a-Wire...twork-in-Linux
 
1 members found this post helpful.
Old 01-24-2012, 10:17 PM   #5
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 470

Rep: Reputation: Disabled
Yes, it looks like your interface is up, so it is quite strange that you can't see any network connections. Try "iwlist scan"
This is basicly a command shell way of searching for networks.
 
1 members found this post helpful.
Old 01-24-2012, 11:12 PM   #6
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
hi, vickyk, Thanks for the info. Also, thanks to mreff555 for add'l info.


when i type in vicky's first suggested command line it says:

*Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
*Reconfiguring network interfaces
ifdown: failed to open statefile/var/run/network/ifstate: Permission denied
ifup: failed to open statefile/var/run/network/ifstate: Permission denied
[fail]

when i type in mreff555 command, i get:

lo Interface doesn't support scanning
eth0 Interface doesn't support scanning
wlan0 No scan results

Something here doesn't look right to me. This user has administrator rights, so don't understand "permission denied"

Any other suggestions? My wireless works great with two other computers, and used to work fine on the Shuttle. When I first got the machine I was asked to enter the WEP code several times when I booted or restarted. I thought that was strange, one of the glitchy things I ran into early on, but then it seemed to finally get the WEP code memorized and started connecting automatically. Then it quit for no apparent reason, nothing changed, I was still reading and getting informed on system, so something happened internally.

If you have more ideas let me know. Otherwise I can download Mint 12 to this PC and copy program to disk (I bot external DVD drive to use with Shuttle). Maybe that will clear up whatever issues are going on now.

Y'all are wonderful. Thanks so much for your time!

Maggie Rose
 
Old 01-26-2012, 02:21 PM   #7
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
I'm renewing this thread for continued help solving problem. I've loaded mint 12, and am still having same problem.
Thanks
 
Old 01-26-2012, 08:08 PM   #8
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 470

Rep: Reputation: Disabled
Alright. If you are absolutely sure that you don't have a switch to turn on and off wifi, try this:

Type "iwconfig wlan0". you should see something like this:

wlan0 IEEE 802.11bgn ESSID:"Routy"
Mode:Managed Frequency:2.462 GHz Access Point: 00:1F:90:F3:A4:FC
Bit Rate=54 Mb/s Tx-Power=16 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementn
Link Quality=50/70 Signal level=-60 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:12 Invalid misc:6621 Missed beacon:0

The Essid blank will most likely be empty since you aren't connectedand I'm taking a wild guess that the Tx-Power is off, but let me know what it says.

if it is off, try this.
"sudo iwconfig txpower auto"
I would then try rebooting and see if that makes a difference.

btw. I'm not familiar with these shuttle systems but assuming you are running a standard version of linux let me briefly explain something about administrator rights. I apologize if I'm explaining things you already know. Unlike Windows where administrator access is a little more transparent and default. Generally, in linux when a user had "administrator access" it means they have access to "sudo". In linux there are three ways to get "root" access in linux, which is the equivalent of administrator linux.
1. You can log in directly with the username "root" and a password which you may or may not know. I'll explain in a second. By the way, this isn't recommended. Logging in to a graphical environment at root is dangerout because many commands are being executed in the background and if the x server has root access, there is the possibility to do damage.

2. You can log in as yourself and type "su" in the command prompt, and then enter the root password. This will convert this shell only to root. You can then freely access commands with root access. This is the second safest method.

3. The best method, if you only need to run one command as root is the sudo command. It requires your username being in a file called "/etc/sudoers", this is generally what is refered to as administrative access for a user in linux. If you need to run a command which requires root access, such as adjusting the power to your wireless card. The command is "sudo" followed by the commands eg "sudo iwconfig wlan0 txpower auto". It will ask you for a password, but it is looking for your password, not the root password. Many systems, Ubuntu included don't make actual root easily accessable for safety reasons.

Hopefully that clears up some confusion. Sorry if I'm explaining things you already know.
 
Old 01-26-2012, 10:38 PM   #9
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
mreff555--

There is a "antenna" symbol on the front of the machine which has a green light, so i assume the wireless is on. Can't find switch but I know what you're talking about and I don't think I have one.

And, please don't apologize for telling me stuff I might already know. I am a Real New Newbie. i know windows, but not this, and especially not terminal.

typing "iwconfig wlan0":wla0 802.11bgn Nickname: "rtl8191seva1"
mode: managed Frequency=2.417 GHz Access Point: not-Associated
Bit Rate:135 mb/s
Retry: on RTS thrff Fragment thrff
power Managementff
Link Quality=10/100 Signal level=dBm Noise level=-100 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Then I entered "sudo iwconfig wlan0 txpower auto", and entered password when prompted"

Error for wireless re
 
Old 01-26-2012, 10:50 PM   #10
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
mreff555, hi again. Don't think i have a switch, the little wireless antenna icon on the front of the machine is green though, so looks on to me.

And please dont apologize for stuff I might already know. If you haven't figured it out already, I'm a Real New Newbie. Windows for years, don't know terminal at all.

Typing iwconfig wlan0:
wlan0 802.11bgn Nickname:"rtl8191SEVA1"
Mode:Managed Frequency=2.417 GHz Access Point; Not-Associated
Bit Rate:135Mb/s
Retryn RTS thrff Fragment thrff
Power Managementff
Link Quality=10/100 Signal level=0 dBm Noise level=-100 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 invalid misc:0 Missed beacon:0

Typing "wudo iwconfig wlan0 txpower auto" and entering password when prompted:

Error for wireless request "Set Tx Power" (8826) :
Set failed on device wlan0 ' Operation not supported

Any clues here? Reminder, when I boot or restart i get the message on screen that "Wireless networks Available" and to go to network menu which has nothing listed for me to choose.
 
Old 01-27-2012, 08:08 AM   #11
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,396

Rep: Reputation: 101Reputation: 101
Good morning Maggie Rose,

In response to your post in the other thread...

When adding a new wireless network:

SSID is the router/network name - 2WIRE006 is likely correct in your case
Infrastructure is probably the correct mode
The only other settings you should have to enter would relate to security. What sort of security and what is the password.

That said, we probably need to verify the information about your network. A couple of ideas...

You said you have a Dell PC which you used to download Mint 12. I guess it is connected to the network. Is it wireless? If so we can find some of the settings by looking at its configuration.

If the Dell PC is wired to the network - please tell me what make and model the modem/router. You will need to access the modem/router (usually by using a web browser) to lookup the information.

Please let me know how you want to proceed.

Ken

p.s. I agree that the green antenna symbol says the hardware is working. The results of iwconfig support this. If we get the correct setup information for your network (as described above) I am sure we can get things connected.
 
Old 01-27-2012, 01:17 PM   #12
mrmorrighan
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
Hi, Ken

Don't know why i didn't think to check my Dell connections. Duh....

IT'S WORKING!!!!!

Once I knew what SSID was and that I could ignore the rest, and set up the right WEP, ir connected! Such a simple fix for all the hard work and time from you guys. I really appreciate all your help, Ken and mredd555.

Don't know what happened, but now I know how to fix if it happens again.

The only other thing I have to do before switching to the Shuttle/Linux full time is to load a Windows bridge game (Jack 5.0), but i'll start another thread if i continue to have problems. I've got wine so maybe I can do this on my own.

Y'all are wonderful!!

Maggie Rose
 
Old 01-27-2012, 02:34 PM   #13
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,396

Rep: Reputation: 101Reputation: 101
Glad you got it working!!!


WEP security on your wireless network is better than nothing - but not much better. It has been cracked for a long time so if someone wants to tap you signal they can do so without too much effort. Not to break things again but if you want to upgrade to WPA2 some day for better security start another thread and I am sure folks here will assist you in doing so.

Ken
 
Old 01-27-2012, 02:59 PM   #14
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Good to hear mrmorrighan fixed that wireless problem. I was following this threat and glad to know its happy ending!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Suddenly, cannot connect o the internet lindners Linux - General 2 07-07-2010 10:10 AM
Suddenly, Cannot connect to network gilman824 Linux - Networking 4 11-27-2006 05:36 PM
Suddenly can't wirelessly connect with my Inspiron E1405 muskyminxx Linux - Newbie 2 08-27-2006 10:46 AM
Slackware10.2 suddenly isn't able to connect to internet makinavaja Linux - Networking 6 05-06-2006 11:16 AM
This one's got me stumped...suddenly can only connect in not out ealpert1 Linux - Networking 8 12-19-2004 01:39 PM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration