LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2011, 06:17 PM   #1
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Rep: Reputation: 17
Can't connect to internet on ubuntu 11.10 Beta 1 (not even using ethernet)


Ubuntu was working just fine. All the internet connections worked. I didn't do any modifications to it, i just used it to browse the web. I restarted my computer and then my network manager was gone from the gnome panel (using unity of course).
I checked the software center and the wireless network manager is installed (or so it says) (btw, i mostly use wireless) I tried plugging in my ethernet cable and that didnt work either.

So i thought i could just do a repair, so i booted up into recovery mode and selected the option to fix broken packages (connected to ethernet of course) and it wouldn't connect to the archives, Im clueless on how to get my internet connections working again

Last edited by noncomputergeek; 09-21-2011 at 06:21 PM. Reason: spelling mistakes
 
Old 09-21-2011, 09:25 PM   #2
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Original Poster
Rep: Reputation: 17
I think I figured out my problem, but another arose.
How do I install the missing library?
I ran the network app through terminal and it said it was missing a library.

How do I install it if i have absoultely no internet access on ubuntu?
 
Old 09-21-2011, 10:50 PM   #3
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Try booting into recovery mode and selecting root console with networking.

That may work even if fix broken packages does not connect to the network.
 
Old 09-21-2011, 11:12 PM   #4
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by andrewthomas View Post
Try booting into recovery mode and selecting root console with networking.

That may work even if fix broken packages does not connect to the network.
What do I do after i go to console with networking?

When i tried running the manager from terminal it said that its missing some library.
Can I download it on windows and install it on ubuntu via terminal?

The things is I have avant windows manager and I have the applet that measures traffic, everytime i click on the weather app to refresh, the network trafic app shows that kb go in and out, (4 for each) but the weather doesnt get updated, so im not sure if im completely internetless.
 
Old 09-21-2011, 11:31 PM   #5
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
When you get to the root console, do you have networking?

Code:
apt-get update && apt-get upgrade
 
Old 09-22-2011, 06:22 AM   #6
Fou-Jah
LQ Newbie
 
Registered: Sep 2011
Posts: 1

Rep: Reputation: Disabled
Thats weird, last night i experienced the exact same problem but only after doing an update and then autoclean - no internet wifi or ether, i thought it removed something important but it has never done that before which left me stumped.
I messed with it but couldn't figure it out so i am on my W7 partition until i do a fresh install of beta 2 today. Might be a bug but that would be shitty letting something like that thru, beta 1 has been pretty buggy for me especially when having multiple windows open and deluge running it would almost always freeze a window or two and sometimes altogether crash after login, screw that!

- heres to beta 2 getting its shit straight.

Last edited by Fou-Jah; 09-22-2011 at 06:25 AM.
 
Old 09-22-2011, 08:26 PM   #7
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by andrewthomas View Post
When you get to the root console, do you have networking?

Code:
apt-get update && apt-get upgrade
It didn't work, im resorting to a fresh install. I appreciate the help though!
 
Old 09-22-2011, 08:27 PM   #8
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Fou-Jah View Post
Thats weird, last night i experienced the exact same problem but only after doing an update and then autoclean - no internet wifi or ether, i thought it removed something important but it has never done that before which left me stumped.
I messed with it but couldn't figure it out so i am on my W7 partition until i do a fresh install of beta 2 today. Might be a bug but that would be shitty letting something like that thru, beta 1 has been pretty buggy for me especially when having multiple windows open and deluge running it would almost always freeze a window or two and sometimes altogether crash after login, screw that!

- heres to beta 2 getting its shit straight.
I feel you, im doing a beta 2 install right now.
Thank goodness I decided to keep my win7 partition.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to internet via ethernet xav.vijay Linux - Networking 3 06-06-2008 04:57 PM
I can`t connect to the internet though ETHERNET in Fedora7 Ali87 Linux - Networking 2 07-05-2007 02:24 PM
I can`t connect to the internet though ETHERNET in Fedora7 Ali87 Linux - Networking 2 07-05-2007 08:15 AM
trying to connect to internet via ethernet midnightmax General 14 05-24-2007 07:59 PM
cannot connect internet at redhat 8 through ethernet mazlan Linux - Newbie 1 11-30-2005 05:41 AM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration