LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-31-2014, 05:23 PM   #1
paulstenlund
LQ Newbie
 
Registered: Dec 2012
Posts: 24

Rep: Reputation: Disabled
can't connect to internet


I reloaded Ubuntu 10.4 LTS to run EMC and now I cant connect to the internet. I can ping the gateway and can ping the Linux box from a networked pc but the internet times out. What dns should I use?

thanks
Paul
 
Old 01-31-2014, 05:26 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Do you really think that it's a problem with DNS? Execute
Code:
cat /etc/resolv.conf
to check which DNS-server you're using. One public DNS-server provided by Google would be 8.8.8.8

Markus
 
Old 01-31-2014, 06:09 PM   #3
paulstenlund
LQ Newbie
 
Registered: Dec 2012
Posts: 24

Original Poster
Rep: Reputation: Disabled
Thanks markush

I set the Dns settings to match the winpc and it still doesnit work on the Linux box, what could it be??

Paul
 
Old 02-01-2014, 02:46 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Well, please post the output of the
Code:
ifconfig
and
Code:
cat /etc/resolv.conf
command on the Linux-computer and the output of the
Code:
ipconfig /all
command on the Windows-Computer.
This will help us to compare the network-settings on both systems.

Markus
 
Old 02-01-2014, 09:07 AM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Also check that the default gateway is set correctly with "netstat -rn".
 
Old 02-01-2014, 09:19 AM   #6
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,061

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
some diag info:
Code:
echo uname: && uname -a -m -p && echo lspci: && lspci && echo lsusb: && lsusb && echo lsmod: && lsmod && echo ifconfig: && ifconfig && echo ifconfig -a: && ifconfig -a && echo iwconfig: && iwconfig && echo resolv.conf: && cat /etc/resolv.conf && echo route: && route -n && echo ping router: && ping -c 1 `route | awk '/default/ {print $2}'` && echo ping dns-server: && ping -c 1 `awk '/nameserver/ {print $2}' /etc/resolv.conf | head -n 1` && echo ping using ip: && ping -c 1 64.235.229.141 && echo ping using dns: && ping -c 1 www.02144.com

Last edited by schneidz; 02-01-2014 at 09:36 AM.
 
Old 02-01-2014, 12:23 PM   #7
andy78
Member
 
Registered: Oct 2005
Location: Stockholm, Sweden
Distribution: Ubuntu
Posts: 78

Rep: Reputation: 18
You say you can ping the gateway, what's you gateway address?

You say you can ping the linux box, and what is that the computer your having issues with or another linux device serving your gateway?
Whats the address to the linux box?

If you enter this address in your browser 75.126.162.205 does it take you to linuxquestions.org?
If not then you expect an routing problem more then dns issue.

Anser the above and it will be easier to help out.
 
Old 02-01-2014, 12:33 PM   #8
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
Quote:
Originally Posted by paulstenlund View Post
I reloaded Ubuntu 10.4 LTS to run EMC and now I cant connect to the internet. I can ping the gateway and can ping the Linux box from a networked pc but the internet times out. What dns should I use?

thanks
Paul
are you using DHCP or Static IP for your Ubuntu box?
 
Old 02-01-2014, 07:40 PM   #9
paulstenlund
LQ Newbie
 
Registered: Dec 2012
Posts: 24

Original Poster
Rep: Reputation: Disabled
Thanks for all the help guys

win-pc 192.168.0.3
Linux 192.168.0.7

dns1 192.168.0.1
dns2 209.206.160.254

gateway 192.168.0.1

ifconfig - mtu 180, metric 1 (10's of 1000s of errors)
cat /etc/resolv.conf - all match
ipconfig /all -- all match

netstat -rn

destination gateway genmask flags
192.168.0.0 0.0.0.0 255.255.255 u
169.244.0.0 0000 255.255.0.0 u
0 192.168.0.1 0 ug
0 192.168.0.1 0 ug

pretty strange don't know what it means - the gateway ip is there ??

thanks for looking
Paul

Last edited by paulstenlund; 02-01-2014 at 07:41 PM.
 
Old 02-01-2014, 07:44 PM   #10
andy78
Member
 
Registered: Oct 2005
Location: Stockholm, Sweden
Distribution: Ubuntu
Posts: 78

Rep: Reputation: 18
If you punch in this address in your browser 75.126.162.205 do you then end up here at LQ or not?

If you run "tracepath 75.126.162.205" how far does it go, does it stop at 192.168.0.1?

That routing table looks fishy to me, you are missing your universal gateway.

Destination
0.0.0.0
Gateway 192.168.01

But not sure so perform the above tests to se if you can reach LQ.


Another question is your address received by dhcp or have you configured it with static address?

Last edited by andy78; 02-01-2014 at 08:03 PM.
 
Old 02-01-2014, 08:53 PM   #11
paulstenlund
LQ Newbie
 
Registered: Dec 2012
Posts: 24

Original Poster
Rep: Reputation: Disabled
andy

Its a static address, the browser times out before it gets to LQ. Tracepath goes out into the world and hops around, it quits at 31 hops, lots of "no replys" before it gets to LQ. sometimes it doesn't get past the router before it quits.

That routing table doesn't make sense to me. What should one look like?

Paul
 
Old 02-01-2014, 09:00 PM   #12
andy78
Member
 
Registered: Oct 2005
Location: Stockholm, Sweden
Distribution: Ubuntu
Posts: 78

Rep: Reputation: 18
Ok.
31 hops is the maximum.


well mine looks like this, obeserve the last line.

Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0


Is there any difference if you connect via wifi or ethernet?
What service are you using since it requires you to configure it staticly is it cable, dsl, fiber, i guess you have som router of some kind from your provider.

Last edited by andy78; 02-01-2014 at 09:04 PM.
 
Old 02-01-2014, 09:09 PM   #13
andy78
Member
 
Registered: Oct 2005
Location: Stockholm, Sweden
Distribution: Ubuntu
Posts: 78

Rep: Reputation: 18
Is there a difference if you do
ping 75.126.162.205

Compared with.

ping linuxquestion.org


Is the outcome the same?
If its an dns issue the last ping should return an error.
 
Old 02-01-2014, 09:15 PM   #14
paulstenlund
LQ Newbie
 
Registered: Dec 2012
Posts: 24

Original Poster
Rep: Reputation: Disabled
no wifi, it wouldn't connect automatically

I've got 2 last lines with my gateway

0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

how do I delete one??
 
Old 02-01-2014, 09:20 PM   #15
paulstenlund
LQ Newbie
 
Registered: Dec 2012
Posts: 24

Original Poster
Rep: Reputation: Disabled
andy

"ping 75.126.162.205" works fine

"ping linuxquestion.org" just hangs up
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connect my netbook to wireless but it wont connect to the internet but it did . Haydn456MJW Linux - Newbie 7 01-26-2011 05:56 PM
Kubuntu - Can't connect to the internet, but can connect to the LAN KellyT Linux - Networking 1 11-12-2009 04:17 AM
Able to connect to default Gateway, Unable to connect to internet Dumb.Coder Linux - Newbie 11 04-14-2009 04:22 AM
connect to internet trough wireless others connect to me with lan Amir Menesy Linux - Wireless Networking 1 11-13-2007 08:28 PM
how i connect (bridging) two internet connection and how to use that both the connect karthi26 Linux - Newbie 1 08-26-2007 03:10 AM


All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration