LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-01-2008, 12:26 PM   #1
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Rep: Reputation: 36
Thumbs down Can't connect to HTTPS sites using firefox


Hey Guys,

I'm trying to connect to a HTTPS site and I get this error message: "Firefox can't connect securely to <website> because the site uses a security protocol which isn't enabled"
I enabled SSl2 using about:config but I still get that error message.
hope you guys can help!
 
Old 05-01-2008, 01:44 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
What version of Firefox are you running? That has worked for me as long as I can remember.

Have a look at Edit-->Preferences-->Advanced-->Encryption and make sure in the Protocol section SSL and TLS are checked.

Last edited by camorri; 05-01-2008 at 01:49 PM. Reason: Added information.
 
Old 05-01-2008, 02:07 PM   #3
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Original Poster
Rep: Reputation: 36
I'm using ver 2.0.0.6 and yes I have SSl enabled and TLS enabled.

cheers!
 
Old 05-02-2008, 01:21 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I'm going to suggest you do two things.

1. Create a new profile and try again. I have seen several threads with various problems, it seems when you install add-ons, some seem to mess up the user profile, and there are various problems reported.

2. 2.0.0.6 has been around for a while. If #1 doesn't help, get the latest version and give it a try. I think it is up to 2.0.0.14.
 
Old 05-05-2008, 01:10 PM   #5
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Original Poster
Rep: Reputation: 36
Hello,

Im now running 2.0.0.14 and SSL2 TRUE but I still cannot access HTTPS any other suggestions?
 
Old 05-05-2008, 04:51 PM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Did you create the new profile? Do you have the same problem under a new profile?
 
Old 05-06-2008, 11:01 AM   #7
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Original Poster
Rep: Reputation: 36
Yes I did, I created a new profile and enabled SSL2 but I still can't connect using HTTPS. any suggestions?
Thank man!
For now I'm using IE6 to connect to it but im trying to get rid of my M$crosoft machine and just run linux! but because of this issue I can't yet.
 
Old 05-06-2008, 11:25 AM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I guessing, now. I suspect you have something missing ( not sure what ) in your installation. The other possibility is there is something wrong in your firefox configuration. ( not sure what ).

Have you got another web browser installed? If yes, try it, for example Konqueror. See if it works. That may give us some direction, to look for a FF problem or something missing in your install.
 
Old 05-06-2008, 11:34 AM   #9
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Original Poster
Rep: Reputation: 36
HI cliff,

I tried Konqueor before posting this threat here and It didn't work. I get "Could not connect to HTTPS://(address)"
Thanks
 
Old 05-06-2008, 12:36 PM   #10
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Original Poster
Rep: Reputation: 36
I also checked the firewall setting, disabled the firewall for a bit and nothing. but I'm not giving up!
 
Old 05-06-2008, 02:29 PM   #11
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Mint, Backtrack, OpenSuse
Posts: 560

Original Poster
Rep: Reputation: 36
I enabled all SSLs on Konqueor and it worked but now how can I open it with Firefox? or what do you think the issue might be?
 
Old 05-06-2008, 08:22 PM   #12
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I suspect you have a config problem in FF.

Quote:
Im now running 2.0.0.14 and SSL2 TRUE but I still cannot access HTTPS any other suggestions?
Are you sure it is SSL2 you are running? SSL2 is old. When I go to about:config in FF, and type ssl2 none of the ssl2 stuff is enabled in my FF version 2.0.0.12. I have SSL3 enabled. When I look on about:config and put SSL3 in the filter, I have lots of SSL3 items selected. I can connect to https sites without problems.

I don't have an answer other than activate SSL3 and try again.
 
Old 05-06-2008, 08:30 PM   #13
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I came across this tip. You can try it to see if it makes any difference. BTW, do a google search on SSL2 and do a little reading. As I suspected, SSL2 is old and not very secure. Anyway, here is the tip.

Quote:
Firefox 2.0: SSL 2 Tweak
Published Tuesday, October 24, 2006 Firefox 2.0 (Bon Echo) , Mozilla Firefox , Tips & Tweaks

Firefox 2, no longer allows you to enable SSL 2 encryption protocols due to the fact SSL 2 is not very secure. However, some folks may run into sites that insist you have SSL 2 Protocol enabled. Once again a simple about:config change:

1. In a new tab type about:config in the address bar and press enter or open the about:config editor if you have the extension
2. In the filter field enter security.enable_ssl2
3. Double click the entry so the value is true
4. Close the tab or about:config edito
Some more things from that site.

Quote:
#

Hi,
Yes, I set this security.enable_ssl2 to true and FireFox2 is still not working with nemoves.com website
When I open Tools/Options/Advanced there is still no SSL2.0 checkbox. Can you help me how to enable FireFox2 to support SSL2.0. Thank you.
# 2 Obfuscated Friday, October 27, 2006 at 4:18 pm

In about:config, do a search for security.ssl2 and enable the ciphers you see there. That did the trick for me.
After doing some more reading, it seems FF went to SSL3 because it is more secure. However there are still sites out there only using SSL2, possibly your site(s).

See if the tip allows you to connect.

Last edited by camorri; 05-06-2008 at 08:47 PM. Reason: Added info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get Firefox to connect to localhost but can get to outside web sites esimuro Linux - Newbie 7 11-14-2007 04:51 PM
Can't access https sites in Firefox, fresh Ubuntu 6.10 install Gnewb Linux - Newbie 10 12-05-2006 10:07 PM
Client cannot open few https://.. sites i.e. secure sites rajeshghy Linux - General 1 11-02-2006 07:30 AM
Cannot connect to secure sites after update to Firefox 1.5.0.7 solar1951 Linux - Software 3 09-17-2006 07:19 AM
Firefox cannot load https sites. Lambda_Core Linux - Software 3 08-27-2006 06:24 PM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration