LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-14-2004, 08:43 PM   #1
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Rep: Reputation: 15
Can't build ATI module using "sh make.sh"


When I use "sh make.sh" to generate my ATI module I get this error, but I have the latest kernel (2.6.7). What am I doing wrong?
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.7-1.494.2.2/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
[root@localhost build_mod]#
 
Old 08-14-2004, 08:50 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
What distro? The reference to X 4.1.0 may indicate that it's looking for something specific to XFree86 whereas a lot of modern distros use X.org instead. That's something of a stab in the dark though.
 
Old 08-14-2004, 08:52 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I've never used the ATI drivers, but are you
sure that they will work with a 2.6 kernel at
all? They may well be crafted towards the
2.4 series... have another look at your
README.


Cheers,
Tink
 
Old 08-16-2004, 12:01 PM   #4
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
I have followed instructions on this and many other sites as to using ATI drivers with the 2.6.7 kernel. I just can't seem to be able to compile the drivers for this kernel.
 
Old 08-16-2004, 12:16 PM   #5
linuxlastslonge
Member
 
Registered: Jun 2002
Location: Franklin, IN
Distribution: Debian, CentOS, Mac OS X
Posts: 158

Rep: Reputation: 30

Quote:
XFree86 drm includes at /lib/modules/2.6.7-1.494.2.2/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.


The kernel has nothing to do with this, as the error clearly statess that:

Quote:
This driver is designed to only work with X4.1.0 or higher
the ATI make.sh is looking for libraries that are only included with X4.1.0 and higher. you will need the latest version of X for the driver to compile properly. i had the same problem until i upgraded to X4.3


hope i could help!!!!!!!!!!!





 
Old 08-16-2004, 12:31 PM   #6
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
How do I update to X 4.3 ive done a "yum search X4.3" with no results Thanks!
 
Old 08-16-2004, 01:20 PM   #7
linuxlastslonge
Member
 
Registered: Jun 2002
Location: Franklin, IN
Distribution: Debian, CentOS, Mac OS X
Posts: 158

Rep: Reputation: 30
i don't know how to automatically update X, i've always done it by hand at the console. you can visit X.org to download the needed files and follow the README.... other than that, sorry i can't help that much via a forum.



 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
So many errors when I typed the "make" and "make install" command Niceman2005 Linux - Software 23 07-22-2009 03:33 PM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 05:51 AM
"Invalid module format" when I try to install my ATI drivers freddurgan Linux - Newbie 2 05-21-2004 11:49 PM
suse ati driver "Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing" madcow007 Linux - Hardware 0 03-06-2004 03:53 PM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 04:31 PM


All times are GMT -5. The time now is 09:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration