LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2008, 08:53 PM   #1
ivoidwarranties
LQ Newbie
 
Registered: Feb 2008
Location: Auburndale, Florida
Distribution: Mepis 11, Debian, Raspian
Posts: 7

Rep: Reputation: 0
Can't browse network by Workgroup name in Konqueror


Briefly, after setting up the Samba shares, I am able to view shared folders on Windows box if I specify the ip address of the remote computer in the address bar of Konqueror, but not if I use a Workgroup name or computer name.

Specifically, I'm trying to add a linux laptop (Mepis 7.0) to my existing home network of 3 Windows boxes. Everything is connected through an SMC7004ABR Barricade router with two laptops (a linux and a Windows) connecting wirelessly through a Linksys Wireless G access point.

NO firewall is enabled on any of the computers. I learned how THAT can make a difference the hard way when I first started trying to get my first two windows boxes to talk to each other.

NO MAC address filtering is enabled. Was "reminded" about that part when I got my second laptop.

All windows boxes are XP Pro with simple file sharing disabled. Samba is currently set up with Security "Share". I briefly changed it to security "User" but all that did was make me enter a password when connecting the the windows box.

Here's the state of things right now. To keep things simple, I'll just describe the interaction between the Linux box and the Windows laptop
  • I can ping from back and forth from each box.
  • From the Windows box I can view all the computers in the workgroup -- all windows boxes and the linux.
  • From the Linux box, I can type "smb:/" in the address bar of Konqueror, which will show an icon for my workgroup (MY_HOUSE). Clicking on MY_HOUSE gives an almost immediate error message stating "Timeout on server my_house". I've noticed that even though the smb.conf config entry for workgroup is "MY_HOUSE" (all caps), the Konqueror icon displays a title of "My_house" (only first letter is cap), while the error message displays the workgroup name as "my_house" (no caps). Have done a global text search through all the files on the laptop and everything seems to be spelled "MY_HOUSE".
  • Same thing happens when I use the netbios name of the windows computer in the address bar i.e "smb://windozebox gives the same error message except that it complains that windozebox instead of MY_HOUSE timed out.
  • But when use the IP address of the Windoze box (smb://192.168.2.40), success! I can see, navigate through shared folders, open files, edit etc just hunky dory.

I've searched all over the internet and haven't turned up anything about not being able to look at your network by Workgroup or computer name. On e thread mentioned inserting ip addresses and names into the lmhosts file, but gee whiz! That's hard coding and that defeats the whole purpose of having a flexible network! Or am I being picky?

One tactic I ran across mentioned setting wins support = yes in smb.conf on the theory that if the computer name couldn't be found in WINS, the laptop would go looking elsewhere in the DNS. Tried several configurations along this model, but no success.

Am I going to have to set up WINS on one of my Windows boxes to get this work? Was really hoping this Linux stuff would move me away from instead into more Windows settings but if it's gotta be, then its gotta be.

Admittedly, this is certainly not the biggest problem I could run across, but there has to be someone who's run across this before.

Any help, advice, encouragement, or just plain sympathy will be much appreciated.


=========================================================================

/etc/samba/smb.conf

Code:
;*******************section global*****************
[global]

# Do something sensible when Samba crashes: mail the admin a backtrace
panic action = /usr/share/samba/panic-action %d
printing = cups
workgroup = MY_HOUSE
server string = %h server (Samba %v)
hosts allow = 192.168.0. 192.168.1. 192.168.2. 192.168.79. 127. 10.0.0. 10.1.1.
socket options = TCP_NODELAY IPTOS_LOWDELAY 
log level = 1
dead time = 15
hide unreadable = yes
passdb backend = tdbsam
host msdfs = no
max log size = 1000
map to guest = Bad Password
restrict anonymous = no
domain master = no
preferred master = no
max protocol = NT
ldap ssl = No
server signing = Auto
oplocks = no
level2 oplocks = no
acl compatibility = winnt


name resolve order = wins lmhosts host bcast
security = share
;**********    wins support = yes



;*******************section Paul*****************
[Shared]
path = /home/foo/Shared
read only = no
browseable = yes
writable = yes

;*******************section Music*****************
[Music]
path = /home/foo/Music
read only = no

;*******************section homes*****************
[homes]
comment = Home Directory
read only = no

;*******************section printers*****************
[printers]
comment = All Printers
path = /tmp
printable = yes
create mask = 0700
 
Old 02-23-2008, 03:10 PM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 802

Rep: Reputation: 101Reputation: 101
Try changing domain master and preferred master. Here's mine...
Code:
[global]
	workgroup = MSHOME
	server string = Graceland
	security = SHARE
	guest account = ftp
	acl compatibility = winnt
	server signing = auto
	printcap name = /etc/printcap
	preferred master = Yes
	domain master = Yes
	ldap ssl = no
	printing = lprng
	lppause command = lpc hold '%p' %j
	lpresume command = lpc release '%p' %j
	queuepause command = lpc stop '%p'
	queueresume command = lpc start '%p'

Last edited by manwichmakesameal; 02-23-2008 at 03:12 PM.
 
Old 03-03-2008, 09:28 AM   #3
stormzen
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
I've seen this problem in ubuntu Gutsy

Same symptoms you describe. Filed a bug report here: https://bugs.launchpad.net/ubuntu/+bug/198002 . (But this is the work-around that I found):

"I went back to my original installed file. It appears that commenting out both the "interface" settings and the "host allow" settings causes both Nautilus and Konqueror to work as expected. ... Unless Samba is doing away with those settings, however, it's probably still a bug."

Looks like this inconvenience has existed for over a year. If this solves your problem, take care that your firewall limits where the SMB packets go...

Good luck.
 
Old 07-02-2008, 12:16 PM   #4
pouletfou
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
Solved by setting firewall on router

I had the same problem here. konqueror in a lan managed by a router with tomato firmware. I changed the "NAT loopback" to "All" in the Advanced/Firewall section and it solved my problem. Now smb://workgroup/ and smb://machine/ work perfectly.
 
Old 07-16-2008, 11:33 PM   #5
likema
LQ Newbie
 
Registered: Jul 2008
Distribution: kubuntu
Posts: 2

Rep: Reputation: 0
Enable broadcast only in "name resolve order"

I encounter the same problem on my work machine kubuntu 8.04, whose the "interface" settings and the "host allow" settings was already commented out. BTW, There is a gateway (ubuntu server 8.04) without WINS and DNS servers.

However, when executing "smbtree -d 8", smbtree finds the machine name by broadcasting, but it still tried to connect <gateway external ip>:445 (Microsoft Naked CIFS) and <gateway external ip>:139 (NETBIOS session service) and causes timeout.

I don't why my gateway always replies the external ip when some internal machines tries to resolve the internal machine names. I guess it causes by no WINS and DNS servers internally.

So I change the "host allow" settings of smb.conf to

name resolve order = bcast

Luckily, konqueror works well.
 
  


Reply

Tags
networking, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't browse workgroup (suse 9.3) mbquartnut Linux - Networking 1 11-09-2005 11:04 PM
Unable to browse WORKGROUP when samba running mariusak Linux - Networking 10 05-30-2005 07:44 AM
browse XP network from Konqueror elite122 Linux - Networking 1 08-06-2004 11:48 AM
Can't browse Windows Workgroup due to Samba? CanadianSlacker Linux - General 4 05-07-2004 07:49 PM
can't browse windows workgroup when linux box online revdshepard Linux - Networking 2 02-04-2004 03:14 PM


All times are GMT -5. The time now is 10:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration