LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Closed Thread
 
Search this Thread
Old 03-14-2012, 01:49 PM   #1
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Rep: Reputation: Disabled
Can't boot Windows 7 after Slackware install


I (probably stupidly) didn't install lilo in a Windows 7 boot manager friendly way and now when I try to boot Windows it tries to boot to recovery. Any pointers on fixing this?

(Cross posted in the Slackware forum as well)
 
Old 03-14-2012, 05:39 PM   #2
FrankP
Member
 
Registered: Aug 2003
Location: Britain
Distribution: Debian, MacOSX, FreeBSD
Posts: 65

Rep: Reputation: 18
Probably the easiest way is to boot up from a live CD/DVD and make changes that way. You might need to mark the Windows partition as bootable using a partition tool like gparted, or adjust the lilo.conf.
 
Old 03-14-2012, 11:34 PM   #3
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Dehradun, Uttarakhand, India
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,412

Rep: Reputation: 303Reputation: 303Reputation: 303Reputation: 303
One thing to remember is LILO has to be installed on the bootable partition(if not the MBR) otherwise to the MBR and Windows always has to be installed first. If you have a re-install partition make sure LILO is pointed at your Windows 7 OS partition.
The MBR can be restored with any windows OS CD-ROM, but it is a good idea to make a backup of the MBR before trying to install LILO there(I've been there many times).
 
Old 03-15-2012, 03:30 AM   #4
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,458

Rep: Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941Reputation: 1941
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate. Please follow discussion here: http://www.linuxquestions.org/questi...nstall-934454/
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't boot Windows 7 after Slackware install J1NKL3 Slackware 16 03-20-2012 01:31 PM
How do I install Slackware to dual-boot with Windows XP? tin Slackware 9 06-20-2010 12:05 PM
[SOLVED] Slackware won't boot in dual boot with windows 7... aryn07 Slackware 9 01-22-2010 08:56 AM
Dual boot windows/slackware, but slackware installed first? Cryptic_K Slackware 3 11-20-2006 12:49 PM


All times are GMT -5. The time now is 01:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration