LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2010, 12:39 AM   #1
fiascosf
LQ Newbie
 
Registered: Jan 2007
Location: San Francisco, CA
Distribution: Ubuntu
Posts: 2

Rep: Reputation: 0
Question Can't boot Ubuntu to command line


I'm new to Linux. Just installed Ubuntu 10.04 LTS as a VM on MAC OSX. I want to auto boot to the command line, but the GUI keeps coming up. I ran "sudo update-rc.d -f gdm remove", but it didn't work. Please help.
 
Old 08-09-2010, 01:13 AM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

1. Boot to the GUI

2. Log in

3. Use "sudo vi" to create this one-line "/etc/inittab" file:
Quote:
sudo vi /etc/inittab
Code:
:id:3:initdefault:
4. Reboot ("sudo reboot -i" will work fine )

5. Voila! You should now boot to text-mode (runlevel 3) instead of GUI mode (runlevel 5).

Here is more info on the "new" Ubuntu "upstart":

http://www.linux.com/archive/feature/125977

And more alternatives, if you wish:

http://serverfault.com/questions/147...f-ubuntu-lucid

'Hope that helps .. PSM
 
Old 08-09-2010, 04:18 AM   #3
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 111Reputation: 111
You can also change grub option.

open the /etc/default/grub file, locate the following line:

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to:

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
and donít forget to run Ďupdate-grubí
 
1 members found this post helpful.
Old 08-09-2010, 04:41 AM   #4
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Quote:
Originally Posted by paulsm4 View Post
5. Voila! You should now boot to text-mode (runlevel 3) instead of GUI mode (runlevel 5).
I thought Debian and Ubuntu used Run-level 2 for GUI?
 
Old 08-10-2010, 10:30 AM   #5
bsat
Member
 
Registered: Feb 2009
Posts: 347

Rep: Reputation: 72
guess r3sistance is right, by default there is no /etc/inittab file in ubutnu 10.04 ( haven't checked with the previous version) the run level is set by the file /etc/init/rc-sysinit.conf. in which the default runlevel is set to 2, so the GUI runlevel in ubuntu is actually 2.

We can modify this by setting the required level in the line
Quote:

env RUNLEVEL=
Or by passing the runlevel as an argument during the boot i.e,

Quote:
press esc while grub is loading.
press "e" when the cursor is on the version of linux you are booting
move to the line that starts with kernel
press e
add 3 to the end of this line
press b.

or by running the command

Quote:


init 3.
this might be useful

http://upstart.ubuntu.com/
 
Old 08-10-2010, 11:05 AM   #6
babunix
Member
 
Registered: Jul 2010
Location: India
Distribution: RHEL, Ubuntu
Posts: 35

Rep: Reputation: Disabled
Another way is disabling login manager at boot time.
Code:
#update-rc.d -f gdm remove
You have to run startx command for graphics.

Method suggested by sem007 is also work fine.
I learn another way to start ubuntu in text mode.
 
0 members found this post helpful.
Old 08-10-2010, 11:22 PM   #7
fiascosf
LQ Newbie
 
Registered: Jan 2007
Location: San Francisco, CA
Distribution: Ubuntu
Posts: 2

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks to all who responded...sem007's suggestion worked...I'd send a 'thanks' but don't have a button!
 
Old 08-11-2010, 02:10 AM   #8
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 111Reputation: 111
Quote:
Originally Posted by fiascosf View Post
I'd send a 'thanks' but don't have a button!
You can see thanks button at right bottom side of every post.you won't see it on your own posts.
 
Old 08-11-2010, 06:50 AM   #9
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Quote:
Originally Posted by bsat View Post
guess r3sistance is right, by default there is no /etc/inittab file in ubutnu 10.04 ( haven't checked with the previous version) the run level is set by the file /etc/init/rc-sysinit.conf.
If I had to take a guess, that's probably something related to grub 2 which Ubuntu started using at version 9.10. But that is just a guess. 9.04 might use the older method of /etc/inittab
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Finding command line in ubuntu dhamle Linux - Software 2 09-12-2007 03:00 AM
Ubuntu Server 7.04 command line boot sequence KAOZ_IT Linux - Server 1 07-05-2007 05:28 AM
ubuntu or kubuntu text only boot to command line fyoder Ubuntu 2 06-03-2007 04:44 PM
Blank Screen after Suse Boot - HowTo boot from grub to command line benco420 Linux - Newbie 3 02-13-2005 06:50 AM
mandrake 10 command line to gui boot, then stuck at boot with hour glass chris008 Linux - Laptop and Netbook 1 11-14-2004 06:29 PM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration