LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-07-2016, 08:20 AM   #1
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Rep: Reputation: Disabled
Unhappy can't access graphical grub2 boot loader menu screen


Helllo.
When my centos7 starting up i immediately press "esc" button to get into the grub2 boot loader and i expected to see a graphical menu of grub (as in many systems i saw!) but i see just a black and white screen menu without any background and so on.
So what can i do to have that graphical menu or did i incorrectly pressed "esc" button?
 
Old 10-07-2016, 09:13 AM   #2
aragorn2101
Member
 
Registered: Dec 2012
Location: Mauritius
Distribution: Slackware
Posts: 203

Rep: Reputation: 82
Hello,

I am curious. Is it the first time you are booting this machine?

I use CentOS on a server and I don't remember ever pressing ESC to access grub. Normally the boot loader is the first thing which the machine loads, by default.

However, if you want to modify grub to add a colourful background or other things, that's easy. Check these out:
https://www.howtoforge.com/tutorial/...-screen-image/
https://wiki.archlinux.org/index.php...d_bitmap_fonts
 
1 members found this post helpful.
Old 10-07-2016, 02:02 PM   #3
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
still have problem

I Tried so many methods , but i couldn't configure to have that graphical menu with background or theme, here is my /etc/defaults/grub entries and later is black screen menu that i see now when i boot the system.

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY="true"
GRUB_GFXMODE=1024*768*32
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND="/home/fardad/cool-linux-wallpapers-25.jpg"
GRUB_FONT="/boot/grub2/fonts/unicode.pf2"
 
Old 10-07-2016, 02:09 PM   #4
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Fardad74 View Post
No i'm using centos about two months, my friend. I Tried so many methods , but i couldn't configure to have that graphical menu with background or theme, here is my /etc/defaults/grub entries and later is black screen menu that i see now when i boot the system.

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY="true"
GRUB_GFXMODE=1024*768*32
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND="/home/fardad/cool-linux-wallpapers-25.jpg"
GRUB_FONT="/boot/grub2/fonts/unicode.pf2"
...
Attached Thumbnails
Click image for larger version

Name:	Screenshot (10).png
Views:	10
Size:	19.7 KB
ID:	23186  
 
Old 10-07-2016, 08:04 PM   #5
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
Unhappy can't access graphical grub2 boot loader menu screen

Now i searched further and it seems everything is true in my /etc/default/grub file. i set gfxterm and gfxmode, even pf2 font with arial.pf2 generated by grub2.mkfont , background image and so on. but still don't see backgrounded menu .here is my /etc/default/grub output:

GRUB_TIMEOUT=30
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_CMDLINE_LINUX="quiet splash"
GRUB_DISABLE_RECOVERY="true"
GRUB_GFXMODE=1024*768*32
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND="/boot/grub/water-wallpaper-hd-17.png"
GRUB_FONT="/boot/grub2/fonts/arial.pf2"

can anyone help me? now i'm slightly realizing that centos 7 hasn't really graphical grub menu!!

Last edited by Fardad74; 10-07-2016 at 08:05 PM.
 
Old 10-07-2016, 08:30 PM   #6
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,332
Blog Entries: 12

Rep: Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727Reputation: 2727
I don't believe CentOS uses a GUI screen. I have CentOS 7 in a VM and it uses a plain text display.

Remember that CentOS is a server distro. By and large, persons who run servers really aren't interested in eye candy. In the enterprise, many servers live in racks and are administered remotely via ssh or similar tools.
 
1 members found this post helpful.
Old 10-07-2016, 09:12 PM   #7
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
can't access graphical grub2 boot loader menu screen

Quote:
Originally Posted by frankbell View Post
I don't believe CentOS uses a GUI screen. I have CentOS 7 in a VM and it uses a plain text display.

Remember that CentOS is a server distro. By and large, persons who run servers really aren't interested in eye candy. In the enterprise, many servers live in racks and are administered remotely via ssh or similar tools.
Thanks for help.
of course I know these, i just saw that backgrounded menu in a centos 6.5 , but maybe or surely it's not possible to have that on centos 7 with this two completely days searching on the web. really i surprised myself, too when i saw that backgrounded menu on centos 6.5!! maybe grub versions less that 2.0 support that on centos. however i was really Curioused and tried that.

Last edited by Fardad74; 10-08-2016 at 08:47 AM.
 
Old 10-08-2016, 08:19 AM   #8
plasmonics
Member
 
Registered: Jan 2009
Distribution: Fedora, Gentoo
Posts: 125

Rep: Reputation: 46
I don't think this is anything to do with Centos. It is more of a Grub issue. Your file uses the old style method of theming and fonts. I would comment out grub_background and grub_font and insert the following
Code:
GRUB_THEME=/usr/share/grub/themes/starfield/theme.txt
The path name varies. You also have to install DejaVU fonts and grub-theme. The package names vary. The theme and font size are set in theme.txt. Finally
Code:
grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg
If Grub says it found theme.txt, it should work. If not, you have to troubleshoot. If there is error, it is usually because dejavu pf2 fonts missing.

Last edited by plasmonics; 10-08-2016 at 08:25 AM.
 
1 members found this post helpful.
Old 10-08-2016, 09:43 AM   #9
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
Lightbulb New Status!

Quote:
Originally Posted by plasmonics View Post
I don't think this is anything to do with Centos. It is more of a Grub issue. Your file uses the old style method of theming and fonts. I would comment out grub_background and grub_font and insert the following
Code:
GRUB_THEME=/usr/share/grub/themes/starfield/theme.txt
The path name varies. You also have to install DejaVU fonts and grub-theme. The package names vary. The theme and font size are set in theme.txt. Finally
Code:
grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg
If Grub says it found theme.txt, it should work. If not, you have to troubleshoot. If there is error, it is usually because dejavu pf2 fonts missing.
Thanks for your help, i tried all of that you said in previous reply, i added starfield theme as you told and grub FOUND my theme then i installed dejavu package and converted one of them from ttf to pf2 with grub2.mkfont command.

After all of these when i rebooted the system before that boot loader black screen be appear i saw an error that said : "invalid video mode specifications ?1024*768*32?" , i think i should change grub_gfxmode resolution , i guess it's a bigger size than the system requires, but what resolution?? how can i find out?

Last edited by Fardad74; 10-08-2016 at 09:44 AM.
 
Old 10-08-2016, 09:55 AM   #10
plasmonics
Member
 
Registered: Jan 2009
Distribution: Fedora, Gentoo
Posts: 125

Rep: Reputation: 46
I would try commenting out grub_gfxmode. It should read the resolution directly off the efi firmware.
 
1 members found this post helpful.
Old 10-08-2016, 10:16 AM   #11
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by plasmonics View Post
I would try commenting out grub_gfxmode. It should read the resolution directly off the efi firmware.
I Deleted grub_gfxmode and it worked, the theme was appeared . Now only thing that changed is the boot loader, logs and login screen size before going to gnome desktop are in half sized than before were and are so small!!
however thanks for your help my friend.
 
Old 10-08-2016, 10:28 AM   #12
plasmonics
Member
 
Registered: Jan 2009
Distribution: Fedora, Gentoo
Posts: 125

Rep: Reputation: 46
You have to increase the font sizes using grub2-mkfont. I use very large fonts, size 20 and 22. Then edit theme.txt and enter those changes. The colours can also be changes using rgb hex format.
 
1 members found this post helpful.
Old 10-08-2016, 11:00 AM   #13
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
still have problem

Quote:
Originally Posted by plasmonics View Post
You have to increase the font sizes using grub2-mkfont. I use very large fonts, size 20 and 22. Then edit theme.txt and enter those changes. The colours can also be changes using rgb hex format.
Not the font size, it's ok. i meant boot loader screen size, it's not full screen!
 
Old 10-08-2016, 11:23 AM   #14
plasmonics
Member
 
Registered: Jan 2009
Distribution: Fedora, Gentoo
Posts: 125

Rep: Reputation: 46
You might have to troubleshoot. Mine is full screen for all distros, incl Centos. The version of Centos I installed on my desktop is 7. Screen size is ok. One possibility is you might have to try grub_gfxmode with just the resolution, but without the color depth.

Last edited by plasmonics; 10-08-2016 at 12:10 PM.
 
1 members found this post helpful.
Old 10-09-2016, 02:34 AM   #15
Fardad74
Member
 
Registered: Jan 2016
Posts: 42

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by plasmonics View Post
You might have to troubleshoot. Mine is full screen for all distros, incl Centos. The version of Centos I installed on my desktop is 7. Screen size is ok. One possibility is you might have to try grub_gfxmode with just the resolution, but without the color depth.
Thanks a lot, now it's all fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to keep a tidy boot loader (GRUB2)? Seviath Linux - General 0 12-15-2011 03:52 AM
[SOLVED] Create independent Grub2 boot loader menu in USB stick. cr4321 Linux - General 27 07-18-2010 01:48 PM
GRUB2 - FreeBSD-8.0 does not show up in triple boot menu, dual boot menu it does.. wiliweld *BSD 7 05-03-2010 02:05 PM
LXer: Transitioning to the new GRUB2 boot loader LXer Syndicated Linux News 1 04-22-2010 08:37 AM
can't use graphical menu in boot loader hacchan Mandriva 2 06-03-2005 11:17 PM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration