LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-24-2013, 01:59 PM   #1
sequimbob
LQ Newbie
 
Registered: Jul 2013
Location: On the road, Sequim, WA is home base
Distribution: Linux Mint 18 sarah Mate
Posts: 15

Rep: Reputation: Disabled
Question can't access files in usb drive in terminal


I am a pretty much of a novice with Ubuntu, but slowly learning as I go along. I am switching from WIN 7. I want to use the 'convert' utility to add captions to photos. These photos are on a USB HDD. I cannot seem to access these files in terminal. (GUI is no problem but the convert program must run in Terminal). When I cd to media and do an ls, it shows all of my USB HDD in all CAPS and the color is dark blue. When I try to cd to the drive itself it returns 'No such file or directory'. I have checked and the drive is mounted according to the properties page in the gui display. What am I doing wrong. I have checked all of the threads but have not found an answer. Any help will be greatly appreciated. I have searced the web but have not come up with an answer.

Last edited by sequimbob; 08-24-2013 at 02:00 PM.
 
Old 08-24-2013, 02:47 PM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,990

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Might be entering the 'cd' command incorrectly but we don't know what command you used so...?
Run an ls -l on the /media directory which shows permissions, owner:group.
 
1 members found this post helpful.
Old 08-24-2013, 03:35 PM   #3
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
Hi there,

Quote:
Originally Posted by sequimbob View Post
I am a pretty much of a novice with Ubuntu, but slowly learning as I go along. I am switching from WIN 7.
coming from Win7, almost anything else must be a relief. ;-)

Quote:
Originally Posted by sequimbob View Post
When I cd to media and do an ls, it shows all of my USB HDD in all CAPS and the color is dark blue. When I try to cd to the drive itself it returns 'No such file or directory'.
Don't mind the colors for the moment; it's a convenience of ls when used in a color-enabled terminal. The colors are used as an additional means for visualizing file types and access rights. But back to the "all CAPS" part: Did you enter the directory name in all caps when issuing the 'cd' command? Unlike Windows, Linux wants to have it *exactly*. So if there's a media listed as 3A91-04E7, you can't address it as 3a91-04e7. This is a typical tripwire for people being used to Windows.

By the way, there's a typing aid: Type the first two or three characters of the file or directory name, and hit the TAB key. The name will automatically be extended if it's distinct by what you typed.

[X] Doc CPU.
 
1 members found this post helpful.
Old 08-24-2013, 05:41 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,990

Rep: Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448
also if there is a blank space in the name the terminal will NOT like it
the terminal uses a blank space to define an option

for example the folder name
"Program Files" ( a default windows folder )
can NOT be cd'd into without using quotes or "escaping" it
Code:
cd "/media/Program Files"
-- or --
cd /media/Program\Files
 
1 members found this post helpful.
Old 08-24-2013, 06:21 PM   #5
sequimbob
LQ Newbie
 
Registered: Jul 2013
Location: On the road, Sequim, WA is home base
Distribution: Linux Mint 18 sarah Mate
Posts: 15

Original Poster
Rep: Reputation: Disabled
Yancik: I don't know why it would not work before but it now is working. I must have mistyped a cmd.
Doc CPU: The drives are named with upper case. I cannot change that for some reason. WIN 7 is where they were name and WIN 7 will not let me change the names to lower case. Any how, as I said, it is now working. Don't know what was wrong. Thanks for your answers. I will close this thread out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to Format USB Drive in the Terminal LXer Syndicated Linux News 0 08-01-2013 04:01 PM
blocking cdrom drive access and usb drive kalidoss Linux - Security 3 05-22-2012 11:27 PM
Wish to access files in USB pen drive in Ubuntu Linux Vasudevmukherjee Linux - Newbie 4 07-16-2010 02:59 PM
how to access files in USb flash drive riba43 SUSE / openSUSE 4 07-09-2007 04:34 AM
Access USB flash drive? Zeno McDohl Linux - Newbie 4 01-16-2006 01:47 PM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration