LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-27-2009, 08:53 AM   #1
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Rep: Reputation: 15
Lightbulb cacti graph not coming


hi, i have installed cacti-0.8.7d on my ubuntu-8.04 hardy.but whenever i try to create the graph for my device (here localhost 127.0.0.1) then following line im getting-
local host graph created
but im not seeing any graph.when i check my graph management for localhost-traffic-eth0 following line is coming as error

RRDTool Command:
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="localhost - Traffic - eth0" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="bytes per second" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
DEF:a="/opt/lampp/htdocs/cacti/rra/localhost_traffic_in_52.rrd":traffic_in:AVERAGE \
DEF:b="/opt/lampp/htdocs/cacti/rra/localhost_traffic_in_52.rrd":traffic_out:AVERAGE \
AREA:a#00CF00FF:"Inbound" \
GPRINT:a:LAST:" Current\:%8.2lf %s" \
GPRINT:a:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:a:MAX:"Maximum\:%8.2lf %s\n" \
COMMENT:"Total In\: 0 bytes\n" \
LINE1:b#002A97FF:"Outbound" \
GPRINT:b:LAST:"Current\:%8.2lf %s" \
GPRINT:b:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:b:MAX:"Maximum\:%8.2lf %s\n" \
COMMENT:"Total Out\: 0 bytes\n"
RRDTool Says:
ERROR: opening '/opt/lampp/htdocs/cacti/rra/localhost_traffic_in_52.rrd': No such file or directory
>>>>>please guide me how to solve fix this problem.Since too many days im nagging with this problem.
 
Old 04-27-2009, 12:05 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,647

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by gitecravirs View Post
hi, i have installed cacti-0.8.7d on my ubuntu-8.04 hardy.but whenever i try to create the graph for my device (here localhost 127.0.0.1) then following line im getting-
local host graph created
but im not seeing any graph.when i check my graph management for localhost-traffic-eth0 following line is coming as error

RRDTool Command:

ERROR: opening '/opt/lampp/htdocs/cacti/rra/localhost_traffic_in_52.rrd': No such file or directory
>>>>>please guide me how to solve fix this problem.Since too many days im nagging with this problem.
As the error says: the RRD file isn't there. You either missed some steps in the installation, or the user doesn't have read/write permissions to the directory where the .RRD file is.
 
Old 04-27-2009, 11:50 PM   #3
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TB0ne View Post
As the error says: the RRD file isn't there. You either missed some steps in the installation, or the user doesn't have read/write permissions to the directory where the .RRD file is.
my rra folder is in /opt/lampp/htdocs/cacti/rra, but nothing is there in rra. according to ur suggestion i need .rrd file in my rra but the question is how to get it? can u send me approprite .rrd file?
 
Old 04-28-2009, 09:32 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,647

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by gitecravirs View Post
my rra folder is in /opt/lampp/htdocs/cacti/rra, but nothing is there in rra. according to ur suggestion i need .rrd file in my rra but the question is how to get it? can u send me approprite .rrd file?
No, the RRD's are created by Cacti, and are very specific to the installations.

Re-read the installation instructions for Cacti...the RRD's must be created first, before they can be updated, and graphs generated from them. And as I suggested in my first post, check the permissions on that directory, and make sure the cacti user has full permissions to it.
 
Old 05-01-2009, 12:19 AM   #5
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TB0ne View Post
No, the RRD's are created by Cacti, and are very specific to the installations.

Re-read the installation instructions for Cacti...the RRD's must be created first, before they can be updated, and graphs generated from them. And as I suggested in my first post, check the permissions on that directory, and make sure the cacti user has full permissions to it.
i have again installed cacti onto my other system and im again getting the same error as i was getting earliar.this time i remember, i dint left any step in installing cacti with xampp( i installed xampp first because cacti needs php,mysql and apache).im still not getting the cacti graph and folling message are coming whenever i do graph management-----

RRDTool Command:
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="localhost - Traffic" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="bytes per second" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
AREA:#00CF00FF:"Inbound" \
GPRINT::LAST:" Current\:%8.2lf %s" \
GPRINT::AVERAGE:"Average\:%8.2lf %s" \
GPRINT::MAX:"Maximum\:%8.2lf %s\n" \
COMMENT:"Total In\: 0 bytes\n" \
LINE1:#002A97FF:"Outbound" \
GPRINT::LAST:"Current\:%8.2lf %s" \
GPRINT::AVERAGE:"Average\:%8.2lf %s" \
GPRINT::MAX:"Maximum\:%8.2lf %s\n" \
COMMENT:"Total Out\: 0 bytes\n"

RRDTool Says:

ERROR: parameter '#00CF00FF' does not represent a number in line AREA:#00CF00FF:Inbound
also some .rrd does not exist
-------------------------------------
>>> please tell me any relevant and significant answer to work-around this problem.
 
Old 05-01-2009, 09:06 AM   #6
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,647

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by gitecravirs View Post
i have again installed cacti onto my other system and im again getting the same error as i was getting earliar.this time i remember, i dint left any step in installing cacti with xampp( i installed xampp first because cacti needs php,mysql and apache).im still not getting the cacti graph and folling message are coming whenever i do graph management-----

RRDTool Says:

ERROR: parameter '#00CF00FF' does not represent a number in line AREA:#00CF00FF:Inbound
also some .rrd does not exist
-------------------------------------
>>> please tell me any relevant and significant answer to work-around this problem.
Well, it would have helped if you mentioned xampp earlier, since that is "relevant" to things. While cacti does need php, mysql and apache, xampp isn't required. This link

http://www.howtoforge.com/cacti_xampp_ubuntu

points to a howto for Cacti with xampp on Ubuntu. However, your error is pointing to something missing. Either the poller isn't CRON'ned, the permissions to the rrd directory or rrdtool are bad, or rrdtool isn't in your path.

Check the howto, and see if that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cacti ??? your_shadow03 Linux - Newbie 36 01-14-2009 09:43 PM
Cacti installation on Debian Sarge: create cacti database error Yahweee Debian 2 08-26-2008 06:35 AM
cacti graph not showing jdpl Linux - Server 2 09-06-2007 02:18 AM
Debian : Cacti graph coming up as blue Yahweee Debian 0 03-06-2007 08:14 AM
need help urgently!!! display not coming and error mesage coming when user is logging rddreamz Linux - Newbie 0 08-14-2003 11:11 AM


All times are GMT -5. The time now is 05:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration