LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2003, 12:29 PM   #1
carne
LQ Newbie
 
Registered: Jun 2001
Posts: 5

Rep: Reputation: 0
Question cable modem display problem


Dear Linux Users,

I use RH7.3 on a Dell laptop, with DHCP protocol. I have successfully used DHCP to connect to a network, but have had problems with displays using a cable modem.

I use a Motorola SB4200 cable modem with ATT (Comcast) broadband service. The broadband works perfectly with my Windows XP desktop. When I plug my laptop into the modem, using either Ethernet or USB, the connection works, using the 'eth0' interface. However, I cannot open any X-windows -
local or remote. For example, when I run 'emacs &', I get the error message:

$ Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :0
Check the DISPLAY variable or use '-d' .

I have 'DISPLAY=:0' and when I run 'xhost' I get the same two lines as above plus "unable to open display ':0' ".

My /etc/hosts file contains only the line

127.0.0.1 localhost.localdomain localhost

but there is a lot of information in the /etc/dhcpd/dhcpd-eth0.info file that seems useful.

Also when I do 'ssh' login to my network at work, I try to open an emacs terminal remotely, and get the different error message:

$ Xlib: connection to "work.xxxxx.edu:11.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
emacs: cannot convert to server work.xxxxx.edu:11.0.
....

If someon can point out a fix to this problem, I would greatly appreciate it.

Thanks,
carne
 
Old 02-18-2003, 07:09 PM   #2
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I would check to make sure that an instance of X isn't currently running or improperly shut down. You can do a

ps -a

to get all your running processes. Additionally, you can try (from command line) SHIFT+F7 to see if one's running. Also, I would run "netconfig" again just to make sure that everything is set up correctly with your configurations. Also, you could check in /var/log/XFree86.0.log for a more thorough explanation of what went right and wrong when trying to startx. That's another thing, try to just "startx" and see what it says instead of emacs & and what not. View the log file mentioned above as well and post anything suspicious. If any of this seems a bit basic I apologize, I always start with the basics first. Hopefully this helps some, and if not, maybe someone else will have some thoughts too.
 
Old 02-19-2003, 12:35 PM   #3
carne
LQ Newbie
 
Registered: Jun 2001
Posts: 5

Original Poster
Rep: Reputation: 0
Unhappy

Thanks for the response.


I checked the processes and there is only one X server running. I
ran netconfig, and set to use DHCP.

After starting the eth0 connection, the only new process is dhcpcd.


I get the following new output from 'dmesg':

hub.c: USB new device connect on bus1/1, assigned device number 2
usb.c: USB device 2 (vend/prod 0x7b2/0x4200) is not claimed by any active driver.
usb.c: registered new driver acm
acm.c: v0.21:USB Abstract Control Model driver for USB modems and ISDN adapters
CDCEther.c: CDCEther.c: v0.98.5 22 Sep 2001 Brad Hards and another
usb.c: registered new driver CDCEther
CDCEther.c: Ethernet information found at device configuration. This is broken.CDCEther.c: detected BULK OUT packets of size 64
usb.c: ignoring set_interface for dev 2, iface 0, alt 0
CDCEther.c: eth0: Motorola Corporation SB4200 USB Cable Modem 00080EC825A9 00:08:0E:C8:25:A9
CDCEther.c: eth0: set multicast filters
CDCEther.c: eth0: set multicast filters
CDCEther.c: eth0: set multicast filters
CDCEther.c: eth0: set too many MC filters, using allmulti

None of this prevents the connection from successfully working.
We now have the module CDCEther running.


The error line from /var/log/XFree86.0.log is:

AUDIT: Wed Feb 19 10:45:02 2003: 1359 X: client 14 rejected from local host


I checked the file /etc/resolve.conf and tried adding the lines

search attbi.com
nameserver xxx.xxx.xxx.x
nameserver xx.xxx.xx.x

(using numbers from the etc/dhcpd/dhcpd-eth0.info file) but this had no effect.

Finally, I ran 'hostname', and found that it had changed from 'localhost.localdomain' to the ATT hostname, which is
something like 'x0-0-00-00-0x-x0-00-x0' (not real characters), which is the correct hostname from the etc/dhcpd/dhcpd-eth0.info file.


The odd thing about this problem is that it persists *after* I turn off the eth0 connection. When I run 'hostname' I continue to get the ATT hostname. The only way to restore the ability to open X windows is the restart the computer.


Thanks for any help that can be offered,
carne
 
Old 02-19-2003, 02:22 PM   #4
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Okay, after you ran ps -a you found one instance of X running. Hit CTRL+ALT+F7 (or is it SHIFT+F7?--I'm not on my Linux box right now so I can't try it to make sure--someone will correct me though I'm sure) to go to that process and then logout of X. Or, if you've already rebooted then X should not be running (if you're set to boot to a command line). Now that X is not running, if you run a ps -a it should not be listed.

Your hostname that you're seeing was set by you in netconfig. The first question asking you what your hostname is, was really asking you what you want to call your computer. You can call it whatever you want (mine is frankenstein). Everything after that is regarding your ISP info.

Now, your /etc/resolv.conf shows the correct syntax, but I'm afraid you might have your DNS IPs (nameserver) not set up correctly. Contact your ISP and get all the information I listed in my previous post instead of what is listed in your etc/dhcpd/dhcpd-eth0.info file. Chances are your ISP will have more correct information.

The output from dmesg looks like it's not going to cause you any problems. It seems like you're starting an X session on boot up from your posts. This could be causing all the problems with X when you try to open it. Do a clean shutdown and restart then, do a ps -a again without opening anything. Is X running?

Last edited by Texicle; 02-19-2003 at 02:33 PM.
 
Old 02-19-2003, 03:35 PM   #5
lhiggins
Member
 
Registered: Jan 2003
Location: Sydney, Australia
Distribution: FedoraCore
Posts: 105

Rep: Reputation: 15
I dont know if this is going to help you at all. But if I have the same cable modem. it ran fine with my mandy 8/9. If I changed the network card that the modem was connected to, I had to cold boot my modem. Now my mandy box is connected to a switch which is connected to a router then to the modem.

Apart from that I wouldnt have a clue. That is quite a strange problem. Texicle seems to have it all figured out.

Last edited by lhiggins; 02-19-2003 at 03:40 PM.
 
Old 02-19-2003, 04:05 PM   #6
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by lhiggins
I dont know if this is going to help you at all. But if I have the same cable modem. it ran fine with my mandy 8/9. If I changed the network card that the modem was connected to, I had to cold boot my modem. Now my mandy box is connected to a switch which is connected to a router then to the modem.

Apart from that I wouldnt have a clue. That is quite a strange problem. Texicle seems to have it all figured out.
I completely forgot about the restarting of the cable modem! With my cable internet, I have to kill the power to the cable modem for a few seconds, then give it power again. This resets the cable modem and it will most likely help with the NIC. Thanks for posting this lhiggins! This just might be what does the trick!
 
Old 02-19-2003, 04:08 PM   #7
carne
LQ Newbie
 
Registered: Jun 2001
Posts: 5

Original Poster
Rep: Reputation: 0
Well, I seem to have got things working. Let me say that I have had all the DNS IPs correct, and that I have been able to use the eth0 connection before, it has simply been disrupting normal X functions.

Now for what seems to be the solution. I give credit to Texicle for the suggestion to try running netconfig. My way of login is

console login -> 'startx' -> start eth0 using 'rp3'

However, this was disrupting normal X display. So I ran /usr/sbin/netconfig from the *console* with no X running, and again set things to use DHCP. This time when I reboot and start X, everything works fine, even if I don't connect the USB cable until I'm ready to turn on eth0.

The only additional touch I made was to edit the /etc/sysconfig/network-scripts/ifcfg-eth0 that Red Hat provides. I changed "ONBOOT='yes' " to 'no', since I use a laptop and don't like to wait for an ethernet connection that isn't there when I have the cable uunplugged.

Thanks for everyone's help,
carne
 
Old 02-19-2003, 04:30 PM   #8
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I'm glad you got it all working
 
Old 02-20-2003, 02:33 AM   #9
lhiggins
Member
 
Registered: Jan 2003
Location: Sydney, Australia
Distribution: FedoraCore
Posts: 105

Rep: Reputation: 15
No problem texicle. Actually you have answered a question of mine before! So I tried to return the favour. This is what I love about linux. Everyone is eager to help each. Thanks to GNU and Linux there is a Operating System Community.

Last edited by lhiggins; 02-20-2003 at 02:35 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cable modem problem usman88 Linux - Newbie 3 04-08-2005 02:39 PM
problem with cable modem fatcatis Linux - Networking 0 05-04-2004 10:48 PM
Cable Modem Problem PLEASE HELP!!! mikey_man380 Linux - Networking 40 07-10-2003 08:44 PM
cable modem problem figadiablo Slackware 1 11-14-2002 11:31 PM
cable modem problem mrcracky Linux - Networking 0 01-02-2002 06:41 PM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration