LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2005, 07:26 AM   #1
aNthraXx
LQ Newbie
 
Registered: May 2005
Location: London, UK
Distribution: Knoppix 3.82
Posts: 5

Rep: Reputation: 0
Unhappy cable internet on knoppix 3.8.2


Hi, first of I would liek to say i am totally new to linux and dont really know anything about it. Sory if this has been asked before although i have searched the forum and tried suggestions but none have worked. I have downloaded knoppix v382 yesterday, and it looks great and i would like to use it but there is one problem, my internet wont work on it.

I have tried configuring the network cards (i have 2)
One which goes to the cable modem (onboard nic, i think this one is eth0)
and one which is connected to a winxp computer through a crossoveer cable (pci nic, i think it is eth1)
these are both wired connections

each time it asks
-use dhcp broadcast? [y/n]
if i press yess on either network card it fails to broadcast.

-please enter ip[ address for eth0
here i enter my ip address from the internet (is this right?) which is 82.xx.xxx.xx.

--please enter networtk mask for eth0
in windows it says "subnet mask" which is "255.255.248.0". i put that into the box? i dont tknwo if this is right,

--please enter broadbast address for eth0
i dont know what this is so i leave it blank

--please enter default gateway
in windows it says this is "82.44.200.1", so i put that in

--please enter nmameservers
al my nameservers are automatically put in, i dont know how this happens but they are "62.30.112.29, 192.117.134.19, 62.30.0.39" Because it is put in automatically i htoguth it had a connection to something..

then it does somehting in a command prompt, and then closes. there is no error message.

after doing all that i try using an internet application such as firefox or konquerer and it says looking up google.com... but eventually cannot find the site. or any other site.

on another thread it suggested to do this command in a box
"apt-get install dhcpcd" - that didnt work
and
"dhcpcd eth0" - this didnt work either.


from "connecting with blueyonder & a few other queries" thread (i cannot post the url) it suggests "ifdown eth0" and "dhclient eth0", i tried these on a root terminalbut it said bash: unknown command or something.
also in "blueyonder broadband" thread it says try "dhcpcd eth0" i tried this but again nothing happened there was an error.

all of the above information was probably useless and i was doign the wrong thing, but i would really like to test knoppix out. Could anyone help me with the dhcp stuff? what to put in etc. any help would be greatly apprechiated.
thanks in advance

Last edited by aNthraXx; 05-20-2005 at 09:23 AM.
 
Old 05-20-2005, 09:00 AM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
You could try "ifup eth0" and "pump -i eth0" to broadcast.
"ifconfig" will tell if it's configured and got an IP.
BTW, you shouldn't post your IP and the fact that you're running a semiconfigured linux. IMHO it's asking for trouble. Edit your real ip to xx.xx.xx.xx.
 
Old 05-20-2005, 09:25 AM   #3
aNthraXx
LQ Newbie
 
Registered: May 2005
Location: London, UK
Distribution: Knoppix 3.82
Posts: 5

Original Poster
Rep: Reputation: 0
thanks for the reply, i will try what you have suggested now. also a x'ed out my ip, thansk for the tip.
 
Old 05-20-2005, 10:20 AM   #4
aNthraXx
LQ Newbie
 
Registered: May 2005
Location: London, UK
Distribution: Knoppix 3.82
Posts: 5

Original Poster
Rep: Reputation: 0
i tried that and it said

"Operation failed".


 
Old 05-20-2005, 11:13 AM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Try following the directions here:
"How do I use a static IP address with the CD-Rom?"
http://www.knoppix.net/wiki/Network_...9_nameservers.
 
Old 05-21-2005, 05:16 AM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
The IP is static? Then dhcp is of little use and you might as well use the "nodhcp" cheatcode as well as follow the howto posted by craigevil
 
Old 05-21-2005, 05:50 AM   #7
aNthraXx
LQ Newbie
 
Registered: May 2005
Location: London, UK
Distribution: Knoppix 3.82
Posts: 5

Original Poster
Rep: Reputation: 0
thankyou for your replies,

the ip is not static, although it has been the same for ages. sometiomes it changes. in windows network properties it says i have a dhcp server, which is 62.3x.3x.1xx, is this of any use?
 
Old 05-21-2005, 06:12 AM   #8
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Are you sure the nic is detected correctly and have drivers? What does "dmesg |grep eth" say?
Reason I ask it is "Operation failed" should happen if the nic is ok.
What does "ifconfig" say?

You could also try adding to /etc/network/interfaces :
auto eth0
iface eth0 inet dhcp
and do "sudo /etc/init.d/networking restart"
 
Old 05-21-2005, 06:54 AM   #9
aNthraXx
LQ Newbie
 
Registered: May 2005
Location: London, UK
Distribution: Knoppix 3.82
Posts: 5

Original Poster
Rep: Reputation: 0
thankyou allf or your help, i am typing this on knoppix!!!!!

wohooo

thankyou again

im not quite sure how i did it, but those commands you gave me seemed to work (i cant copy and paste form the root terminal, if you showed me how i would paste the results)

thanks alot, aNthraXx
 
Old 05-21-2005, 06:48 PM   #10
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Glad it worked.
You can copy-paste in linux by copying with highlighting text and pasting with middle-mousebutton. With a 2-button mouse you paste by pressing both buttons simultaneously.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cable Internet Anyone? Murdock1979 Linux - Hardware 7 07-03-2005 05:38 PM
Knoppix- Cable Internet Issue iatemyfingers Linux - Networking 6 01-12-2005 10:32 PM
knoppix std cable net connection dakota0718 Conectiva 1 12-13-2004 02:00 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 12:48 PM
knoppix installed, but can't get cable modem to work bigredmed Linux - Networking 4 08-24-2003 01:05 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration