LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2011, 09:33 PM   #1
jbdean
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
building glibc/gcc


Hi,

No matter which glibc I use, I get the error that I need a compiler that supports visibility. I'm using 4.4.5, so it can't be too old.
What is the visibility for gnu, this is a compile for glibc.
Any glibc fails for the same reason. I can't compile an older version of gcc, more errors.
Is it possible to turn off the check for visibility?
 
Old 01-27-2011, 07:45 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,631

Rep: Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267
Welcome to LQ.

First : You cannot change the default glibc on an OS. Glibc is your system.
You will most possibly have to reinstall the OS, if you install a different glibc.


Building a glibc ( to a hidden location, please ) :
A build directory outside the source is required.

And the right configure options are required too :
cd build/
&& ../glibc-<version>/configure --prefix=/usr/local/glibc/ \
--disable-profile --enable-add-ons

( http://www.linuxfromscratch.org/lfs/...r06/glibc.html )

...

Last edited by knudfl; 01-27-2011 at 07:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem about building Glibc-2.5.1 linrizeng Linux From Scratch 1 12-20-2009 05:52 AM
glibc 2.5.1 building problem sergi6666 Linux From Scratch 0 08-10-2009 09:10 AM
one more error building GCC - related with the newer version of Glibc?? lfs63 Linux From Scratch 1 02-17-2008 09:20 AM
Problems building glibc-2.5 sorenp Slackware 6 10-12-2007 02:13 AM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare SUSE / openSUSE 3 11-29-2004 02:13 PM


All times are GMT -5. The time now is 08:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration