LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2009, 09:57 AM   #1
mh.morta
LQ Newbie
 
Registered: May 2009
Location: asia
Distribution: fedora 10
Posts: 9

Rep: Reputation: 0
Question bug


hello.
it is my first time I post to this site.
I have an question .
when I want to install fedora8 it show a bug .it is:
MP-BIOS bug :8254 timer not connected to IO-APIC.
what should I do to I solve this problem and if I haveto press a key when should I press it.
please help me,please.
bye bye.
 
Old 05-17-2009, 10:30 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
If you enter MP-BIOS bug :8254 timer not connected to IO-APIC fedora into http://google.com/linux

you will find a variety of explanations and solutions.

Adding acpi=noirq or noapic or nolapic to the kernel boot line seems to work.

Also, see here: http://www.linuxquestions.org/questi...02#post2924602

Welcome to LQ!
 
Old 05-17-2009, 12:09 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
You should also know that Fedora 8 is an old distribution, and no longer supported. (It's so old that support for Fedora 9 will be dropped next month!)

The latest release of Fedora (Fedora 11) should be available for downloading next week.

Fedora follows a fairly aggressive release schedule, with new releases every six to nine months, and support for any release more than one release less than the current release is usually terminated a month after the current release in made. (See https://fedoraproject.org/wiki/Releases/Schedule for details.)

As to your timer bug, you could also try the enable_8254_timer option on the GRUB kernel line. (I had a Gateway laptop that displayed that "bug" message, and that "enable" option fixed it.)

Here's a copy of the /boot/grub/grub.conf file I used on that laptop that I found in an old post of mine. (Note that I was using FC6 back then.)
Code:
$ sudo cat /boot/grub/grub.conf
 Password:
# grub.conf generated by anaconda
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,1)/splash.xpm.gz
#hiddenmenu
title Fedora Core (2.6.20-1.2948.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.20-1.2948.fc6.img
title Fedora Core (2.6.20-1.2948.fc6) when USB is connected
        root (hd1,2)
        kernel (hd1,2)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd1,2)/initrd-2.6.20-1.2948.fc6.img
title Fedora Core (2.6.20-1.2948.fc6) From USB
        root (hd0,1)
        kernel (hd0,1)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/USB_Fedora/Base rhgb quiet
        initrd (hd0,1)/initrd-2.6.20-1.2948.fc6.img
title WinXP
        rootnoverify (hd0,0)
        chainloader +1
title WinXP USB Connected
        rootnoverify (hd1,0)
        chainloader +1
 
Old 05-18-2009, 01:28 AM   #4
mh.morta
LQ Newbie
 
Registered: May 2009
Location: asia
Distribution: fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
hello.
before I used fc10 but when I wanted to install a package it showed that need many packages
and some of them were from fc10 and it should had them so I want to use fc8 .
do you have any idea to fix my fc10
thanks (PTrenholme)
Bye
 
Old 05-18-2009, 01:38 AM   #5
mh.morta
LQ Newbie
 
Registered: May 2009
Location: asia
Distribution: fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
and I forget to ask a question .
when I should type this note.
pleaseeeeeee help.
 
Old 05-18-2009, 01:39 AM   #6
mh.morta
LQ Newbie
 
Registered: May 2009
Location: asia
Distribution: fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
and Iforgot to ask another queston.
when I should type this text.
please answere me.
bye bye
 
Old 05-18-2009, 02:03 PM   #7
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Quote:
Originally Posted by mh.morta View Post
hello.
before I used fc10 but when I wanted to install a package it showed that need many packages
and some of them were from fc10 and it should had them so I want to use fc8 .
do you have any idea to fix my fc10
thanks (PTrenholme)
Bye
Depending on how you installed your Fedora 10 system, you may or may not have installed all the packages you needed to get some package running. When yum tells you that it needs to install some packages, well, that's because you need to install them.

In other word, there's nothing to "fix." Just let your system access the repositories over the Internet, and the needed packages will be downloaded.

Note that I can't be any more specific since you failed to include either the name of the package(s) that caused your problem or the packages you needed to install.

Quote:
and I forget to ask a question .
when I should type this note.
pleaseeeeeee help.
I don't understand the meaning of the above post you made. (For one thing, there is no question in the note. Perhaps you forgot the question mark?)
 
Old 05-18-2009, 02:14 PM   #8
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,072

Rep: Reputation: 384Reputation: 384Reputation: 384Reputation: 384
Quote:
Originally Posted by mh.morta View Post
and Iforgot to ask another queston.
when I should type this text.
please answere me.
bye bye
You also forgot that there's an "Edit" button. There's no need to post three in a row. Please, next time instead edit the post and add whatever else you need to add.
 
Old 05-19-2009, 04:57 AM   #9
mh.morta
LQ Newbie
 
Registered: May 2009
Location: asia
Distribution: fedora 10
Posts: 9

Original Poster
Rep: Reputation: 0
oh.
please excuse me I sent 3 replies and I didn't want to send 3 post
and also when I sent them it didn't show them.
please excuse me ,pleaseeeeeeee .
I'm sorry(PTrenhome and i92guboj).
and PTrenholme ,when I asked when Ishould type this not,my mean was
when I should type that code in your first reply?

Last edited by mh.morta; 05-19-2009 at 05:29 AM.
 
Old 05-19-2009, 11:47 AM   #10
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Ah. Sorry, I thought that it was clear that I was referring to th /boot/grub/grub.conf file contents. (Note the first line - the command - in the block.)

Anyhow, that output was, as I said, an example only. It was very specific to the old laptop that I discarded several years ago.

What I was suggesting was that you modify the kernel line in your GRUB configuration file to include the enable_8524_timer option. The point in the listing I posted was only to show you one way that the suggestion could be implemented.

Note, however, that GRUB includes a simple, keyboard only, editor that can be used to make temporary changes in your GRUB boot configuration file. (The instructions are printed at the bottom of the GRUB menu screen, and easily accessed by pressing the "Escape" key when the menu is first displayed.) So, to test a change to the GRUB configuration, just press "Escape" when the menu is displayed, use the arrow keys to select the OS boot line, and press "e" (or the equivalent key on your keyboard) to see the boot stanza for that OS. Then highlight the kernel line in that stanza, press "e" to edit it, add the enable_8524_timer option, press "Enter" to return the the full stanza listing, and then "b" to boot from the modified stanza to test it.

If the test is successful, you will then need to use whatever editor you wish to use to edit /boot/grub/grub.conf. (You must, of course, have "root" access to edit that file.)

The point in trying a temporary change is, of course, that, if it doesn't work, then your actual configuration file is unchanged so you're no worse-off then you were before you tried the change.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] Current pkgtools installpkg bug jazzor Slackware 7 04-16-2009 05:30 AM
dhcp bug or bug in my head belda Linux - Networking 2 01-26-2008 08:46 AM
LXer: 2008 CES: Bug Labs Introduces BUG, BUGbase. So Cool! LXer Syndicated Linux News 0 01-09-2008 01:21 AM
2038 bug-Is Debian Bug-Proof? deepclutch Debian 1 08-02-2007 10:59 AM
Free86 bug or nVidia bug?? ProtoformX Linux - Software 2 05-12-2004 02:38 AM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration