LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2015, 01:05 AM   #1
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Rep: Reputation: 19
Browser lags when browsing websites [high CPU usage]


Hi,

Whenever I open browser (any browser) and load websites (any website), it lags and CPU rate gets hiked. I think its due to the processor of the system.

System specs:


Intel(R) Pentium(R) 4 CPU 3.00GHz

RAM : 2 GiB

The modern websites need at least Core i3 processors to handle properly?

Or is it some other problem?

Thanks
 
Old 01-29-2015, 08:25 AM   #2
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
All websites use Javascript which is inherently single threading. Using a multicore/multithreaded processor won't make an ounce of difference.
Most websites these days are optimised for Google Chrome (or Chromium) and tend to lag on other browsers.

If a site is taking a ridiculous amount of time to load, and I'm only interested in the text then I load it on the command line in Lynx instead.
 
Old 01-29-2015, 08:26 AM   #3
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Which distro and which web browser you are using?

Opening multiple webpages loaded wih flash, scripts, images, videos of huge size with in multiple tabs makes a system unresponsive.

It happens in dual core i3 also.

Since Pentium is usually single core with propably hyper threading present so it happens with it also.

You can raise ram to 4GB.

Also use lightweight web browser based on webkit like epiphany or midori.

Also open a single or two webpage at a time.

Turn off videos, flash and even animated images.
 
Old 01-29-2015, 10:49 PM   #4
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by qlue View Post
All websites use Javascript which is inherently single threading. Using a multicore/multithreaded processor won't make an ounce of difference.
Most websites these days are optimised for Google Chrome (or Chromium) and tend to lag on other browsers.

If a site is taking a ridiculous amount of time to load, and I'm only interested in the text then I load it on the command line in Lynx instead.
But when I browse the same websites on a core i5 processors, I don't notice the delay.

---------- Post added 01-30-15 at 09:20 AM ----------

Quote:
Originally Posted by veerain View Post
Which distro and which web browser you are using?

Opening multiple webpages loaded wih flash, scripts, images, videos of huge size with in multiple tabs makes a system unresponsive.

It happens in dual core i3 also.

Since Pentium is usually single core with propably hyper threading present so it happens with it also.

You can raise ram to 4GB.

Also use lightweight web browser based on webkit like epiphany or midori.

Also open a single or two webpage at a time.

Turn off videos, flash and even animated images.
I use Cent OS 6.6 and Firefox. Even chromium lags when loading websites.
 
Old 01-30-2015, 04:13 AM   #5
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
Check your swappiness on the command line with the following command;
Code:
cat /proc/sys/vm/swappiness
The default is usually 60
Try setting it to 10 with this command;
Code:
sysctl vm.swappiness=10
Note: you must do this as root or you'll get a permission denied error message.

I suspect your machine is lagging because it is going into swap frequently. Increasing ram can reduce the problem if that is the case but reducing your swappiness can reduce the problem as well.
 
Old 01-30-2015, 04:21 AM   #6
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
There was a old trick for Firefox where temporary files are kept in a shared ram memory (tmpfs).
 
Old 01-30-2015, 05:51 AM   #7
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by qlue View Post
Check your swappiness on the command line with the following command;
Code:
cat /proc/sys/vm/swappiness
The default is usually 60
Try setting it to 10 with this command;
Code:
sysctl vm.swappiness=10
Note: you must do this as root or you'll get a permission denied error message.

I suspect your machine is lagging because it is going into swap frequently. Increasing ram can reduce the problem if that is the case but reducing your swappiness can reduce the problem as well.

Thanks. I can say that there is no issue with swappiness value. My swap is not being used. Just loading from RAM. Also, if I scroll the pages (All the browsers)the CPU usage increases and due to that the browser lags.
 
Old 01-30-2015, 06:02 AM   #8
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Go to about:config and disable javascript.

You could also try a lighter webkit-based browser (as mentioned, as long as you can live with the webkit bugs) or a light-weight distribution -- the ones based on BusyBox are very undemanding of hardware (SliTaz, TinyCore, etc).
 
Old 01-30-2015, 09:34 PM   #9
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Head_on_a_Stick View Post
Go to about:config and disable javascript.

You could also try a lighter webkit-based browser (as mentioned, as long as you can live with the webkit bugs) or a light-weight distribution -- the ones based on BusyBox are very undemanding of hardware (SliTaz, TinyCore, etc).
Thank you for the suggestion. I will try it. But when I browse websites on a higher end machine which has core i5 processor, I don't get any lag.
 
Old 01-30-2015, 10:17 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
How far are you from router?
Are you using wireless or wired?
What network are you using.
It may be your carrier.
 
Old 01-31-2015, 06:19 AM   #11
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,493

Rep: Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635
Seems to be a normal problem, I experienced the same.

http://www.linuxquestions.org/questi...wser+scripting

In the mean time I have upgraded to a fanless I7 processor. The lag is gone. Except for Flickr which brings even an I7 to a grinding halt.

jlinkels
 
Old 01-31-2015, 06:23 AM   #12
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Fanless processor are less fast than those with liquid cooling whether be it i7 or not.
 
Old 01-31-2015, 10:14 AM   #13
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,493

Rep: Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635
Put it a bit more subtle: it is true that I7 come in a lot of versions. Both in clock speed and architecture. Mine is a I7 4587T. Whatever that may mean. I have seen comparision charts were other I7 are faster.

Nevertheless this I7 is the perfect processor for me. I am running KDE with full graphic effects. I do not experience any slowness neither in KDE, not in any other desktop application.

Except for certain web pages in Firefox. But hey, making a process slow as molasses is not really difficult. I assume Flickr let decode their JPG pictures pixel by pixel in Javascript or so.

jlinkels
 
Old 01-31-2015, 10:54 AM   #14
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,017

Rep: Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622
Quote:
Originally Posted by veerain View Post
Fanless processor are less fast than those with liquid cooling whether be it i7 or not.
To be more accurate: Fanless processors of any given generation will likely be slower than those with active cooling (whether it is a fan or liquid makes no difference whatsoever) since fanless processors will be designed to run cool which more often than not will mean low voltage and slow.
 
Old 03-23-2015, 10:26 PM   #15
heyubob
LQ Newbie
 
Registered: Jan 2005
Location: Portland, Oregon (baja Canada)
Distribution: Fiesty Fawn-Meets-Brunching-Bear
Posts: 11

Rep: Reputation: 0
I used the above mentioned swappiness setting ((changing from 60 to 10) on a Dell Inspiriron 1150 (linuxMint) with 512k ram)). It worked Great! So, I set same to 5 and it works even better. I wonder though, could I get similar result with higher swappiness setting (w/o having to try all)? I am unsure just what is the trade-off with this method?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid 3 near 100% cpu usage and high RAM usage piman Linux - Software 1 11-16-2013 03:20 AM
mysql server not responding with high cpu usage and high load avgs landysaccount Linux - Server 2 09-15-2013 04:46 AM
[SOLVED] High CPU load, but low CPU usage (high idle CPU) baffy Linux - Newbie 5 03-13-2013 10:24 AM
High load and high cpu kernel usage enid Linux - Server 8 09-30-2010 04:33 AM
cpu usage lags the puter w/rh9 Goofee Linux - General 16 07-29-2003 04:20 PM


All times are GMT -5. The time now is 06:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration