LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2014, 02:02 PM   #1
newmintuser
Member
 
Registered: Jul 2014
Location: mojave desert
Posts: 33

Rep: Reputation: Disabled
broken packages


just downloaded and installed Linux mint 17 qiana cinnamon 64 on gateway laptop nv52. formerly had windows 7 premium.
drive was wiped with dban before installation with a couple non fatal errors. cinnamon is working great but downloaded packages for chromium and wine are broken and do not know how to fix. AS I said everything working great just -f install not working ...what else can I do or try. Also should I be reseting or changing the bios settings for the new system?
 
Old 09-07-2014, 02:23 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
It would help to know how you were installing your packages and what error messages you were receiving. Have you tried giving this command?
Code:
apt-get clean
and starting again?
jdk
 
Old 09-07-2014, 03:21 PM   #3
newmintuser
Member
 
Registered: Jul 2014
Location: mojave desert
Posts: 33

Original Poster
Rep: Reputation: Disabled
apt-get clean
E: Could not open lock file /var/cache/apt/archives/lock - open (13: Permission denied)
E: Unable to lock the download directory
 
Old 09-07-2014, 04:45 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
You'll need to switch to root (i.e. use sudo) to do "apt-get clean" -- you can't do it as a normal user.
 
Old 09-07-2014, 08:31 PM   #5
DMKz3
LQ Newbie
 
Registered: Sep 2014
Location: All your base, which are belong to us
Distribution: Desktop: Manjaro i3 Laptop: Debian Wheezy
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by newmintuser View Post
apt-get clean
E: Could not open lock file /var/cache/apt/archives/lock - open (13: Permission denied)
E: Unable to lock the download directory
The error "Permission denied" gives you a bit of reasoning why you couldn't use it. To use apt-get, make sure you're using it as root. For example:
Code:
sudo apt-get clean
or (depreciated with sudo as sudo runs the command with root privileges)
Code:
su root
apt-get clean
 
Old 09-07-2014, 08:53 PM   #6
newmintuser
Member
 
Registered: Jul 2014
Location: mojave desert
Posts: 33

Original Poster
Rep: Reputation: Disabled
Hello
I tried every combination of your post and all i get is this /usr/bin/sudo: /usr/bin/sudo: cannot execute binary file. after sudo root name changed red. does this mean anything
 
Old 09-07-2014, 10:01 PM   #7
DMKz3
LQ Newbie
 
Registered: Sep 2014
Location: All your base, which are belong to us
Distribution: Desktop: Manjaro i3 Laptop: Debian Wheezy
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by newmintuser View Post
Hello
I tried every combination of your post and all i get is this /usr/bin/sudo: /usr/bin/sudo: cannot execute binary file. after sudo root name changed red. does this mean anything
In that case, sudo is broken, use su root.
 
Old 09-10-2014, 09:10 PM   #8
newmintuser
Member
 
Registered: Jul 2014
Location: mojave desert
Posts: 33

Original Poster
Rep: Reputation: Disabled
su root apt-get clean
Password:
/usr/bin/apt-get: /usr/bin/apt-get: cannot execute binary file
thomas@thomas-NV52-Series ~ $ su root
Password:
thomas-NV52-Series thomas # apt-get clean
thomas-NV52-Series thomas #

Sorry for the delay, been very busy...Tried both ways and got the above........................did I get a bad distro??
 
Old 09-10-2014, 09:15 PM   #9
DMKz3
LQ Newbie
 
Registered: Sep 2014
Location: All your base, which are belong to us
Distribution: Desktop: Manjaro i3 Laptop: Debian Wheezy
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by newmintuser View Post
did I get a bad distro??
Sounds like you got a bad install. The best idea would be to reinstall.
 
Old 09-10-2014, 09:54 PM   #10
newmintuser
Member
 
Registered: Jul 2014
Location: mojave desert
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by DMKz3 View Post
Sounds like you got a bad install. The best idea would be to reinstall.
installed 4 times 2 with mate (was worse) and this is second time with cinnamon. This is the best one yet. could it be due to a slow internet connection or the mirror/torrent?? My down speed is maybe 1
 
Old 09-10-2014, 10:09 PM   #11
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Something is definitely wrong. Did you verify the download of the install media against its published checksum (MD5 or SHA)? Also, you might want to double check your hardware with memtest86+ and the SMART hard drive self test tools (see man smartctl for details).
 
Old 10-29-2014, 09:23 PM   #12
newmintuser
Member
 
Registered: Jul 2014
Location: mojave desert
Posts: 33

Original Poster
Rep: Reputation: Disabled
Hello again, I must apologize for the vanishing act but sometimes life changes your priorities for a while. Anyway I have appreciated all the help but nothing has worked so I got my hands on a good disk and am going to try to install again with it.

Here is the questions, 1- how do I properly check the md5 to ensure a good install (memtest is good) and I created a logical partition on my windows 7 pc labeled I drive, How do I install to that drive.

I know the pc is healthy so if I can install on my pc without anymore problems then I know its the laptop, or if both have problems it must be something I am doing wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
E: Broken packages ? golden_boy615 Linux - General 2 05-08-2010 08:48 PM
The following packages are BROKEN: pk_kala Ubuntu 4 11-08-2007 12:23 AM
Broken packages mcnearcj Ubuntu 3 08-01-2006 02:56 PM
Broken Packages hongman Linux - Software 2 04-13-2005 06:48 AM
Broken Packages Kujila Linux - Software 2 02-01-2004 06:07 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration