LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2014, 07:21 PM   #1
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Rep: Reputation: Disabled
Broken libglib on debian 6


So, some time ago I wanted to update mpd to the newest version which required a newer version of libglib, so I compiled them from source as I was on debian oldstable and couldn't find an easier way of doing that. For various reasons I didn't have access to that system again until now. When I tried to run mpd it gave me the following error:

Code:
mpd/usr/bin/mpd: symbol lookup error: /usr/bin/mpd: undefined symbol: g_malloc_n failed!
I tried reinstalling mpd but to no result, so then I tried to reinstall libglib but it gave me the following output:

Code:
 root@nibelung:~# apt-get --reinstall install libglib2.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libglib2.0-0' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dev' for regex 'libglib2.0'
Note, selecting 'libglib2.0-doc' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0-dbg' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dbg' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0-refdbg' for regex 'libglib2.0'
Note, selecting 'libglib2.0-data' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil-dev' for regex 'libglib2.0'
The following packages were automatically installed and are no longer required:
  libao-common libsamplerate0 libjack-jackd2-0 libwavpack1 libresid-builder0c2a libice6 libao4 libflac8 libshout3 libasyncns0 libxtst6 libsidplay2 x11-common libmad0 libid3tag0 libsm6 libpulse0 libxi6
  libmpcdec6 libsndfile1 libmms0 libaudiofile0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 8 reinstalled, 0 to remove and 0 not upgraded.
7 not fully installed or removed.
Need to get 0 B/6,964 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 55621 files and directories currently installed.)
Preparing to replace libglib2.0-0 2.24.2-1 (using .../libglib2.0-0_2.24.2-1_amd64.deb) ...
Unpacking replacement libglib2.0-0 ...
Preparing to replace libglib2.0-data 2.24.2-1 (using .../libglib2.0-data_2.24.2-1_all.deb) ...
Unpacking replacement libglib2.0-data ...
Preparing to replace libglib2.0-dev 2.24.2-1 (using .../libglib2.0-dev_2.24.2-1_amd64.deb) ...
Unpacking replacement libglib2.0-dev ...
Preparing to replace libglib2.0-doc 2.24.2-1 (using .../libglib2.0-doc_2.24.2-1_all.deb) ...
Unpacking replacement libglib2.0-doc ...
Preparing to replace libglib2.0-0-dbg 2.24.2-1 (using .../libglib2.0-0-dbg_2.24.2-1_amd64.deb) ...
Unpacking replacement libglib2.0-0-dbg ...
Preparing to replace libglib2.0-0-refdbg 2.24.2-1 (using .../libglib2.0-0-refdbg_2.24.2-1_amd64.deb) ...
Unpacking replacement libglib2.0-0-refdbg ...
Setting up mono-gac (2.6.7-5.1) ...
* Installing 1 assembly from libglib2.0-cil into Mono
/usr/bin/mono: symbol lookup error: /usr/bin/mono: undefined symbol: g_malloc0_n
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 144.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 113.
/usr/bin/mono: symbol lookup error: /usr/bin/mono: undefined symbol: g_malloc0_n
E: installing Assembly /usr/lib/cli/glib-sharp-2.0/glib-sharp.dll failed
E: Installation of libglib2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing mono-gac (--configure):
 subprocess installed post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of mono-runtime:
 mono-runtime depends on mono-gac (= 2.6.7-5.1); however:
  Package mono-gac is not configured yet.
dpkg: error processing mono-runtime (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-corlib2.0-cil:
 libmono-corlib2.0-cil depends on mono-runtime (>= 2.6.7); however:
  Package mono-runtime is not configured yet.
 libmono-corlib2.0-cil depends on mono-runtime (<< 2.6.8); however:
  Package mono-runtime is not configured yet.
dpkg: error processing libmono-corlib2.0-cil (--configure):
 dependency problems - leconfigured to not write apport reports
                                                               configured to not write apport reports
                                                                                                     configured to not write apport reports
                                                                                                                                           configured to not write apport reports
                                                                                                                                                                                 configured to not write apport reports
    configured to not write apport reports
                                          configured to not write apport reports
                                                                                aving unconfigured
dpkg: dependency problems prevent configuration of libmono-system2.0-cil:
 libmono-system2.0-cil depends on libmono-corlib2.0-cil (>= 2.6.3); however:
  Package libmono-corlib2.0-cil is not configured yet.
 libmono-system2.0-cil depends on mono-runtime (>= 2.6.7); however:
  Package mono-runtime is not configured yet.
 libmono-system2.0-cil depends on mono-runtime (<< 2.6.8); however:
  Package mono-runtime is not configured yet.
dpkg: error processing libmono-system2.0-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-posix2.0-cil:
 libmono-posix2.0-cil depends on libmono-corlib2.0-cil (>= 2.6.3); however:
  Package libmono-corlib2.0-cil is not configured yet.
 libmono-posix2.0-cil depends on libmono-system2.0-cil (>= 2.6.3); however:
  Package libmono-system2.0-cil is not configured yet.
 libmono-posix2.0-cil depends on mono-runtime (>= 2.4); however:
  Package mono-runtime is not configured yet.
dpkg: error processing libmono-posix2.0-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib2.0-cil:
 libglib2.0-cil depends on libmono-corlib2.0-cil (>= 1.2.2.1); however:
  Package libmono-corlib2.0-cil is not configured yet.
 libglib2.0-cil depends on libmono-system2.0-cil (>= 2.4.3); however:
  Package libmono-system2.0-cil is not configured yet.
dpkg: error processing libglib2.0-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib2.0-cil-dev:
 libglib2.0-cil-dev depends on libglib2.0-cil (= 2.12.10-1); however:
  Package libglib2.0-cil is not configured yet.
dpkg: error processing libglib2.0-cil-dev (--configure):
 dependency problems - leaving unconfigured
Setting up libglib2.0-0 (2.24.2-1) ...
Setting up libglib2.0-data (2.24.2-1) ...
Setting up libglib2.0-dev (2.24.2-1) ...
Setting up libglib2.0-doc (2.24.2-1) ...
Setting up libglib2.0-0-dbg (2.24.2-1) ...
Setting up libglib2.0-0-refdbg (2.24.2-1) ...
Errors were encountered while processing:
 mono-gac
 mono-runtime
 libmono-corlib2.0-cil
 libmono-system2.0-cil
 libmono-posix2.0-cil
 libglib2.0-cil
 libglib2.0-cil-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)
Because I didn't have access to the system for some time, I don't really remember what I did back then and I'm not sure how to revert it.
 
Old 02-26-2014, 12:11 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Can you post the contents of your /etc/apt/sources.list file.
You are clearly having dependency issues as you can see from the error messages. Is there any reason for using such an old version of Debian? In any event you can get the oldstable version of libglib2.0 which is version 2.24.2-1 so you don't really need to compile it from source.
jdk
 
Old 02-26-2014, 12:31 PM   #3
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
The reason I still have oldstable is because I'm using OpenMediaVault. Here's my sources file:

Code:
#

# deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130824-13:07]/ squeeze main non-free

#deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130824-13:07]/ squeeze main non-free

deb http://ftp.gr.debian.org/debian/ squeeze main
deb-src http://ftp.gr.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main non-free
deb-src http://security.debian.org/ squeeze/updates main non-free

# squeeze-updates, previously known as 'volatile'
deb http://ftp.gr.debian.org/debian/ squeeze-updates main non-free
deb-src http://ftp.gr.debian.org/debian/ squeeze-updates main non-free
deb http://backports.debian.org/debian-backports/ squeeze-backports main

Last edited by trelosae; 02-26-2014 at 12:32 PM.
 
Old 02-26-2014, 02:04 PM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
OpenMediaVault makes the following claim:
Quote:
Easy system updates via Debian package management
So can you explain why you are compiling these packages yourself rather than following their advice. You can install the version you wish using the normal package management.
jdk
 
Old 02-26-2014, 02:24 PM   #5
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
Well, the thing is I wanted mpd 1.6 which required libglib >= 2.31.8 on amd64, which I couldn't get via apt-get, as oldstable goes up to 2.24.2.

Quote:
You can install the version you wish using the normal package management.
I can't do that. When I tried that, it gave the errors in the first post. I have tried apt-get check to fix any broken deps but apt doesn't seem to find any.

Last edited by trelosae; 02-26-2014 at 03:31 PM.
 
Old 02-26-2014, 04:47 PM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
But in your first post you presented a reinstall. So that means the package was already installed. Why did you want to reinstall it?
jdk
 
Old 02-26-2014, 05:02 PM   #7
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
I'm sorry, I wasn't clear. Having mpd installed I had libglib installed too. My first attempt was to try and install libglib but apt tried to install some additional libglib packages (such as libglib2.0-dev or libglib2.0-doc) and reported libglib to be at the newest version, also giving me the following error which is very similar with the one from the reinstall:

Code:
* Installing 1 assembly from libglib2.0-cil into Mono
/usr/bin/mono: symbol lookup error: /usr/bin/mono: undefined symbol: g_malloc0_n
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 144.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 113.
/usr/bin/mono: symbol lookup error: /usr/bin/mono: undefined symbol: g_malloc0_n
The installation failed of course giving output very similar to the output given by the reinstall.
 
Old 02-27-2014, 01:17 AM   #8
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
And does your system now report broken packages? If so, which ones?
jdk
 
Old 02-27-2014, 07:29 AM   #9
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
apt-get check doesn't return anything. I should mention that I just found some libglib files in /usr/local/lib and I suspect they may be from me.

Code:
root@nibelung:~# ls -la /usr/local/lib
total 23284
drwxrwsr-x  9 root staff     4096 Jan 24 21:23 .
drwxrwsr-x 10 root staff     4096 Sep 27 01:59 ..
drwxr-sr-x  3 root staff     4096 Dec 16 05:30 glib-2.0
-rwxr-xr-x  1 root staff      902 Dec 16 05:30 libgio-2.0.la
lrwxrwxrwx  1 root staff       19 Dec 16 05:30 libgio-2.0.so -> libgio-2.0.so.0.0.0
lrwxrwxrwx  1 root staff       19 Dec 16 05:30 libgio-2.0.so.0 -> libgio-2.0.so.0.0.0
-rwxr-xr-x  1 root staff  1784924 Dec 16 05:30 libgio-2.0.so.0.0.0
-rwxr-xr-x  1 root staff      816 Dec 16 05:30 libglib-2.0.la
lrwxrwxrwx  1 root staff       23 Dec 16 05:30 libglib-2.0.so -> libglib-2.0.so.0.1600.6
lrwxrwxrwx  1 root staff       23 Dec 16 05:30 libglib-2.0.so.0 -> libglib-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff  2839105 Dec 16 05:30 libglib-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff      869 Dec 16 05:30 libgmodule-2.0.la
lrwxrwxrwx  1 root staff       26 Dec 16 05:30 libgmodule-2.0.so -> libgmodule-2.0.so.0.1600.6
lrwxrwxrwx  1 root staff       26 Dec 16 05:30 libgmodule-2.0.so.0 -> libgmodule-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff    33897 Dec 16 05:30 libgmodule-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff      864 Dec 16 05:30 libgobject-2.0.la
lrwxrwxrwx  1 root staff       26 Dec 16 05:30 libgobject-2.0.so -> libgobject-2.0.so.0.1600.6
lrwxrwxrwx  1 root staff       26 Dec 16 05:30 libgobject-2.0.so.0 -> libgobject-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff   951131 Dec 16 05:30 libgobject-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff      879 Dec 16 05:30 libgthread-2.0.la
lrwxrwxrwx  1 root staff       26 Dec 16 05:30 libgthread-2.0.so -> libgthread-2.0.so.0.1600.6
lrwxrwxrwx  1 root staff       26 Dec 16 05:30 libgthread-2.0.so.0 -> libgthread-2.0.so.0.1600.6
-rwxr-xr-x  1 root staff    47492 Dec 16 05:30 libgthread-2.0.so.0.1600.6
 
Old 02-27-2014, 09:44 AM   #10
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by trelosae View Post
apt-get check doesn't return anything. I should mention that I just found some libglib files in /usr/local/lib and I suspect they may be from me.
Yes, if "from me" means "files that are the result of your own compilation. You can always try to remove the broken packages and then install them (not reinstall) them.
jdk
 
Old 02-27-2014, 10:03 AM   #11
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
I would do that, but a lot of stuff depends on glib, and removing it would remove them too. Is there any way to remove the problematic packages without removing everything that depends on them?
 
Old 02-27-2014, 10:34 AM   #12
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
You can do a simulation (in aptitude it's the -s option) of removing glib without actually removing it. That will give you an idea of what other packages would be removed. It's not a big deal to copy that list and then paste it back into a future command installing all the files that were removed when you removed glib.
jdk
 
1 members found this post helpful.
Old 02-27-2014, 11:31 AM   #13
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
Just to make sure, removing the packages won't delete their settings, right?
 
Old 02-27-2014, 02:12 PM   #14
trelosae
LQ Newbie
 
Registered: Feb 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
So I tried removing libglib, but this happened:

Code:
root@nibelung:~# apt-get -s remove libglib2.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libtalloc2 hdparm php5-proctitle proftpd-basic libunistring0 bind9-host libiceutil33 libsensors4
  libfile-copy-recursive-perl libsnmp15 lsof lvm2 whiptail libprotobuf6 libxml-parser-perl
  liburi-perl libhtml-parser-perl libparted0debian1 xmlstarlet update-inetd apache2-suexec tftpd-hpa
  gdisk libdbi0 libdns69 libjson-perl libwbclient0 libcpufreq0 groff-base quota quotatool beep
  cron-apt libthai-data socat parted libisccc60 libsnmp-base ifenslave-2.6 libnss-mdns
  libhtml-tree-perl libdatrie1 fontconfig libavahi-common-data sdparm libavahi-core7 samba-common
  libapache2-mod-fcgid snmpd libupsclient1 libpango1.0-common php-json-schema liblwres60
  libjs-extjs4 collectd-core libcups2 libssh2-1-dev cpufrequtils scponly libnfnetlink0 smartmontools
  libxft2 libthai0 libbind9-60 libntfs-3g75 liblocale-po-perl wget nut libjavascript-minifier-perl
  samba uuid libcap-ng0 libperl5.10 libnewt0.52 monit libdaemon0 libisccfg62 libnl1 avahi-daemon
  libzeroc-ice33 libavahi-client3 watchdog libavahi-compat-libdnssd1 libhtml-tagset-perl
  samba-common-bin libwww-perl libisc62 defoma libavahi-common3 iptables ntfs-3g libltdl7 php5-pam
  libldap2-dev
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  collectd gettext intltool libatk1.0-0 libcroco3 libcurl4-openssl-dev libdbus-glib-1-2 libglib2.0-0
  libglib2.0-0-dbg libglib2.0-0-refdbg libglib2.0-cil libglib2.0-cil-dev libglib2.0-data
  libglib2.0-dev libgsf-1-114 libidn11-dev libmono-corlib2.0-cil libmono-posix2.0-cil
  libmono-security2.0-cil libmono-system2.0-cil libpango1.0-0 libqt4-dbus libqt4-network libqt4-sql
  libqt4-sql-sqlite libqt4-xml libqtcore4 librrd4 libsigc++-2.0-dev mono-2.0-gac mono-gac
  mono-runtime mumble-server openmediavault openmediavault-nut openmediavault-omvextrasorg
  openmediavault-processlist pkg-config python-dbus python-gobject rrdtool
0 upgraded, 0 newly installed, 41 to remove and 0 not upgraded.
7 not fully installed or removed.
Remv libglib2.0-cil-dev [2.12.10-1]
Remv libglib2.0-cil [2.12.10-1]
Remv libmono-posix2.0-cil [2.6.7-5.1] [libmono-system2.0-cil:amd64 ]
Remv libmono-system2.0-cil [2.6.7-5.1] [libmono-security2.0-cil:amd64 ]
Remv libmono-corlib2.0-cil [2.6.7-5.1] [libmono-security2.0-cil:amd64 mono-2.0-gac:amd64 ]
Remv mono-runtime [2.6.7-5.1] [libmono-security2.0-cil:amd64 mono-2.0-gac:amd64 ]
Remv mono-gac [2.6.7-5.1] [libmono-security2.0-cil:amd64 mono-2.0-gac:amd64 ]
Remv mono-2.0-gac [2.6.7-5.1] [libmono-security2.0-cil:amd64 ]
Remv libmono-security2.0-cil [2.6.7-5.1]
Remv openmediavault-nut [0.5.9]
Remv openmediavault-processlist [0.5.6]
Remv openmediavault-omvextrasorg [0.5.39]
Remv openmediavault [0.5.35]
Remv collectd [4.10.1-1+squeeze2]
Remv intltool [0.41.1-1]
Remv gettext [0.18.1.1-3]
Remv libatk1.0-0 [1.30.0-1]
Remv libcroco3 [0.6.2-1]
Remv libcurl4-openssl-dev [7.21.0-2.1+squeeze7]
Remv python-dbus [0.83.1-1]
Remv libdbus-glib-1-2 [0.88-2.1+squeeze1]
Remv rrdtool [1.4.3-1]
Remv librrd4 [1.4.3-1]
Remv mumble-server [1.2.2-6+squeeze1]
Remv libqt4-dbus [4:4.6.3-4+squeeze1]
Remv libqt4-xml [4:4.6.3-4+squeeze1]
Remv libqt4-sql-sqlite [4:4.6.3-4+squeeze1]
Remv libqt4-sql [4:4.6.3-4+squeeze1]
Remv libqt4-network [4:4.6.3-4+squeeze1]
Remv libqtcore4 [4:4.6.3-4+squeeze1]
Remv python-gobject [2.21.4+is.2.21.3-1]
Remv libsigc++-2.0-dev [2.2.4.2-1]
Remv libidn11-dev [1.15-2]
Remv libglib2.0-dev [2.24.2-1]
Remv pkg-config [0.25-1.1]
Remv libpango1.0-0 [1.28.3-1+squeeze2]
Remv libgsf-1-114 [1.14.18-1]
Remv libglib2.0-data [2.24.2-1]
Remv libglib2.0-0-refdbg [2.24.2-1]
Remv libglib2.0-0-dbg [2.24.2-1]
Remv libglib2.0-0 [2.24.2-1]
root@nibelung:~# apt-get remove libglib2.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libtalloc2 hdparm php5-proctitle proftpd-basic libunistring0 bind9-host libiceutil33 libsensors4
  libfile-copy-recursive-perl libsnmp15 lsof lvm2 whiptail libprotobuf6 libxml-parser-perl
  liburi-perl libhtml-parser-perl libparted0debian1 xmlstarlet update-inetd apache2-suexec tftpd-hpa
  gdisk libdbi0 libdns69 libjson-perl libwbclient0 libcpufreq0 groff-base quota quotatool beep
  cron-apt libthai-data socat parted libisccc60 libsnmp-base ifenslave-2.6 libnss-mdns
  libhtml-tree-perl libdatrie1 fontconfig libavahi-common-data sdparm libavahi-core7 samba-common
  libapache2-mod-fcgid snmpd libupsclient1 libpango1.0-common php-json-schema liblwres60
  libjs-extjs4 collectd-core libcups2 libssh2-1-dev cpufrequtils scponly libnfnetlink0 smartmontools
  libxft2 libthai0 libbind9-60 libntfs-3g75 liblocale-po-perl wget nut libjavascript-minifier-perl
  samba uuid libcap-ng0 libperl5.10 libnewt0.52 monit libdaemon0 libisccfg62 libnl1 avahi-daemon
  libzeroc-ice33 libavahi-client3 watchdog libavahi-compat-libdnssd1 libhtml-tagset-perl
  samba-common-bin libwww-perl libisc62 defoma libavahi-common3 iptables ntfs-3g libltdl7 php5-pam
  libldap2-dev
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  collectd gettext intltool libatk1.0-0 libcroco3 libcurl4-openssl-dev libdbus-glib-1-2 libglib2.0-0
  libglib2.0-0-dbg libglib2.0-0-refdbg libglib2.0-cil libglib2.0-cil-dev libglib2.0-data
  libglib2.0-dev libgsf-1-114 libidn11-dev libmono-corlib2.0-cil libmono-posix2.0-cil
  libmono-security2.0-cil libmono-system2.0-cil libpango1.0-0 libqt4-dbus libqt4-network libqt4-sql
  libqt4-sql-sqlite libqt4-xml libqtcore4 librrd4 libsigc++-2.0-dev mono-2.0-gac mono-gac
  mono-runtime mumble-server openmediavault openmediavault-nut openmediavault-omvextrasorg
  openmediavault-processlist pkg-config python-dbus python-gobject rrdtool
0 upgraded, 0 newly installed, 41 to remove and 0 not upgraded.
7 not fully installed or removed.
After this operation, 69.1 MB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 55520 files and directories currently installed.)
Removing libglib2.0-cil-dev ...
Removing libglib2.0-cil ...
E: File does not exist: /usr/share/cli-common/packages.d/policy.2.6.glib-sharp.installcligac
dpkg: error processing libglib2.0-cil (--remove):
 subprocess installed post-removal script returned error exit status 1
configured to not write apport reports
                                      Removing libmono-posix2.0-cil ...
Removing mono-runtime ...
Removing mono-gac ...
* Removing packages from mono
Removing mono-2.0-gac ...
Removing libmono-security2.0-cil ...
Removing openmediavault-nut ...
Reinitializing monit daemon
Stopping Network UPS Tools: driver(s) upsd upsmon.
Stopping Network UPS Tools: driver(s) upsd upsmon.
update-rc.d: using dependency based boot sequencing
update-rc.d: using dependency based boot sequencing
update-rc.d: error: no runlevel symlinks to modify, aborting!
Removing openmediavault-processlist ...
insserv: warning: current start runlevel(s) (empty) of script `nut' overwrites defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `nut' overwrites defaults (0 1 6).
Removing openmediavault-omvextrasorg ...
Removing openmediavault ...
Removing collectd ...
Removing intltool ...
Removing gettext ...
Removing libatk1.0-0 ...
Removing libcroco3 ...
Removing libcurl4-openssl-dev ...
Removing python-dbus ...
Removing libdbus-glib-1-2 ...
Removing rrdtool ...
Removing librrd4 ...
Removing mumble-server ...
Removing libqt4-dbus ...
Removing libqt4-xml ...
Removing libqt4-sql-sqlite ...
Removing libqt4-sql ...
Removing libqt4-network ...
Removing libqtcore4 ...
Removing python-gobject ...
Removing libsigc++-2.0-dev ...
Removing libidn11-dev ...
Removing libglib2.0-dev ...
Removing pkg-config ...
Removing libpango1.0-0 ...
Removing libgsf-1-114 ...
Removing libglib2.0-data ...
Removing libglib2.0-0-refdbg ...
Removing libglib2.0-0-dbg ...
Removing libglib2.0-0 ...
Removing libmono-system2.0-cil ...
Removing libmono-corlib2.0-cil ...
Processing triggers for python-support ...
Errors were encountered while processing:
 libglib2.0-cil
E: Sub-process /usr/bin/dpkg returned an error code (1)
So I identified libglib2.0-cil as the troublemaker, and after some googling I manually removed it with:

Code:
root@nibelung:~# mv /var/lib/dpkg/info/libglib2.0-cil.* /tmp/
root@nibelung:~# dpkg --remove --force-remove-reinstreq libglib2.0-cil
Then I tried reinstalling all the removed packages but this happened:

Code:
root@nibelung:~# apt-get install collectd gettext intltool libatk1.0-0 libcroco3 libcurl4-openssl-dev libdbus-glib-1-2 libglib2.0-0 libglib2.0-0-dbg libglib2.0-0-refdbg libglib2.0-cil libglib2.0-cil-dev libglib2.0-data libglib2.0-dev libgsf-1-114 libidn11-dev libmono-corlib2.0-cil libmono-posix2.0-cil libmono-security2.0-cil libmono-system2.0-cil libpango1.0-0 libqt4-dbus libqt4-network libqt4-sql libqt4-sql-sqlite libqt4-xml libqtcore4 librrd4 libsigc++-2.0-dev mono-2.0-gac mono-gac mono-runtime mumble-server openmediavault pkg-config python-dbus python-gobject rrdtool                                    Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  nut
Use 'apt-get autoremove' to remove them.
Suggested packages:
  gettext-doc libcurl3-dbg monodoc-gtk2.0-manual libmono-i18n2.0-cil libgamin0 libgdiplus
  libmono-winforms2.0-cil libqt4-dev libsigc++-2.0-doc mumble-server-web mumble-django
  python-dbus-doc python-dbus-dbg python-gobject-dbg librrds-perl
Recommended packages:
  libesmtp5 libgtk2.0-0 libhal1 libmemcached5 libmysqlclient16 libnotify1 libnotify1-gtk2.10
  libopenipmi0 liboping0 libpcap0.8 libprotobuf-c0 libtokyotyrant3 libvirt0 libyajl1 autopoint
  libatk1.0-data shared-mime-info libmono-i18n-west2.0-cil ttf-dejavu ttf-bitstream-vera
  binfmt-support
The following NEW packages will be installed:
  collectd gettext intltool libatk1.0-0 libcroco3 libcurl4-openssl-dev libdbus-glib-1-2 libglib2.0-0
  libglib2.0-0-dbg libglib2.0-0-refdbg libglib2.0-cil libglib2.0-cil-dev libglib2.0-data
  libglib2.0-dev libgsf-1-114 libidn11-dev libmono-corlib2.0-cil libmono-posix2.0-cil
  libmono-security2.0-cil libmono-system2.0-cil libpango1.0-0 libqt4-dbus libqt4-network libqt4-sql
  libqt4-sql-sqlite libqt4-xml libqtcore4 librrd4 libsigc++-2.0-dev mono-2.0-gac mono-gac
  mono-runtime mumble-server openmediavault pkg-config python-dbus python-gobject rrdtool
0 upgraded, 38 newly installed, 0 to remove and 0 not upgraded.
Need to get 22.0 MB of archives.
After this operation, 68.2 MB of additional disk space will be used.
Get:1 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-0 amd64 2.24.2-1 [1,122 kB]
Get:2 http://packages.openmediavault.org/public/ sardaukar/main openmediavault all 0.5.35 [1,086 kB]
Get:3 http://ftp.gr.debian.org/debian/ squeeze/main libpango1.0-0 amd64 1.28.3-1+squeeze2 [330 kB]
Get:4 http://ftp.gr.debian.org/debian/ squeeze/main librrd4 amd64 1.4.3-1 [319 kB]
Get:5 http://ftp.gr.debian.org/debian/ squeeze/main collectd amd64 4.10.1-1+squeeze2 [66.7 kB]
Get:6 http://ftp.gr.debian.org/debian/ squeeze/main libcroco3 amd64 0.6.2-1 [125 kB]
Get:7 http://ftp.gr.debian.org/debian/ squeeze/main gettext amd64 0.18.1.1-3 [2,076 kB]
Get:8 http://ftp.gr.debian.org/debian/ squeeze/main intltool all 0.41.1-1 [104 kB]
Get:9 http://ftp.gr.debian.org/debian/ squeeze/main libatk1.0-0 amd64 1.30.0-1 [88.3 kB]
Get:10 http://ftp.gr.debian.org/debian/ squeeze/main pkg-config amd64 0.25-1.1 [59.2 kB]
Get:11 http://ftp.gr.debian.org/debian/ squeeze/main libidn11-dev amd64 1.15-2 [629 kB]
Get:12 http://ftp.gr.debian.org/debian/ squeeze/main libcurl4-openssl-dev amd64 7.21.0-2.1+squeeze7 [1,100 kB]
Get:13 http://ftp.gr.debian.org/debian/ squeeze/main libdbus-glib-1-2 amd64 0.88-2.1+squeeze1 [173 kB]
Get:14 http://ftp.gr.debian.org/debian/ squeeze/main libmono-posix2.0-cil all 2.6.7-5.1 [110 kB]
Get:15 http://ftp.gr.debian.org/debian/ squeeze/main libmono-system2.0-cil all 2.6.7-5.1 [1,572 kB]
Get:16 http://ftp.gr.debian.org/debian/ squeeze/main libmono-security2.0-cil all 2.6.7-5.1 [153 kB]
Get:17 http://ftp.gr.debian.org/debian/ squeeze/main mono-2.0-gac all 2.6.7-5.1 [48.6 kB]
Get:18 http://ftp.gr.debian.org/debian/ squeeze/main mono-gac all 2.6.7-5.1 [40.0 kB]
Get:19 http://ftp.gr.debian.org/debian/ squeeze/main mono-runtime amd64 2.6.7-5.1 [1,406 kB]
Get:20 http://ftp.gr.debian.org/debian/ squeeze/main libmono-corlib2.0-cil all 2.6.7-5.1 [927 kB]
Get:21 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-cil amd64 2.12.10-1 [185 kB]
Get:22 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-cil-dev amd64 2.12.10-1 [140 kB]
Get:23 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-data all 2.24.2-1 [994 kB]
Get:24 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-dev amd64 2.24.2-1 [1,273 kB]
Get:25 http://ftp.gr.debian.org/debian/ squeeze/main libgsf-1-114 amd64 1.14.18-1 [162 kB]
Get:26 http://ftp.gr.debian.org/debian/ squeeze/main libqtcore4 amd64 4:4.6.3-4+squeeze1 [2,503 kB]
Get:27 http://ftp.gr.debian.org/debian/ squeeze/main libqt4-xml amd64 4:4.6.3-4+squeeze1 [145 kB]
Get:28 http://ftp.gr.debian.org/debian/ squeeze/main libqt4-dbus amd64 4:4.6.3-4+squeeze1 [267 kB]
Get:29 http://ftp.gr.debian.org/debian/ squeeze/main libqt4-network amd64 4:4.6.3-4+squeeze1 [542 kB]
Get:30 http://ftp.gr.debian.org/debian/ squeeze/main libqt4-sql amd64 4:4.6.3-4+squeeze1 [146 kB]
Get:31 http://ftp.gr.debian.org/debian/ squeeze/main libqt4-sql-sqlite amd64 4:4.6.3-4+squeeze1 [53.3 kB]
Get:32 http://ftp.gr.debian.org/debian/ squeeze/main libsigc++-2.0-dev amd64 2.2.4.2-1 [113 kB]
Get:33 http://ftp.gr.debian.org/debian/ squeeze/main mumble-server amd64 1.2.2-6+squeeze1 [815 kB]
Get:34 http://ftp.gr.debian.org/debian/ squeeze/main rrdtool amd64 1.4.3-1 [459 kB]
Get:35 http://ftp.gr.debian.org/debian/ squeeze/main python-dbus amd64 0.83.1-1 [237 kB]
Get:36 http://ftp.gr.debian.org/debian/ squeeze/main python-gobject amd64 2.21.4+is.2.21.3-1 [446 kB]
Get:37 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-0-dbg amd64 2.24.2-1 [1,484 kB]
Get:38 http://ftp.gr.debian.org/debian/ squeeze/main libglib2.0-0-refdbg amd64 2.24.2-1 [489 kB]
Fetched 22.0 MB in 18s (1,192 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously deselected package libglib2.0-0.
(Reading database ... 53222 files and directories currently installed.)
Unpacking libglib2.0-0 (from .../libglib2.0-0_2.24.2-1_amd64.deb) ...
Selecting previously deselected package libpango1.0-0.
Unpacking libpango1.0-0 (from .../libpango1.0-0_1.28.3-1+squeeze2_amd64.deb) ...
Selecting previously deselected package librrd4.
Unpacking librrd4 (from .../librrd4_1.4.3-1_amd64.deb) ...
Selecting previously deselected package collectd.
Unpacking collectd (from .../collectd_4.10.1-1+squeeze2_amd64.deb) ...
Selecting previously deselected package libcroco3.
Unpacking libcroco3 (from .../libcroco3_0.6.2-1_amd64.deb) ...
Selecting previously deselected package gettext.
Unpacking gettext (from .../gettext_0.18.1.1-3_amd64.deb) ...
Selecting previously deselected package intltool.
Unpacking intltool (from .../intltool_0.41.1-1_all.deb) ...
Selecting previously deselected package libatk1.0-0.
Unpacking libatk1.0-0 (from .../libatk1.0-0_1.30.0-1_amd64.deb) ...
Selecting previously deselected package pkg-config.
Unpacking pkg-config (from .../pkg-config_0.25-1.1_amd64.deb) ...
Selecting previously deselected package libidn11-dev.
Unpacking libidn11-dev (from .../libidn11-dev_1.15-2_amd64.deb) ...
Selecting previously deselected package libcurl4-openssl-dev.
Unpacking libcurl4-openssl-dev (from .../libcurl4-openssl-dev_7.21.0-2.1+squeeze7_amd64.deb) ...
Selecting previously deselected package libdbus-glib-1-2.
Unpacking libdbus-glib-1-2 (from .../libdbus-glib-1-2_0.88-2.1+squeeze1_amd64.deb) ...
Selecting previously deselected package libmono-posix2.0-cil.
Unpacking libmono-posix2.0-cil (from .../libmono-posix2.0-cil_2.6.7-5.1_all.deb) ...
Selecting previously deselected package libmono-system2.0-cil.
Unpacking libmono-system2.0-cil (from .../libmono-system2.0-cil_2.6.7-5.1_all.deb) ...
Selecting previously deselected package libmono-security2.0-cil.
Unpacking libmono-security2.0-cil (from .../libmono-security2.0-cil_2.6.7-5.1_all.deb) ...
Selecting previously deselected package mono-2.0-gac.
Unpacking mono-2.0-gac (from .../mono-2.0-gac_2.6.7-5.1_all.deb) ...
Selecting previously deselected package mono-gac.
Unpacking mono-gac (from .../mono-gac_2.6.7-5.1_all.deb) ...
Selecting previously deselected package mono-runtime.
Unpacking mono-runtime (from .../mono-runtime_2.6.7-5.1_amd64.deb) ...
Selecting previously deselected package libmono-corlib2.0-cil.
Unpacking libmono-corlib2.0-cil (from .../libmono-corlib2.0-cil_2.6.7-5.1_all.deb) ...
Selecting previously deselected package libglib2.0-cil.
Unpacking libglib2.0-cil (from .../libglib2.0-cil_2.12.10-1_amd64.deb) ...
Selecting previously deselected package libglib2.0-cil-dev.
Unpacking libglib2.0-cil-dev (from .../libglib2.0-cil-dev_2.12.10-1_amd64.deb) ...
Selecting previously deselected package libglib2.0-data.
Unpacking libglib2.0-data (from .../libglib2.0-data_2.24.2-1_all.deb) ...
Selecting previously deselected package libglib2.0-dev.
Unpacking libglib2.0-dev (from .../libglib2.0-dev_2.24.2-1_amd64.deb) ...
Selecting previously deselected package libgsf-1-114.
Unpacking libgsf-1-114 (from .../libgsf-1-114_1.14.18-1_amd64.deb) ...
Selecting previously deselected package libqtcore4.
Unpacking libqtcore4 (from .../libqtcore4_4%3a4.6.3-4+squeeze1_amd64.deb) ...
Selecting previously deselected package libqt4-xml.
Unpacking libqt4-xml (from .../libqt4-xml_4%3a4.6.3-4+squeeze1_amd64.deb) ...
Selecting previously deselected package libqt4-dbus.
Unpacking libqt4-dbus (from .../libqt4-dbus_4%3a4.6.3-4+squeeze1_amd64.deb) ...
Selecting previously deselected package libqt4-network.
Unpacking libqt4-network (from .../libqt4-network_4%3a4.6.3-4+squeeze1_amd64.deb) ...
Selecting previously deselected package libqt4-sql.
Unpacking libqt4-sql (from .../libqt4-sql_4%3a4.6.3-4+squeeze1_amd64.deb) ...
Selecting previously deselected package libqt4-sql-sqlite.
Unpacking libqt4-sql-sqlite (from .../libqt4-sql-sqlite_4%3a4.6.3-4+squeeze1_amd64.deb) ...
Selecting previously deselected package libsigc++-2.0-dev.
Unpacking libsigc++-2.0-dev (from .../libsigc++-2.0-dev_2.2.4.2-1_amd64.deb) ...
Selecting previously deselected package mumble-server.
Unpacking mumble-server (from .../mumble-server_1.2.2-6+squeeze1_amd64.deb) ...
Selecting previously deselected package rrdtool.
Unpacking rrdtool (from .../rrdtool_1.4.3-1_amd64.deb) ...
Selecting previously deselected package openmediavault.
Unpacking openmediavault (from .../openmediavault_0.5.35_all.deb) ...
Selecting previously deselected package python-dbus.
Unpacking python-dbus (from .../python-dbus_0.83.1-1_amd64.deb) ...
Selecting previously deselected package python-gobject.
Unpacking python-gobject (from .../python-gobject_2.21.4+is.2.21.3-1_amd64.deb) ...
Selecting previously deselected package libglib2.0-0-dbg.
Unpacking libglib2.0-0-dbg (from .../libglib2.0-0-dbg_2.24.2-1_amd64.deb) ...
Selecting previously deselected package libglib2.0-0-refdbg.
Unpacking libglib2.0-0-refdbg (from .../libglib2.0-0-refdbg_2.24.2-1_amd64.deb) ...
Setting up libglib2.0-0 (2.24.2-1) ...
Setting up libpango1.0-0 (1.28.3-1+squeeze2) ...
Setting up librrd4 (1.4.3-1) ...
Setting up collectd (4.10.1-1+squeeze2) ...
Restarting statistics collection and monitoring daemon: collectd.
Setting up libcroco3 (0.6.2-1) ...
Setting up gettext (0.18.1.1-3) ...
Setting up intltool (0.41.1-1) ...
Setting up libatk1.0-0 (1.30.0-1) ...
Setting up pkg-config (0.25-1.1) ...
Setting up libidn11-dev (1.15-2) ...
Setting up libcurl4-openssl-dev (7.21.0-2.1+squeeze7) ...
Setting up libdbus-glib-1-2 (0.88-2.1+squeeze1) ...
Setting up libglib2.0-data (2.24.2-1) ...
Setting up libglib2.0-dev (2.24.2-1) ...
Setting up libgsf-1-114 (1.14.18-1) ...
Setting up libqtcore4 (4:4.6.3-4+squeeze1) ...
Setting up libqt4-xml (4:4.6.3-4+squeeze1) ...
Setting up libqt4-dbus (4:4.6.3-4+squeeze1) ...
Setting up libqt4-network (4:4.6.3-4+squeeze1) ...
Setting up libqt4-sql (4:4.6.3-4+squeeze1) ...
Setting up libqt4-sql-sqlite (4:4.6.3-4+squeeze1) ...
Setting up libsigc++-2.0-dev (2.2.4.2-1) ...
Setting up mumble-server (1.2.2-6+squeeze1) ...
Reloading system message bus config...done.
Setting up rrdtool (1.4.3-1) ...
Setting up openmediavault (0.5.35) ...
Updating configuration ...
Setting up python-dbus (0.83.1-1) ...
Remove stale byte-compiled files...
Setting up python-gobject (2.21.4+is.2.21.3-1) ...
Setting up libglib2.0-0-dbg (2.24.2-1) ...
Setting up libglib2.0-0-refdbg (2.24.2-1) ...
Setting up libmono-security2.0-cil (2.6.7-5.1) ...
Setting up mono-2.0-gac (2.6.7-5.1) ...
Setting up mono-gac (2.6.7-5.1) ...
* Installing 1 assembly from libglib2.0-cil into Mono
/usr/bin/mono: symbol lookup error: /usr/bin/mono: undefined symbol: g_malloc0_n
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 144.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 113.
/usr/bin/mono: symbol lookup error: /usr/bin/mono: undefined symbol: g_malloc0_n
E: installing Assembly /usr/lib/cli/glib-sharp-2.0/glib-sharp.dll failed
E: Installation of libglib2.0-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: error processing mono-gac (--configure):
 subprocess installed post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of mono-runtime:
 mono-runtime depends on mono-gac (= 2.6.7-5.1); however:
  Package mono-gac is not configured yet.
dpkg: error processing mono-runtime (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-corlib2.0-cil:
 libmono-corlib2.0-cil depends on mono-runtime (<< 2.6.8); however:
  Package mono-runtime is not configured yet.
dpkg: error processing libmono-corlib2.0-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-posix2.0-cil:
 libmono-posix2.0-cil configured to not write apport reports
                                                            configured to not write apport reports
                                                                                                  configured to not write apport reports
                                  configured to not write apport reports
                                                                        configured to not write apport reports
        configured to not write apport reports
                                              configured to not write apport reports
                                                                                    depends on libmono-corlib2.0-cil (>= 2.6.3); however:
  Package libmono-corlib2.0-cil is not configured yet.
 libmono-posix2.0-cil depends on mono-runtime (>= 2.4); however:
  Package mono-runtime is not configured yet.
dpkg: error processing libmono-posix2.0-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib2.0-cil:
 libglib2.0-cil depends on libmono-corlib2.0-cil (>= 1.2.2.1); however:
  Package libmono-corlib2.0-cil is not configured yet.
dpkg: error processing libglib2.0-cil (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib2.0-cil-dev:
 libglib2.0-cil-dev depends on libglib2.0-cil (= 2.12.10-1); however:
  Package libglib2.0-cil is not configured yet.
dpkg: error processing libglib2.0-cil-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-system2.0-cil:
 libmono-system2.0-cil depends on mono-runtime (>= 2.6.7); however:
  Package mono-runtime is not configured yet.
 libmono-system2.0-cil depends on mono-runtime (<< 2.6.8); however:
  Package mono-runtime is not configured yet.
dpkg: error processing libmono-system2.0-cil (--configure):
 dependency problems - leaving unconfigured
Processing triggers for openmediavault ...
Restarting engine daemon ...
Updating locale files ...
Updating file permissions ...
Processing triggers for python-support ...
Errors were encountered while processing:
 mono-gac
 mono-runtime
 libmono-corlib2.0-cil
 libmono-posix2.0-cil
 libglib2.0-cil
 libglib2.0-cil-dev
 libmono-system2.0-cil
E: Sub-process /usr/bin/dpkg returned an error code (1)
It should be noted, that even after removing libglib, the custom version I compiled was still in /usr/local/lib. Is there any way to remove it?
 
Old 02-27-2014, 02:29 PM   #15
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by trelosae View Post
Just to make sure, removing the packages won't delete their settings, right?
That is the difference between "remove" and "purge". Remove doesn't remove the settings; purge removes everything including the settings.
jdk
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ffmpeg package on Debian stable repositories and debian-multimedia : might be broken patrick295767 Debian 1 07-15-2012 04:37 PM
Problem with libglib-2.0.so.0 after update tradice Fedora 3 02-11-2008 11:09 AM
libglib-2.0.a library missing? bg4 Slackware 2 02-09-2007 09:30 PM
Help me installing libglib please ninja Linux - Software 3 11-20-2004 10:22 AM


All times are GMT -5. The time now is 05:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration