LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-14-2009, 01:25 PM   #1
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Rep: Reputation: 57
Question Broken Apt-Get DB in Debian


Hey guys,
I find a lot of times if I try to install something using apt-get I will get errors stating certain packages are required but will not be installed. This leaves me with unresolved dependencies and I have to rune "apt-get -f install" to fix it.

Any idea what could be the problem?

Machine Info:
uname -a
Linux debian 2.6.26-2-amd64 #1 SMP Thu Nov 5 02:23:12 UTC 2009 x86_64 GNU/Linux
lsb_release -a
Distributor ID: Debian
Description: Debian GNU/Linux 5.0.3 (lenny)
Release: 5.0.3
Codename: lenny

Physical Specs:
AMD Phenom 9550 Quad Core 2.1GHz
4GB Ram
500GB HDD
 
Old 12-14-2009, 01:29 PM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
It would help to post some error messages and the contents of your sources.list.
 
Old 12-14-2009, 02:18 PM   #3
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Kernel & release match. HW specs are not relevant.

Did you forget to post the exact commands you run and the error message? Also, post the contents of /etc/apt/sources.list and /etc/apt/preferences.
 
0 members found this post helpful.
Old 12-14-2009, 02:46 PM   #4
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
I didn't post the error before because I was drawing a blank as to what packages I had tried to cause the error.

Code:
debian:/home/jared# apt-get install kdenlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kdenlive: Depends: libmlt++3 but it is not going to be installed
            Depends: libmlt2 but it is not going to be installed
            Depends: melt but it is not going to be installed
            Depends: ffmpeg but it is not going to be installed
            Recommends: frei0r-plugins but it is not going to be installed
E: Broken packages
debian:/home/jared#
Here is my sources.list
Code:
# deb cdrom:[Debian GNU/Linux 5.0.2a _Lenny_ - Official amd64 NETINST Binary-1 20090817-16:36]/ lenny main
# deb cdrom:[Debian GNU/Linux 5.0.2a _Lenny_ - Official amd64 NETINST Binary-1 20090817-16:36]/ lenny main
deb http://ftp.us.debian.org/debian/ lenny main
deb-src http://ftp.us.debian.org/debian/ lenny main
deb http://security.debian.org/ lenny/updates main
deb-src http://security.debian.org/ lenny/updates main
deb http://volatile.debian.org/debian-volatile lenny/volatile main
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
deb http://www.backports.org/debian lenny-backports main contrib non-free
deb http://www.debian-multimedia.org lenny main
deb http://ftp.us.debian.org/debian sid main non-free
deb http://ftp.us.debian.org/debian sid main contrib
deb http://www.lamaresh.net/apt lenny main
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free

#wine
deb http://wine.sourceforge.net/apt/ binary/

#mp3 diags
#deb http://ftp5.gwdg.de/pub/opensuse/repositories/home:/ciobi/ Ubuntu/
I don't have a preferences file. I have a preferences.d directory but it is empty. Here is a directory listing of /etc/apt/
Code:
debian:/etc/apt# ls -lR
.:
total 40
drwxr-xr-x 2 root root 4096 Dec  1 18:20 apt.conf.d
drwxr-xr-x 2 root root 4096 Aug 28 19:05 preferences.d
-rw------- 1 root root    0 Aug 28 19:52 secring.gpg
-rw-r--r-- 1 root root 1100 Dec  1 17:09 sources.list
-rw-r--r-- 1 root root    0 Aug 28 19:52 sources.list~
-rw-r--r-- 1 root root  788 Aug 29 16:07 sources.list.b
drwxr-xr-x 2 root root 4096 Apr 20  2009 sources.list.d
-rw------- 1 root root 1200 Aug 28 20:23 trustdb.gpg
-rw------- 1 root root 8182 Sep  1 23:39 trusted.gpg
-rw------- 1 root root 7235 Aug 28 20:23 trusted.gpg~

./apt.conf.d:
total 12
-rw-r--r-- 1 root root  40 Aug 28 19:52 00trustcdrom
-rw-r--r-- 1 root root  92 Apr 20  2009 01autoremove
-rw-r--r-- 1 root root 182 Oct 12  2008 70debconf

./preferences.d:
total 0

./sources.list.d:
total 0
 
Old 12-14-2009, 03:11 PM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
First clean up your sources.list, get rid of the duplicate lenny lines and the lines for sid. I like to comment the lines in my sources.list, it helps to keep it a bit more organized. You also have two lines for wine.

Something like:
Code:
#Stable
#deb http://http.us.debian.org/debian/ lenny main contrib non-free
#Stable Sources
#deb-src http://http.us.debian.org/debian/ lenny main contrib non-free
#Security Updates Stable
#deb http://security.debian.org/ lenny/updates main contrib non-free

# Debian Volatile http://www.debian.org/volatile/
# deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

# Debian Stable Backports
#deb http://www.backports.org/debian lenny-backports main contrib non-free

#Debian-multimedia.org apt-get install debian-multimedia-keyring
# deb http://www.debian-multimedia.org lenny  main 

# WINE 
#deb http://www.lamaresh.net/apt lenny main
kdenlive isnt in stable you would have to install it from testing or backport it from sid yourself.
http://packages.debian.org/search?ke...ll&section=all
 
Old 12-14-2009, 03:15 PM   #6
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Quote:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
Code:
deb http://ftp.us.debian.org/debian/ lenny main
deb-src http://ftp.us.debian.org/debian/ lenny main
deb http://security.debian.org/ lenny/updates main
deb-src http://security.debian.org/ lenny/updates main
deb http://volatile.debian.org/debian-volatile lenny/volatile main
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
deb http://www.backports.org/debian lenny-backports main contrib non-free
deb http://www.debian-multimedia.org lenny main
deb http://ftp.us.debian.org/debian sid main non-free
deb http://ftp.us.debian.org/debian sid main contrib
deb http://www.lamaresh.net/apt lenny main
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free

#wine
deb http://wine.sourceforge.net/apt/ binary/

#mp3 diags
#deb http://ftp5.gwdg.de/pub/opensuse/repositories/home:/ciobi/ Ubuntu/
There's your problem.
You've mixed Sid with Lenny,bad move.
Have you done any updates or installed packages since you added the entry for Sid?.
 
Old 12-14-2009, 03:26 PM   #7
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
I updated my source.list like yours, which I find a much more readable format. Normally this is how I manage them but for somereason I never did it that way on this system.

Code:
#Stable
deb http://http.us.debian.org/debian/ lenny main contrib non-free

#Stable Sources
deb-src http://http.us.debian.org/debian/ lenny main contrib non-free

#Stable Security Updates
deb http://security.debian.org/ lenny/updates main contrib non-free

#Stable Source Security Updates
deb-src http://security.debian.org/ lenny/updates main contrib non-free

# Debian Volatile http://www.debian.org/volatile/
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

# Debian Stable Backports
deb http://www.backports.org/debian lenny-backports main contrib non-free

#Debian-Multimedia.org apt-get install debian-multimedia-keyring
deb http://www.debian-multimedia.org lenny main

#Wine
deb http://www.lamaresh.net/apt lenny main

# deb cdrom:[Debian GNU/Linux 5.0.2a _Lenny_ - Official amd64 NETINST Binary-1 20090817-16:36]/ lenny main
# deb cdrom:[Debian GNU/Linux 5.0.2a _Lenny_ - Official amd64 NETINST Binary-1 20090817-16:36]/ lenny main

#mp3 diags
#deb http://ftp5.gwdg.de/pub/opensuse/repositories/home:/ciobi/ Ubuntu/
Also I did run 'apt-get update'
 
Old 12-14-2009, 03:27 PM   #8
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
Yes I have done install with sid and lenny.
 
Old 12-14-2009, 03:29 PM   #9
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Quote:
Also I did run 'apt-get update'
Did you do this when you had the entries for Sid in your sources.list?.
 
Old 12-14-2009, 03:29 PM   #10
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
hmm.. I updated my source.list and removed sid and structured it like suggested and tried kdenlive again and it installed no problem. I think that might have fixed it.

Code:
debian:/etc/apt# apt-get install kdenlive                                           
Reading package lists... Done                                                       
Building dependency tree                                                            
Reading state information... Done                                                   
The following extra packages will be installed:                                     
  dvgrab ffmpeg libavdevice52 libavformat52 libimlib2 libmlt++1 libmlt-data libmlt1 
  mlt swh-plugins                                                                   
The following NEW packages will be installed:                                       
  dvgrab ffmpeg kdenlive libavdevice52 libimlib2 libmlt++1 libmlt-data libmlt1 mlt  
  swh-plugins                                                                       
The following packages will be upgraded:                                            
  libavformat52                                                                     
1 upgraded, 10 newly installed, 0 to remove and 22 not upgraded.                    
Need to get 7,453kB of archives.                                                    
After this operation, 21.5MB of additional disk space will be used.                 
Do you want to continue [Y/n]? y                                                    
Get:1 http://http.us.debian.org lenny/main libimlib2 1.4.0-1.2 [220kB]              
Get:2 http://www.debian-multimedia.org lenny/main libavformat52 3:20080706-0.3lenny1 [324kB]                                                                              
Get:3 http://http.us.debian.org lenny/main swh-plugins 0.4.15-0.2 [602kB]            
Get:4 http://http.us.debian.org lenny/main dvgrab 3.1-2 [133kB]                      
Get:5 http://www.debian-multimedia.org lenny/main libavdevice52 3:20080706-0.3lenny1 [29.8kB]                                                                             
Get:6 http://www.debian-multimedia.org lenny/main ffmpeg 3:20080706-0.3lenny1 [211kB]
Get:7 http://www.debian-multimedia.org lenny/main libmlt-data 1:0.3.0-0.1 [1,366kB]  
Get:8 http://www.debian-multimedia.org lenny/main libmlt1 1:0.3.0-0.1 [472kB]        
Get:9 http://www.debian-multimedia.org lenny/main libmlt++1 1:0.3.0-0.0 [47.1kB]     
Get:10 http://www.debian-multimedia.org lenny/main mlt 1:0.3.0-0.1 [63.9kB]          
Get:11 http://www.debian-multimedia.org lenny/main kdenlive 0.5.svn20080420-0.2 [3,984kB]                                                                                 
Fetched 7,453kB in 5s (1,258kB/s)                                                    
(Reading database ... 158741 files and directories currently installed.)
Preparing to replace libavformat52 0.svn20080206-17+lenny1 (using .../libavformat52_3%3a20080706-0.3lenny1_amd64.deb) ...
Unpacking replacement libavformat52 ...
Selecting previously deselected package libavdevice52.
Unpacking libavdevice52 (from .../libavdevice52_3%3a20080706-0.3lenny1_amd64.deb) ...
Selecting previously deselected package libimlib2.
Unpacking libimlib2 (from .../libimlib2_1.4.0-1.2_amd64.deb) ...
Selecting previously deselected package ffmpeg.
Unpacking ffmpeg (from .../ffmpeg_3%3a20080706-0.3lenny1_amd64.deb) ...
Selecting previously deselected package libmlt-data.
Unpacking libmlt-data (from .../libmlt-data_1%3a0.3.0-0.1_all.deb) ...
Selecting previously deselected package libmlt1.
Unpacking libmlt1 (from .../libmlt1_1%3a0.3.0-0.1_amd64.deb) ...
Selecting previously deselected package libmlt++1.
Unpacking libmlt++1 (from .../libmlt++1_1%3a0.3.0-0.0_amd64.deb) ...
Selecting previously deselected package mlt.
Unpacking mlt (from .../mlt_1%3a0.3.0-0.1_amd64.deb) ...
Selecting previously deselected package kdenlive.
Unpacking kdenlive (from .../kdenlive_0.5.svn20080420-0.2_amd64.deb) ...
Selecting previously deselected package swh-plugins.
Unpacking swh-plugins (from .../swh-plugins_0.4.15-0.2_amd64.deb) ...
Selecting previously deselected package dvgrab.
Unpacking dvgrab (from .../dvgrab_3.1-2_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Setting up libavformat52 (3:20080706-0.3lenny1) ...
Setting up libavdevice52 (3:20080706-0.3lenny1) ...
Setting up libimlib2 (1.4.0-1.2) ...
Setting up ffmpeg (3:20080706-0.3lenny1) ...
Setting up libmlt-data (1:0.3.0-0.1) ...
Setting up libmlt1 (1:0.3.0-0.1) ...
Setting up libmlt++1 (1:0.3.0-0.0) ...
Setting up mlt (1:0.3.0-0.1) ...
Setting up kdenlive (0.5.svn20080420-0.2) ...
Setting up swh-plugins (0.4.15-0.2) ...
Setting up dvgrab (3.1-2) ...
 
Old 12-14-2009, 03:30 PM   #11
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
Quote:
Originally Posted by the trooper View Post
Did you do this when you had the entries for Sid in your sources.list?.
Yes, The sid entries have been there sometime. In fact all the entries below sid were added after sid.
 
Old 12-14-2009, 03:42 PM   #12
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
That's a little worrying.
An easy way to check would be:

apt-get install apt-show-versions
apt-show-versions | grep sid

See if that comes back with sid packages installed.
I have an entry for unstable on my system,here's what i get:

Code:
ade@Pc1:~$ apt-show-versions | grep unstable
linux-headers-2.6.31-1-amd64/unstable uptodate 2.6.31-2
linux-headers-2.6.31-1-common/unstable uptodate 2.6.31-2
linux-image-2.6.31-1-amd64/unstable uptodate 2.6.31-2
linux-kbuild-2.6.31/unstable uptodate 2.6.31.2-1
 
Old 12-14-2009, 03:46 PM   #13
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
Code:
debian:/etc/apt# apt-get install apt-show-versions
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  apt-show-versions: Depends: libapt-pkg-perl (>= 0.1.21) but it is not going to be installed
E: Broken packages
 
Old 12-14-2009, 05:10 PM   #14
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Well,your sources.list looks ok now.
Is there anything else with that error message?.
I think there is a fair chance you have some Sid libraries causing problems.
 
Old 12-14-2009, 05:25 PM   #15
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Original Poster
Rep: Reputation: 57
I am willing to say you are probably right. I know the sid source has been there for at least 7 months.

That is the only thing it says.

Here are some things I have done

apt-get upgrade
Code:
debian:/etc/apt# apt-get upgrade                                                     
Reading package lists... Done                                                        
Building dependency tree                                                             
Reading state information... Done                                                    
The following packages have been kept back:                                          
  mplayer                                                                            
The following packages will be upgraded:                                             
  cups openoffice.org openoffice.org-base openoffice.org-base-core                   
  openoffice.org-calc openoffice.org-common openoffice.org-core openoffice.org-draw  
  openoffice.org-gcj openoffice.org-help-en-us openoffice.org-impress                
  openoffice.org-java-common openoffice.org-kde openoffice.org-math                  
  openoffice.org-officebean openoffice.org-report-builder-bin openoffice.org-writer  
  poppler-utils x11-common xorg xserver-xorg                                         
21 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.                      
Need to get 102MB of archives.                                                       
After this operation, 467kB disk space will be freed.                                
Do you want to continue [Y/n]? y                                                     
Get:1 http://security.debian.org lenny/updates/main poppler-utils 0.8.7-3 [232kB]    
Get:2 http://http.us.debian.org lenny/main x11-common 1:7.3+20 [343kB]               
Get:3 http://security.debian.org lenny/updates/main cups 1.3.8-1+lenny7 [2,053kB]    
Get:4 http://http.us.debian.org lenny/main xserver-xorg 1:7.3+20 [224kB]             
Get:5 http://http.us.debian.org lenny/main xorg 1:7.3+20 [27.2kB]                    
Get:6 http://security.debian.org lenny/updates/main openoffice.org-writer 1:2.4.1+dfsg-1+lenny3 [7,767kB]                                                                 
Get:7 http://security.debian.org lenny/updates/main openoffice.org-calc 1:2.4.1+dfsg-1+lenny3 [5,935kB]                                                                   
Get:8 http://security.debian.org lenny/updates/main openoffice.org-base 1:2.4.1+dfsg-1+lenny3 [3,027kB]                                                                   
Get:9 http://security.debian.org lenny/updates/main openoffice.org-base-core 1:2.4.1+dfsg-1+lenny3 [1,006kB]                                                              
Get:10 http://security.debian.org lenny/updates/main openoffice.org-gcj 1:2.4.1+dfsg-1+lenny3 [4,514kB]                                                                   
Get:11 http://security.debian.org lenny/updates/main openoffice.org-common 1:2.4.1+dfsg-1+lenny3 [14.5MB]                                                                 
Get:12 http://security.debian.org lenny/updates/main openoffice.org-java-common 1:2.4.1+dfsg-1+lenny3 [2,977kB]                                                           
Get:13 http://security.debian.org lenny/updates/main openoffice.org-impress 1:2.4.1+dfsg-1+lenny3 [918kB]                                                                 
Get:14 http://security.debian.org lenny/updates/main openoffice.org-draw 1:2.4.1+dfsg-1+lenny3 [3,022kB]                                                                  
Get:15 http://security.debian.org lenny/updates/main openoffice.org-kde 1:2.4.1+dfsg-1+lenny3 [505kB]                                                                     
Get:16 http://security.debian.org lenny/updates/main openoffice.org-officebean 1:2.4.1+dfsg-1+lenny3 [320kB]                                                              
Get:17 http://security.debian.org lenny/updates/main openoffice.org-math 1:2.4.1+dfsg-1+lenny3 [597kB]                                                                    
Get:18 http://security.debian.org lenny/updates/main openoffice.org 1:2.4.1+dfsg-1+lenny3 [275kB]                                                                         
Get:19 http://security.debian.org lenny/updates/main openoffice.org-core 1:2.4.1+dfsg-1+lenny3 [40.1MB]                                                                   
Get:20 http://security.debian.org lenny/updates/main openoffice.org-report-builder-bin 1:2.4.1+dfsg-1+lenny3 [1,153kB]                                                    
Get:21 http://security.debian.org lenny/updates/main openoffice.org-help-en-us 1:2.4.1+dfsg-1+lenny3 [12.6MB]                                                             
Fetched 102MB in 1min 47s (946kB/s)                                                  
Preconfiguring packages ...                                                          
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
(Reading database ... 159312 files and directories currently installed.)             
Preparing to replace x11-common 1:7.3+19 (using .../x11-common_1%3a7.3+20_all.deb) ...                                                                                    
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
Unpacking replacement x11-common ...                                                 
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
Preparing to replace poppler-utils 0.8.7-2 (using .../poppler-utils_0.8.7-3_amd64.deb) ...                                                                                
Unpacking replacement poppler-utils ...                                              
Preparing to replace cups 1.3.8-1+lenny6 (using .../cups_1.3.8-1+lenny7_amd64.deb) ...                                                                                    
Stopping Common Unix Printing System: cupsd.                                         
Unpacking replacement cups ...                                                       
Preparing to replace openoffice.org-writer 1:2.4.1+dfsg-1 (using .../openoffice.org-writer_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                         
Unpacking replacement openoffice.org-writer ...                                      
Preparing to replace openoffice.org-calc 1:2.4.1+dfsg-1 (using .../openoffice.org-calc_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                             
Unpacking replacement openoffice.org-calc ...                                        
Preparing to replace openoffice.org-base 1:2.4.1+dfsg-1 (using .../openoffice.org-base_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                             
Unpacking replacement openoffice.org-base ...                                        
Preparing to replace openoffice.org-base-core 1:2.4.1+dfsg-1 (using .../openoffice.org-base-core_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                   
Unpacking replacement openoffice.org-base-core ...                                   
Preparing to replace openoffice.org-gcj 1:2.4.1+dfsg-1 (using .../openoffice.org-gcj_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                               
Unpacking replacement openoffice.org-gcj ...                                         
Preparing to replace openoffice.org-common 1:2.4.1+dfsg-1 (using .../openoffice.org-common_1%3a2.4.1+dfsg-1+lenny3_all.deb) ...                                           
Unpacking replacement openoffice.org-common ...                                      
Preparing to replace openoffice.org-java-common 1:2.4.1+dfsg-1 (using .../openoffice.org-java-common_1%3a2.4.1+dfsg-1+lenny3_all.deb) ...                                 
Unpacking replacement openoffice.org-java-common ...                                 
Preparing to replace openoffice.org-impress 1:2.4.1+dfsg-1 (using .../openoffice.org-impress_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                       
Unpacking replacement openoffice.org-impress ...                                     
Preparing to replace openoffice.org-draw 1:2.4.1+dfsg-1 (using .../openoffice.org-draw_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                             
Unpacking replacement openoffice.org-draw ...                                        
Preparing to replace openoffice.org-kde 1:2.4.1+dfsg-1 (using .../openoffice.org-kde_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                               
Unpacking replacement openoffice.org-kde ...                                         
Preparing to replace openoffice.org-officebean 1:2.4.1+dfsg-1 (using .../openoffice.org-officebean_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                 
Unpacking replacement openoffice.org-officebean ...                                  
Preparing to replace openoffice.org-math 1:2.4.1+dfsg-1 (using .../openoffice.org-math_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                             
Unpacking replacement openoffice.org-math ...                                        
Preparing to replace openoffice.org 1:2.4.1+dfsg-1 (using .../openoffice.org_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                                       
Unpacking replacement openoffice.org ...                                             
Preparing to replace openoffice.org-core 1:2.4.1+dfsg-1 (using .../openoffice.org-core_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                                             
Unpacking replacement openoffice.org-core ...                                        
Preparing to replace openoffice.org-report-builder-bin 1:2.4.1+dfsg-1 (using .../openoffice.org-report-builder-bin_1%3a2.4.1+dfsg-1+lenny3_amd64.deb) ...                 
Unpacking replacement openoffice.org-report-builder-bin ...                          
Preparing to replace openoffice.org-help-en-us 1:2.4.1+dfsg-1 (using .../openoffice.org-help-en-us_1%3a2.4.1+dfsg-1+lenny3_all.deb) ...                                   
Unpacking replacement openoffice.org-help-en-us ...                                  
Preparing to replace xserver-xorg 1:7.3+19 (using .../xserver-xorg_1%3a7.3+20_amd64.deb) ...                                                                              
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
Unpacking replacement xserver-xorg ...                                               
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
Preparing to replace xorg 1:7.3+19 (using .../xorg_1%3a7.3+20_amd64.deb) ...         
Unpacking replacement xorg ...                                                       
Processing triggers for man-db ...                                                   
Processing triggers for menu ...                                                     
Processing triggers for hicolor-icon-theme ...                                       
Processing triggers for shared-mime-info ...                                         
Unknown media type in type 'all/all'                                                 

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Setting up x11-common (1:7.3+20) ...
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
Setting up poppler-utils (0.8.7-3) ...                                               
Setting up cups (1.3.8-1+lenny7) ...                                                 
Starting Common Unix Printing System: cupsd.                                         
Setting up openoffice.org-common (1:2.4.1+dfsg-1+lenny3) ...                         
Updating OpenOffice.org's dictionary list... done.                                   
Setting up openoffice.org-core (1:2.4.1+dfsg-1+lenny3) ...                           
Setting up openoffice.org-base-core (1:2.4.1+dfsg-1+lenny3) ...                      
Setting up openoffice.org-writer (1:2.4.1+dfsg-1+lenny3) ...                         
Setting up openoffice.org-calc (1:2.4.1+dfsg-1+lenny3) ...                           
Setting up openoffice.org-java-common (1:2.4.1+dfsg-1+lenny3) ...                    
Setting up openoffice.org-base (1:2.4.1+dfsg-1+lenny3) ...                           
Setting up openoffice.org-gcj (1:2.4.1+dfsg-1+lenny3) ...                            
Setting up openoffice.org-draw (1:2.4.1+dfsg-1+lenny3) ...                           
Setting up openoffice.org-impress (1:2.4.1+dfsg-1+lenny3) ...                        
Setting up openoffice.org-kde (1:2.4.1+dfsg-1+lenny3) ...                            
Setting up openoffice.org-officebean (1:2.4.1+dfsg-1+lenny3) ...                     
Setting up openoffice.org-math (1:2.4.1+dfsg-1+lenny3) ...                           
Setting up openoffice.org-report-builder-bin (1:2.4.1+dfsg-1+lenny3) ...             
Setting up openoffice.org (1:2.4.1+dfsg-1+lenny3) ...                                
Setting up openoffice.org-help-en-us (1:2.4.1+dfsg-1+lenny3) ...                     
Setting up xserver-xorg (1:7.3+20) ...                                               
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.                                                            
Setting up xorg (1:7.3+20) ...                                                       
Processing triggers for menu ...                                                     
debian:/etc/apt# apt-get -f install                                                  
Reading package lists... Done                                                        
Building dependency tree                                                             
Reading state information... Done                                                    
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Tried to install apt-show-versions again
Code:
debian:/etc/apt# apt-get install apt-show-versions                                
Reading package lists... Done                                                     
Building dependency tree                                                          
Reading state information... Done                                                 
Some packages could not be installed. This may mean that you have                 
requested an impossible situation or if you are using the unstable                
distribution that some required packages have not yet been created                
or been moved out of Incoming.                                                    
The following information may help to resolve the situation:                      

The following packages have unmet dependencies:
  apt-show-versions: Depends: libapt-pkg-perl (>= 0.1.21) but it is not going to be installed                                                                             
E: Broken packages
Fixed broken packages and did clean up
Code:
debian:/etc/apt# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
debian:/etc/apt# apt-get clean
debian:/etc/apt# apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
apt-get build-dep apt-show-versions
Code:
debian:/etc/apt# apt-get build-dep apt-show-versions
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have unmet dependencies:
  build-essential: Depends: g++ (>= 4:4.3.1) but it is not going to be installed
E: Build-dependencies for apt-show-versions could not be satisfied.
dpkg -l | grep sid
Code:
debian:/etc/apt# dpkg -l | grep sid
ii  libkonqsidebarplugin4                 4:4.3.2-1                      Konqueror sidebar plugin library
ii  libnfsidmap2                          0.22-2                         An nfs idmapping library
ii  libresid-builder0c2a                  2.1.1-8                        SID chip emulation class based on resid
ii  libsidplay1                           1.36.59-5                      SID (MOS 6581) emulation library
ii  libsidplay2                           2.1.1-8                        SID (MOS 6581) emulation library
ii  libssh2-1                             1.2.1-2                        SSH2 client-side library
ii  libx11-6                              2:1.1.5-2                      X11 client-side library
ii  libx11-data                           2:1.3.2-1                      X11 client-side library
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian / kubuntu: my "apt" appears to be broken/inconsistent tredegar Linux - Software 7 10-02-2008 04:25 AM
apt-get broken kmoffat Debian 4 04-02-2006 10:53 AM
apt-get seems broken jon_k Linux - Software 1 12-09-2004 07:20 PM
apt-get is broken, please help! agentforsythe Linux - General 3 01-12-2004 04:24 AM
broken apt-get mindcry Linux - Software 0 05-24-2003 10:55 AM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration