LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-25-2010, 04:07 PM   #1
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Rep: Reputation: 0
Broadcom & ATI Proprietary driver issue in Ubuntu 9.10


I was just curious as to what Linux was like, so I did some research and downloaded & installed Ubuntu 9.10. Everything works fine, except...

When I navigate to System/Administration/Hardware Drivers in the GUI and attempt to install my proprietary wireless driver (broadcom STA) and my ATI video card driver, I experience an issue where a crash report is generated and the system locks up, forcing me to hold the power button to reboot. After reboot, I attempt to install the broadcom driver again, and I receive an error (Driver has failed to install, check /var/log/jockey.log for details). Sometimes, one driver will successfully install, but then the other will fail, and consequently I just reinstalled Ubuntu and tried again, to no avail. The same crash happened again.

Any help would be greatly appreciated, and I am just curious if anyone else has seen this bug before...

System specs:
Dell Inspiron 1545 (Dual boot with windows 7)
64 bit system
Intel Core 2 Duo processor T6600 @ 2.2 Ghz
4 gb Ram
ATI Mobility Radeon HD 4330 video card
Dell Wireless 1510 Wireless-N WLAN Mini-Card (uses the broadcom driver)

Thanks everyone.
 
Old 01-25-2010, 04:14 PM   #2
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Can you copy and paste the details here from /var/log/jockey.log?
 
Old 01-25-2010, 07:13 PM   #3
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
Here it is, saved as a .txt attachment so I could upload it. It was originally a .log extension. It comes from /var/log/jockey.log, and it is pretty long, as you can see.
Attached Files
File Type: txt jockey.txt (215.8 KB, 8 views)
 
Old 01-26-2010, 08:27 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Could you post the output of lspci? From that log you posted, your system is trying every wireless driver under the sun, particularly some of the Atheros drivers. Also if you could post the output of lsmod from before you try to install the ATI and Broadcom drivers it might help.
 
Old 01-26-2010, 03:23 PM   #5
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
Sure. Here's the lspci output:


daniel@daniel-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series]
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)
0c:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
 
Old 01-26-2010, 07:06 PM   #6
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
I saw a bit of a difference in these two so I will post them both- the output of lsmod.
lsmod Right after booting up:


Module Size Used by
binfmt_misc 10220 1
ppdev 8232 0
joydev 13088 0
snd_hda_codec_idt 72976 1
lib80211 7812 0
snd_hda_intel 31880 2
snd_hda_codec 87584 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 9352 1 snd_hda_codec
snd_pcm_oss 44704 0
snd_mixer_oss 18976 1 snd_pcm_oss
snd_pcm 93160 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 3460 0
snd_seq_oss 33440 0
snd_seq_midi 8192 0
snd_rawmidi 27360 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
iptable_filter 3872 0
snd_seq 60608 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 26992 2 snd_pcm,snd_seq
snd_seq_device 8308 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
dell_wmi 3216 0
ssb 40944 0
ip_tables 21200 1 iptable_filter
x_tables 25832 1 ip_tables
psmouse 57124 0
serio_raw 6596 0
lp 11908 0
parport 40528 2 ppdev,lp
snd 77096 16 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_os s,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 9088 1 snd
snd_page_alloc 10928 2 snd_hda_intel,snd_pcm
dell_laptop 9692 0
dcdbas 9136 1 dell_laptop
usb_storage 66016 1
video 23612 0
output 3680 1 video
radeon 684512 1
ttm 43056 1 radeon
drm 193856 3 radeon,ttm
i2c_algo_bit 7076 1 radeon
sky2 55556 0
intel_agp 32816 0


lsmod After attempted installation:


Module Size Used by
binfmt_misc 10220 1
ppdev 8232 0
joydev 13088 0
snd_hda_codec_idt 72976 1
lib80211 7812 0
snd_hda_intel 31880 2
snd_hda_codec 87584 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 9352 1 snd_hda_codec
snd_pcm_oss 44704 0
snd_mixer_oss 18976 1 snd_pcm_oss
snd_pcm 93160 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 3460 0
snd_seq_oss 33440 0
snd_seq_midi 8192 0
snd_rawmidi 27360 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
iptable_filter 3872 0
snd_seq 60608 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 26992 2 snd_pcm,snd_seq
snd_seq_device 8308 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
dell_wmi 3216 0
ip_tables 21200 1 iptable_filter
x_tables 25832 1 ip_tables
psmouse 57124 0
serio_raw 6596 0
lp 11908 0
parport 40528 2 ppdev,lp
snd 77096 16 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_os s,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 9088 1 snd
snd_page_alloc 10928 2 snd_hda_intel,snd_pcm
dell_laptop 9692 0
dcdbas 9136 1 dell_laptop
usb_storage 66016 0
video 23612 0
output 3680 1 video
radeon 684512 1
ttm 43056 1 radeon
drm 193856 3 radeon,ttm
i2c_algo_bit 7076 1 radeon
sky2 55556 0
intel_agp 32816 0
 
Old 01-27-2010, 11:21 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Hm. The ssb driver is being loaded at boot, but is not present in the later list, so attempting to do the wl install is doing something. However, there isn't a real wireless driver in either list. Have you blacklisted b43? Also have you looked in any of the other system logs after attempting wl installation to see if there is any complaining?

I suppose as an alternative, you could download the driver from Broadcom and try to install it by hand. It isn't hard, and that should work.
 
Old 01-27-2010, 02:16 PM   #8
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
I installed b43 with no complaints, but it doesn't work and also doesn't autostart when I turn on the computer, so I figured it had an error too. I tried once installing the driver manually, but I don't know how to do it... Can you get them from broadcom's website?
 
Old 01-27-2010, 03:19 PM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
I installed b43 with no complaints, but it doesn't work and also doesn't autostart when I turn on the computer, so I figured it had an error too.
There are ways to force it to install at boot. Did you install the firmware for b43 or something else? Due to Broadcom's licensing, Ubuntu can distribute the b43 driver, but not the firmware that is required to make the card work. The unfortunate outcome is that Broadcom cards look like they should work because b43 is there, but they don't because there is no firmware.

Quote:
I tried once installing the driver manually, but I don't know how to do it... Can you get them from broadcom's website?
Yeah, you can get it here. The instructions for compiling and installing are in the README file, and are reasonably straight forward.
 
Old 01-27-2010, 08:48 PM   #10
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
Well I installed from the website and got it working, I logged on to my wireless network here at home, and then I rebooted, and now I still have no wireless networks come up at all in the network manager... I have no idea what might have happened, but after the reboot the driver apparently stopped working. And your explanation for the b43 driver makes a lot of sense, I bet that is why mine didn't work.
 
Old 01-28-2010, 07:48 AM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I'm not sure why, but it sounds like Ubuntu just isn't recognizing your wireless card at boot time. The module is certainly still there, it just isn't loading. So you can either load it manually (modprobe wl) or I think if you add wl to your /etc/modules file, it should load at boot time.

For cards that wl supports, it generally works better than b43, so if you can solve the boot issue, wl would likely be the better choice.
 
Old 01-29-2010, 04:33 PM   #12
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
This is what happens:

daniel@daniel-laptop:~$ modprobe wl
FATAL: Module wl not found.

Am I in the wrong directory or something? Forgive me if it's a noob mistake... haha.
 
Old 01-29-2010, 05:16 PM   #13
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
No you're not in the wrong directory, but you're also not root or using sudo (which you need to be to load or unload a module). The modprobe command always looks in the tree /lib/modules/runningkernelversion for the modules, so it really doesn't matter what directory you're in when you issue the command. What does matter is that you copied the wl.ko file you created when you compiled into /lib/modules/runningkernelversion/kernel/net/wireless.

If it helps, this is a script I use whenever I need to build the wl driver (you do have to run it in the directory with the STA code):

Code:
#!/bin/bash
make -C /lib/modules/`uname -r`/build M=`pwd` clean
make -C /lib/modules/`uname -r`/build M=`pwd`
cp wl.ko /lib/modules/`uname -r`/kernel/net/wireless/wl.ko
depmod -a
The uname -r is in backticks, so it resolves at runtime, so it should install for any kernel version. By the way, the fact that modprobe isn't working may also explain why the card isn't coming up at boot.
 
Old 01-30-2010, 01:25 PM   #14
Daedalus7
LQ Newbie
 
Registered: Jan 2010
Location: Michigan
Distribution: Ubuntu 9.10, Karmic Koala
Posts: 16

Original Poster
Rep: Reputation: 0
Ok I follow. Your code worked for me to build it, but when I typed depmod -a this error came up:

WARNING: Can't read module /lib/modules/2.6.31-17-generic/updates/dkms/wl.ko: Invalid argument

I have been able to install the driver manually three or four times now, but every time I reboot it fails to load. To get it to run I have to uninstall it using rmmod, rebuild the file, then run these two commands:

sudo modprobe lib80211
sudo insmod wl.ko

These were both in the readme file. I also did copy over the wl.ko into the /net/wireless folder, but it didn't change anything.

sudo modprobe wl finally worked when I just ran it, maybe that will change something. I'm going to reboot and see what happens...

Thanks for your help with this.
 
Old 01-30-2010, 07:03 PM   #15
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
I have been able to install the driver manually three or four times now, but every time I reboot it fails to load.
Have you ever modified your /etc/modules file to get wl to load at boot? I think you just have to add a line with wl on it.

Quote:
sudo modprobe lib80211
sudo insmod wl.ko
Actually, if you just run modprobe wl it should load any other modules needed. The insmod will just load the module you tell it to, but modprobe will also load needed modules (which tends to make it a bit more useful).

Quote:
WARNING: Can't read module /lib/modules/2.6.31-17-generic/updates/dkms/wl.ko: Invalid argument
Hm. That isn't the directory that wl should be in. I'm starting to wonder if wl isn't having a little trouble with this kernel version. Given that the morons at Broadcom are maintaining this, I wouldn't be surprised if there were some kernel changes that they haven't picked up yet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Proprietary Driver 8.35.5 uv256 Linux - Hardware 6 10-11-2007 09:26 PM
ATI Proprietary driver issue pdeman2 Linux - Hardware 11 08-19-2006 05:24 PM
ATI Proprietary driver with lfs eculinuxuser Linux From Scratch 5 02-23-2006 01:24 PM
ATI 9600Pro & ATI Proprietary Drivers problem Hyakutake Slackware 6 12-04-2005 11:08 AM
ATI Proprietary Linux Driver 3.12.0 Xerop Linux - Hardware 1 09-11-2004 02:53 PM


All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration