LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2005, 03:29 PM   #1
dreed75
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
bootpart error but still works


I ran bootpart to get my info:

Boot Partition 2.50 for WinNT/2K/XP (c)1995-2002 G. Vollant (info@winimage.com)
Add partition in the Windows NT/2000/XP Multi-boot loader
Run "bootpart /?" for more information

Physical number of disk 0 : 43ce413d
0 : C:* type=7 (HPFS/NTFS), size= 117218241 KB, Lba Pos=63
Physical number of disk 1 : f86af86a
1 : D:* type=82 (Linux swap), size= 1049251 KB, Lba Pos=63
2 : D: type=83 (Linux native), size= 35126122 KB, Lba Pos=2104515
3 : D: type=c (Win95 Fat32 LBA), size= 41969812 KB, Lba Pos=72356760

I have WinXP running on the master 120 GB HD and then Linux on the slave hard drive with a fat partition on it as well. So I want to get bootpart to write the boot file and my boot.ini to give an option to boot Linux. I run "bootpart 2 C:\linux_bs.bin "Linux"" and it does everything correctly. Then I boot up, I see the new option, select it and it says "Cannot load from hard disk please insert system disk and press any key" I am frustrated so I just hit a key to see what happens and then Grub starts loading. Cool, everything works but it still always gives me the error. It would be nice to not hit enter twice but it isn't too big of a deal. I also tried to do it with partition 1 and it does the exact same thing. What am I doing wrong?

David
 
Old 04-09-2005, 04:48 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Since you have GRUB, why not let it manage the booting? If you let it set you MBR on your primary, it can give you a boot menu which will let you chose between Linux and XP.

See "info grub" for details.
 
Old 04-09-2005, 09:33 PM   #3
dreed75
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Because I want to leave the XP drive alone because it has some critical things on it and I am sure I would mess it up. This should be a simple fix but I don't know what to do.

David
 
Old 04-10-2005, 07:04 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
OK, take a look at Booting Linux with the NT loader. The author assumes that you're using LILO, but, once the secondary drive is bootable, it doesn't matter how it got that way.

By the way, can you boot from the secondary directly from you BIOS? (Most BIOS have a "Select boot drive" option.) If you can't start Linux directly from the secondary via BIOS, you should let GRUB fix the boot record on the secondary before proceeding.
 
Old 04-10-2005, 10:48 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Well, for the record, I tried the suggestion I made in the last post, and it didn't work. But my MBR is to GRUB, not XP, which may be where my problem (missing HAL.DLL) comes from.

I also tried this post's suggestion:http://software.newsforge.com/articl...23237&from=rss and it, too, didn't work for me. For the same "HAL.DLL missing" reason.

You might want to try it, though, since you could do it using the "bootpart" program you were using in your second post:
Code:
bootpart 2 C:/Linux.sec "Fedora Core 3"
will copy the boot information from partition 2 of drive D and update your boot.ini file to reference it. Then when you boot XP, the boot menu will give you an option to go to Fedora. (If it doesn't work, no harm is done to your XP system, and you can edit "C:\boot.ini" by hand to delete the option. Or, use the Controll Panel->System applet to do it.)

While writing this, I looked again at your bootpart output and noticed that "2" is not the active partition on drive D. For some reason, you have your swap partition listed as "active." This may be the source of your other problem.

Good luck. And let us know if it works for you -- others may like to know.
 
Old 04-11-2005, 06:04 AM   #6
dreed75
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Well I did run the bootpart program from the beginning only it was:
bootpart 2 C:\linux_bs.bin "Linux"
It still does the same thing as you suggested. I don't know why the swap is active but I just let the installer for Linux do it's thing. Also, if I just boot the second drive by itself, it boots up without giving me a message about a system disk so I don't think that it is the problem but I still could be wrong.

David
 
Old 04-11-2005, 09:14 AM   #7
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Quote:
Originally posted by dreed75
Well I did run the bootpart program from the beginning only it was:
bootpart 2 C:\linux_bs.bin "Linux"
It still does the same thing as you suggested. I don't know why the swap is active but I just let the installer for Linux do it's thing. Also, if I just boot the second drive by itself, it boots up without giving me a message about a system disk so I don't think that it is the problem but I still could be wrong.

David
Um, which of the many things I suggested? Did you mean that you, too, got the "missing hal.dll" message?

I should make it clear, though, that I have a dual-boot system with GRUB setting the MBR on my primary HD (replacing the XP MBR), and I have no problem booting to XP. My grub.conf looks like this:
Code:
$ sudo cat /boot/grub/grub.conf | grep ^[^#]
Password:
default=0
timeout=7
title Fedora Core (2.6.10-1.770_FC3smp)
        root (hd1,1)
        kernel /vmlinuz-2.6.10-1.770_FC3smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.10-1.770_FC3smp.img
title Fedora Core (2.6.10-1.770_FC3smp) No Red Hat Graphic Boot, Init 3
        root (hd1,1)
        kernel /vmlinuz-2.6.10-1.770_FC3smp ro 3 root=/dev/VolGroup00/LogVol00 quiet
        initrd /initrd-2.6.10-1.770_FC3smp.img
title Windows
        rootnoverify (hd0,0)
        chainloader +1
When I select the "Windows" item, I get my usuall XP boot selection menu (since I have two Windows systems [XP and a W2K Server] in my box.) If you're interested, my "boot.ini" file looks like this:
Code:
$ cat /mnt/WinXP/c/boot.ini
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINNT="Win2K" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="WinXP" /fastdetect /NoExecute=OptOut
C:\CMDCONS\BOOTSECT.DAT="Recovery Console" /cmdcon
[Retired]
C:\Win98.bin="Win98"
C:\Linux.bin="Fedora"
(The "[Retired]" section is from my attempts yesterday to get XP to boot Linux [and a Win98 I keep around for access to some old tools].)

IMO, there is little risk in letting GRUB replace the XP MBR. In fact, you can restore the XP MBR from the XP recovery command line tool. So you could avoid the whole problem by just letting GRUB set up your system for dual booting.

I may fool around some more with the missing hal.dll problem, and I'll post anything helpfull I discover here, but it's not a high priority for me right now.

With this, I think I exausted my ability to offer advice. Maybe someone else could step in? [Hint, hint]

Good luck.
 
Old 04-11-2005, 03:46 PM   #8
dreed75
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
I didn't do any of the things you suggested because I had already done those that apply. I never got the error you are talking about. My windows boots fine from the menu, when I select Linux though, it says that it can't load it from hard drive and to insert a system disk. All I do is hit a key and linux boots up like it was supposed to. So to recap, my only problem is that I have to press a key after selecting linux. It's not a big deal and I never meant it to sound like a big deal. I was just wondering if there was something simple I could do so I wouldn't have to hit any key to boot linux. It isn't a big enough deal that I would want to use new boot loaders and stuff and possibly have the problems that you had. I can push a button twice.

David
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer Works, But Gives Error Dialogs mac57 Mandriva 3 03-17-2005 02:02 PM
Firefox install error, but it still works Dsnapper Linux - Software 2 02-19-2005 02:36 PM
Fedora Core 2 or 3 and Windows XP with Bootpart adrenaline_NZ Fedora 4 10-21-2004 12:55 PM
strange error, cant login but su - works ! qwijibow Linux - Software 1 08-23-2004 10:47 AM
X won't load - no error msg - Windows works though lrt2003 Linux - General 2 04-28-2004 04:09 AM


All times are GMT -5. The time now is 11:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration