LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-06-2009, 04:52 AM   #1
lespaul047
LQ Newbie
 
Registered: May 2008
Posts: 6

Rep: Reputation: 0
Booting stops after: Unable to access resume device, mount: could not mount ...


After updating kernel 2.6.27.19 to 2.6.27.21 my computer stops booting after the message:
Unable to access resume device
Mount: could not mount filesystem (/dev/root)
With grub I'm able to boot the previous version and I notice some changes:
1. My 'good' configuration boots from root=/dev/VolGroup00/LogVol00 (I kept the default lvm-names) and my 'bad' config boots from root=/dev/dm-0.
2. When I type mount in terminal after booting the 'good' config I see the mount points are indeed /dev/dm-0 and so on. In LVM-manager I can't see them, because I see the 'old' names (LogVol and so on). Where is the mapping? LVM manager says the LogVols are not mounted...

Can anybody explain this to me? For what I see, my disk is devided in LVMs with the access /dev/VolGroupXX/LogVolXX and somehow there is an extra entry with names like /dev/dm-X.

Then, I rescued: chroot blabla and I tried to mkinitrd and so on. I also swapon, mkswap and swapoff, but no progress. The only change was that /dev/root not found changed in /dev/dm-3 (propably my swap partition)...
I also mkinitrd with scsi_wait_scan, but no result.

Anybody?

Last edited by lespaul047; 04-06-2009 at 04:54 AM.
 
Old 04-06-2009, 09:08 AM   #2
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 45
You need to configure grub so that it can mount your root (the one that is mounted on /) partition.
Since you already tried to build a new initrd, I assume the configuration is pointing to the wrong root device.
Try changing the root=option to the same as your "good" configuration.

If that doesn't help, you maybe have a problem with the kernel modules (the right modules isn't provided, it isn't in the initrd, or something else driver-related)
 
Old 04-06-2009, 06:50 PM   #3
lespaul047
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
I did what you suggested, but the problem remains. Although, now it is the swap space which cannot be found. It is in my lvm-config, but there is no mount point (/dev/dm-3) in the fstab file. Then, I found out there is a program (running somewhere, doing magical stuff??) called dmsetup. I tried to find out WHAT that program does, but the only thing I read is that it is a low level device mapper and I can see a lot of commands.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to access resume device jdege Linux - General 9 12-20-2007 11:32 PM
"USB device stops working after a time" 'fix' stops cdrom device mount/readability adamben Slackware 6 04-18-2007 02:18 PM
Unable to Build ELDK3.1 for kernel 2.4.25. On Booting Unable to mount root fs.. kannath Debian 0 05-11-2006 10:26 AM
unable to mount device latuzim Linux - General 8 10-23-2004 08:03 PM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration