LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2009, 05:46 PM   #1
MainMeat
LQ Newbie
 
Registered: Apr 2009
Posts: 7

Rep: Reputation: 0
Booting Fedora 9 from USB using SuSE 10.1 and Grub


Hi All,

I guess I am a bit new to this and having read through several forums I am sure there is a solution. I have a laptop on which I have installed SuSE 10.1 some time ago. I also require Fedora 9 and want to run this from a external USB drive. I have installed Fedora 9 successfully on the USB drive, and during the installation specifically did not write changes to the MBR, but wrote it to the first boot record of the external drive.

I guess the next step is to add an entry to the GRUB boot loader of SuSE 10.1 in order to allow for an option to boot Fedora 9 from the USB drive. Can someone please help me or point me into a direction on how this can be achieved?

Thanks in advance for any advice!

Kind Regards.
 
Old 04-10-2009, 10:25 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
First we try it the easy way yast>system>Boot Loader>Other>Propose New Configuration
If it does not come up with Fedora as a option keep it as it was
Run the the command as root fdisk -l (l Lower Case) post it and we give you the lines you should add to you're menu.lst
 
Old 04-14-2009, 03:49 AM   #3
MainMeat
LQ Newbie
 
Registered: Apr 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ronlau9 View Post
First we try it the easy way yast>system>Boot Loader>Other>Propose New Configuration
If it does not come up with Fedora as a option keep it as it was
Run the the command as root fdisk -l (l Lower Case) post it and we give you the lines you should add to you're menu.lst
Hi,

Thank you for your reply. I have tried using yast to update the boot loader but it does not recognize Fedora.

Running fdisk -l provides the following output, where /dev/sda is used by SuSE 10.1, and /dev/sdb is for Fedora

Code:
linux:~ # fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2            6778        7296     4165560   12  Compaq diagnostics
Partition 2 does not end on cylinder boundary.
/dev/sda3              14         275     2104515   82  Linux swap / Solaris
/dev/sda4             276        6777    52227315   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14         274     2096482+  82  Linux swap / Solaris
/dev/sdb3             275        7296    56404215   83  Linux
For clarity, below also find the contents of /boot/grub/menu.lst:

Code:
# Modified by YaST2. Last modification on Tue Apr 14 06:20:46 UTC 2009

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,0)/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 10.0
    root (hd0,0)
    kernel /vmlinuz root=/dev/sda4 vga=0x317 selinux=0    resume=/dev/sda3  splash=silent showopts
    initrd /initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX 10.0
    root (hd0,0)
    kernel /vmlinuz root=/dev/sda4 vga=normal showopts ide=nodma apm=off acpi=off noresume selinux=0 nosmp noapic maxcpus=0 edd=off  3
    initrd /initrd

###Don't change this comment - YaST2 identifier: Original name: 2.6.13-15.18-default###
title 2.6.13-15.18-default
    root (hd0,0)
    kernel /vmlinuz-2.6.13-15.18-default root=/dev/sda4 vga=0x317 selinux=0    resume=/dev/sda3  splash=silent showopts
    initrd /initrd-2.6.13-15.18-default
Thanks you for your help, advice and assistance!

Regards
 
Old 04-15-2009, 05:43 AM   #4
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
We can try to add to you're menu.lst
title Fedora
rootnoverity (hd1,0)
chainloader +1
Use a linux text editor to do so
 
Old 04-15-2009, 06:15 AM   #5
MainMeat
LQ Newbie
 
Registered: Apr 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ronlau9 View Post
We can try to add to you're menu.lst
title Fedora
rootnoverity (hd1,0)
chainloader +1
Use a linux text editor to do so
Hi,

I have included this in the menu.lst on SuSE 10.0, and the result is:
- Fedora is visible in the Grub Boot Loader
- When selecting Fedora I briefly see a screen with:
chainloader +1
GRUB Loading stage 2...
- After this is jumps back to the boot loader again and displays the options as seen at the beginning.

Do I have to make any changes to the files that was installed on the external USB drive?

Kind Regards,

Last edited by MainMeat; 04-15-2009 at 06:16 AM.
 
Old 04-15-2009, 03:09 PM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
To be sure where the OS are will you try the next .
When you see grub is loading press the escape key .
It gives you a few option .
One of them is C for command line .
Choose this option
It brings you to the Grub command line
Give the next commands GRUB> find /grub/stage 1
GRUB> find /boot/grub/stage 1
Hope fully it gives ome use full info
 
Old 04-16-2009, 02:46 AM   #7
MainMeat
LQ Newbie
 
Registered: Apr 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ronlau9 View Post
To be sure where the OS are will you try the next .
When you see grub is loading press the escape key .
It gives you a few option .
One of them is C for command line .
Choose this option
It brings you to the Grub command line
Give the next commands GRUB> find /grub/stage 1
GRUB> find /boot/grub/stage 1
Hope fully it gives ome use full info
Hi,

I have managed to resolve this by installing GRUB on the usb drive, and configuring my system BIOS to boot from the USB drive first, so here was my solution:

(http://urge2blabber.blogspot.com/200...usb-drive.html)

- I have a laptop running SuSE 10.0
- I have a USB drive that I am going to install Fedora 9 on

I installed Fedora on the USB drive, ensuring that I use the correct HDD during partition configuration. During installation I noted that:
- I do not want to update the MBR, as this would mess up the SuSE boot loader. So I wrote the boot record to the first boot sector on the USB drive
- I initially installed KDE which is highly unstable on Fedora 9 and crashes after making the smallest config change - and it looks bad, so I opted for GNome, which apparently is stable.

After the initial install, Fedora reboots, and the system boots into SuSE.

Using SuSE I then updated the Fedora boot loader on the USB as follows:
- All references to '(hd1,0)' in /boot/grub/menu.lst was updated to (hd0,0)
- Open the grub prompt by executing 'grub <return>'
- Ensured that (hd1,0) is the correct HDD, since (hd0,0) would be the SuSE hdd by executing:
geometry (hd1)

and this returned

drive 0x81: C/H/S = 7296/255/63, The number of sectors = 117210240, /dev/sdb
Partition num: 0, Filesystem type is ext2fs, partition type 0x83
Partition num: 1, Filesystem type unknown, partition type 0x82
Partition num: 2, Filesystem type is ext2fs, partition type 0x83

- installed the grub boot loader on the USB drive (hd1) by executing:
setup (hd1)

and this returned
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/fat_stage1_5" exists... yes
Running "embed /boot/grub/fat_stage1_5 (hd0)"... 17 sectors are embedded.
succeeded
Running "install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,0)/boot/grub/stage2 /boot/grub/menu.lst"... succeeded
Done.

- Then typed 'quit' to exit grub and rebooted the system
- Lastly I configured the BIOS to boot from the USB drive and finally...Fedora now boots. Since the boot priority is USB and then the HDD, when the USB is unplugged, the system loads the SuSE boot loader.

Hopefully this info will be helpful to someone in the future!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting Fedora 9 from USB using SuSE 10.1 and Grub MainMeat Linux - Newbie 1 04-09-2009 05:48 PM
A few grub questions / booting external usb drives Only_he_stands_here Linux - General 1 11-15-2008 05:08 PM
Booting USB from GRUB ? telovoyagarcar Linux - Software 2 03-01-2007 09:31 PM
Booting with GRUB to external USB drive Mirag3 Linux - Hardware 3 05-18-2006 08:27 AM
Booting USB from Grub? Fox7777 SUSE / openSUSE 2 09-05-2005 09:37 AM


All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration