LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-27-2003, 11:36 AM   #1
Freeek
Newbie
 
Registered: Sep 2003
Distribution: RedHat 8.0
Posts: 15

Rep: Reputation: 0
Exclamation Booting: Device 0x0309 exceeds 1024 cylinder


Hi.
I installed RHL 8.0 on my friend's PC, and it's not booting without a bootdisk. So to fix it, I booted with the bootdisk, logged in as root, and tried the lilo command at the terminal. It gave the following error:
Warning - Device 0x0309 exceeds 1024 cylinder limit
Fatal : Sector 77516620 - Too large for Linear mode (Try lba32 instead)

He has a P4 1.7 GHz PC with an Intel 845 motherboard and a 40GB HDD, and linux is installed on an extended partition, at around 32 GB. The extended partition has a 100 MB /boot partition, a 256 MB swap partition and the main partition in the rest of the space. Lilo was installed on the /boot partition

The same configuration on my 20GB HDD works fine, with Linux installed on last 3 GB of the HDD, and works perfectly fine!

I read somewhere that the above problem could be caused if the linux partition is beyond 8GB, but in that case, it shouldn't have worked on my PC also!

I want to know how I can fix this problem without having to reinstall Linux! Please help!!!! I'm quite sure that the LBA setting is enabled in his BIOS.
 
Old 09-27-2003, 01:46 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
The 1024 cylinder is not a problem here, it's just a warning (and it's not important, LILO in RH 8.0 can boot from above).
The problem is in the /etc/lilo.conf file. Somewhere inside there's an line with 'linear'. Change it to 'LBA32'. If there's no 'linear' line, make sure the disk mode in BIOS is set to LBA.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting around a cylinder 1024 error Digital Surgeon Fedora - Installation 1 02-08-2005 05:26 PM
1024 cylinder problem drmauro223 Linux - General 7 09-24-2004 03:57 AM
new kernel causes lilo crash; /sbin/lilo = Warning: device 0x0305 exceeds 1024 cylind dandysf Linux - Software 0 08-26-2003 05:50 PM
Triple boot cylinder exceeds maximum supported by the bios wlfdgcrkz Linux - Software 1 06-16-2003 12:14 AM
1024 cylinder boundry hmorrow Linux - Newbie 2 05-22-2001 09:15 AM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration