LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2011, 01:34 AM   #1
ahoeffner
LQ Newbie
 
Registered: Aug 2011
Posts: 14

Rep: Reputation: Disabled
Booting debian without starting a desktop


When booting my debian i always get a desktop. It seems runlevel 2-5 is exactly the same.

/Alex
 
Old 09-10-2011, 03:12 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Quote:
It seems runlevel 2-5 is exactly the same
Well, Debian has run level 2 by default.


Disable gdm : Edit /etc/X11/default-display-manager :
from : /usr/bin/gdm , to : false

#27 http://www.linuxquestions.org/questi...635/page2.html

http://linux.derkeiler.com/Mailing-L.../msg02709.html
..
 
Old 09-10-2011, 03:41 AM   #3
ahoeffner
LQ Newbie
 
Registered: Aug 2011
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
Well, Debian has run level 2 by default.


Disable gdm : Edit /etc/X11/default-display-manager :
from : /usr/bin/gdm , to : false

#27 http://www.linuxquestions.org/questi...635/page2.html

http://linux.derkeiler.com/Mailing-L.../msg02709.html
..
Thanks
 
Old 09-10-2011, 10:26 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,352
Blog Entries: 12

Rep: Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731
Debian by default sets all multi-user runlevels to invoke the GUI.

What I did was get sysv-rc-conf and configure runlevel 3 not to start the gdm. It's in the repos.

I then needed to create a .xinitrc file in your /home/[username] directory for startx to start properly.

My .xinitrc contains one line:

Code:
exec startfluxbox
It worked for me.

Last edited by frankbell; 09-10-2011 at 10:30 PM.
 
  


Reply

Tags
default-display-manager


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
starting service while booting noir911 Red Hat 1 01-05-2009 07:43 PM
starting service while booting noir911 SUSE / openSUSE 1 05-05-2008 09:47 AM
Booting without starting X server Peronthious Fedora 2 04-23-2006 02:56 PM
Just installed debian with a desktop manager, don't want xdm starting. Royle Linux - Newbie 2 01-09-2005 07:46 AM
Starting dhcp when booting jaypeasy Linux - Networking 1 07-22-2003 09:32 AM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration