LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2003, 09:07 AM   #1
harrygraham
Member
 
Registered: Apr 2001
Location: Ottawa, Canada
Distribution: Mint Cinnamon AMD64
Posts: 155

Rep: Reputation: 18
Question booting a dos partition


Any ideas on how to boot a dos partition that's not bootable? I added a third hard disk to my computer and loaded it with dos6.22, but it doesn't want to boot with Lilo. It works fine from a dos boot disk though. Here's my lilo.conf:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
vga=normal
default=JUNE2003
keytable=/boot/us.klt
lba32
prompt
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label=Failsafe
root=/dev/hdb5
initrd=/boot/initrd.img
append=" hdc=ide-scsi devfs=mount mem=176M"
read-only

image=/boot/vmlinuz-2.4.8-33mdk
label=JUNE2003
root=/dev/hdb5
initrd=/boot/initrd-2.4.8-33mdk.img
append=" hdc=ide-scsi devfs=mount mem=176M"
vga=normal
read-only

other=/dev/hdd1
table=/dev/hdd
label=MSDOS

And here's the result:

LOADING MSDOS
Error 0x07

Thanks for any help.

Harry
 
Old 09-10-2003, 11:07 AM   #2
jorm
LQ Newbie
 
Registered: Aug 2003
Location: Germany
Distribution: Knoppix
Posts: 4

Rep: Reputation: 0
Hi Harrygram,

I've got "Linux in a Nutshell" here and it tells to use another option in LILO.
So try:
other=/dev/hdd1
table=/dev/hdd
label=MSDOS
loader=/boot/chain.b
This option gives a ?chain-loader? which should take control over your boot-process. But chain.b is just default. My clever book tells me, that you have to use this option if your hdd is whether the first hidd nor a disk drive.
 
Old 09-11-2003, 04:14 PM   #3
Tez218
Member
 
Registered: Jun 2003
Distribution: Slackware 9.1, UnitedLinux 1.0
Posts: 42

Rep: Reputation: 15
What I think the problem is that M$ OS's want to be on the FIRST partition on the FIRST disk. I had a similar problem when I had linux on my first disk and win xp on the second disk. I forgot exactly what is needed, when I get home Ill check and post again. Good Luck.
 
Old 09-11-2003, 04:53 PM   #4
harrygraham
Member
 
Registered: Apr 2001
Location: Ottawa, Canada
Distribution: Mint Cinnamon AMD64
Posts: 155

Original Poster
Rep: Reputation: 18
Thumbs down Thanks

The modified lilo.conf still gets the same result.

Yes, I know that dos wants to hog all the prime retail space on the hard disks, but I don't want to reinstall Linux just to accomodate an OS that's rarely used.

Thanks very much for your suggestions. It's helping to zero in on an answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
quad booting dos 6.22/win98se/winxppro/mandrake10.1 jgundo Linux - Newbie 5 05-22-2006 01:59 AM
Problem booting Fedora Core 2 install from DOS bleedingturnips Fedora 1 10-20-2004 10:46 AM
Booting to DOS command line from LILO ninadb Linux - General 4 08-12-2004 11:26 AM
URGENT HELP > Booting into DOS with GRUB GodFoca Linux - General 4 07-15-2003 07:49 AM
dos booting lilo enzo250gto Linux - Software 2 11-06-2001 05:56 PM


All times are GMT -5. The time now is 04:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration