LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2006, 09:45 AM   #1
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Rep: Reputation: 15
Booting


I want to be able to use my windows boot loader to come up and then use it to boot my linux... Right now Iam running three OS's on my computer Vista, Xp, & Fedora 6... When I turn my computer on my grub boot loader comes up then if I hit the windows it will take me to the windows boot loader where I have boot options for Fedora, Xp & Vista The Fedora one just brings me back to the grub bootloader which I don't mind but if I could get it to come up after the windows boot laoder then I can set the grub bootloader with a zero second timeout and just boot linux... So if there is anyway I can move the grub bootloader behind the windows one it would help me out... Thanks in advance...
 
Old 12-26-2006, 10:03 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Here's the picture I have so far:
grub is in the mbr and gives choices for Windows + Linux
boot.ini (on the Windows side) is set to choose XP, Vista, or Fedora

The easiest way to proceed is to keep grub in the mbr and set it it chainload to either XP or Vista--ie take out any options in boot.ini.

Please post the output of:
fdisk -l (run as root in Linux)
cat /boot/grub/menu.lst (in Linux also)
and also the contents of boot.ini You should be able to access the NTFS partition from Fedora--if so, then: cat /<pathname>/boot.ini
 
Old 12-26-2006, 11:19 AM   #3
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
gone15

This is a classic case of "a dog chasing its own tail".

In your case you use Grub at the MBR (head of the dog) and then copy Grub inside NTLDR (as a tail) for booting it back to the MBR.

It is simple to stop it

Method (1) - Let Grub retain MBR. Disable Fedora in boot.ini so that only Grub boot Fedora. This is the easiest.

Method (2) - Let NTLDR take over the MBR.

First while in Fedora restore Grub inside its root partition. If the /boot partition of your Fedora is in hda2 the command is just
Code:
grub-install /dev/hda2
You then copy the first 512 bytes of hda2 into the "C" directory of Windows where boot.ini resides, in exactly the same way you first made Fedora bootable by Windows except the location for sourcing first 512 bytes is different. Thereafter you use a Dos floppy or a XP installation CD to restore MS MBR. (Task B1 & B2 of the last of my signature refer). NTLDR will now boot all 3 systems.
 
Old 12-26-2006, 03:57 PM   #4
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Here Are The Output Files

Quote:
Originally Posted by pixellany
Here's the picture I have so far:
grub is in the mbr and gives choices for Windows + Linux
boot.ini (on the Windows side) is set to choose XP, Vista, or Fedora

The easiest way to proceed is to keep grub in the mbr and set it it chainload to either XP or Vista--ie take out any options in boot.ini.

Please post the output of:
fdisk -l (run as root in Linux)
cat /boot/grub/menu.lst (in Linux also)
and also the contents of boot.ini You should be able to access the NTFS partition from Fedora--if so, then: cat /<pathname>/boot.ini
Boot ini File

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT /NOGUIBOOT

Fdisk Output

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4864 39070048+ 7 HPFS/NTFS
/dev/sda2 4865 7817 23718912 7 HPFS/NTFS
/dev/sda3 7818 7830 104422+ 83 Linux
/dev/sda4 7831 9729 15253717+ 5 Extended
/dev/sda5 7831 9729 15253686 8e Linux LVM

Disk /dev/sdb: 507 MB, 507322880 bytes
16 heads, 63 sectors/track, 983 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 983 495313+ 6 FAT16

Grub Menu List

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,2)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda3
default=1
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.18-1.2798.fc6)
root (hd0,2)
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-1.2798.fc6.img
title Windows
rootnoverify (hd0,0)
chainloader +1


P.S. I didn't know I could read my NTFS folder in Fedora since when did that take effect I thought linux wasn't able to read NTFS...

Last edited by gone15; 12-26-2006 at 04:00 PM.
 
Old 12-26-2006, 04:11 PM   #5
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Linux has always been able to read ntfs partitions, It is the writing bit that isn't universally reliable and requires additional software.

You can let Linux to get from ntfs partition to edit all Word document, use Excel spreadsheets, play MP3, display photos...... in just about any distro as long as you don't change the files.
 
Old 12-26-2006, 07:31 PM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
OK--your config files do not match the narrative in the first post.

First, boot.ini has no options--only XP. Also, the grub config file has no option for Vista.

Hunch: The grub Windows option goes to the first drive, first partition (hd0,0 in grubspeak; sda1 in Linuxspeak) So make sure you are looking at the boot.ini that is on THAT partition.
 
Old 12-26-2006, 07:43 PM   #7
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Don't Comprehend

Quote:
Originally Posted by saikee
gone15

This is a classic case of "a dog chasing its own tail".

In your case you use Grub at the MBR (head of the dog) and then copy Grub inside NTLDR (as a tail) for booting it back to the MBR.

It is simple to stop it

Method (1) - Let Grub retain MBR. Disable Fedora in boot.ini so that only Grub boot Fedora. This is the easiest.

Method (2) - Let NTLDR take over the MBR.

First while in Fedora restore Grub inside its root partition. If the /boot partition of your Fedora is in hda2 the command is just
Code:
grub-install /dev/hda2
You then copy the first 512 bytes of hda2 into the "C" directory of Windows where boot.ini resides, in exactly the same way you first made Fedora bootable by Windows except the location for sourcing first 512 bytes is different. Thereafter you use a Dos floppy or a XP installation CD to restore MS MBR. (Task B1 & B2 of the last of my signature refer). NTLDR will now boot all 3 systems.

K I don't get exactly what your trying to say here... I hope I don't sound dumb saying that but its a bit confusing to me... Heres why you said Method (1) and Method (2) then you gave me some things to try... Which method did you give me to try was it the Ntldr one??? Was it the Grub retain MBR one don't understand... Fedora isn't in my Boot.ini file Windows Vista basically does away with the boot.ini file and uses a bcdedit.exe file which you can't even edit like you do the boot.ini file you have to use either a seperate program like bcdedit pro... I pointed the seperate program to a file that I created a bin file in linux (from some instructions on the web somewhere I can find it if needeed) and stored it on my c drive and pointed the bcdedit loader to that file for booting linux which is why the grub loader comes up when selected from the windows boot loader... Hope any of this makes sense to you guys... If not tell me what doesn't and i'll try to clear it up... Thanks for your help so far...
 
Old 12-26-2006, 07:45 PM   #8
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Ntfs

Quote:
Originally Posted by saikee
Linux has always been able to read ntfs partitions, It is the writing bit that isn't universally reliable and requires additional software.

You can let Linux to get from ntfs partition to edit all Word document, use Excel spreadsheets, play MP3, display photos...... in just about any distro as long as you don't change the files.
How would I go about seeing my NTFS files then??? I would love to be able to play some of my mp3's and read my word docs from linux... If you can point me in the write direction of that it would be Great...
 
Old 12-26-2006, 07:48 PM   #9
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pixellany
OK--your config files do not match the narrative in the first post.

First, boot.ini has no options--only XP. Also, the grub config file has no option for Vista.

Hunch: The grub Windows option goes to the first drive, first partition (hd0,0 in grubspeak; sda1 in Linuxspeak) So make sure you are looking at the boot.ini that is on THAT partition.
In Vista they don't use the Boot.ini file they use something new called the BCDEDIT.exe file which isn't very easy to edit but can be configured using a program called bcdedit pro... What I just would like to do is put the grub boot loader behind the windows one if any way possible... Know what I mean??? Cause that wouldn't be my ideal soloution to all of this but it would be a fix that I would be willing to cope with...
 
Old 12-26-2006, 08:16 PM   #10
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I think your Windows disk has been taken over by Vista's new boot loader which I haven't used. My Vista was installed as a standalone system and I just added to my Box as the 131th OS all booted by Grub. It can boot just like a Dos or Windows system that way.

There is a free software called VistaBootPro which I have downloaded but never tried it out. May be you can have a go at it.

If you want to access your two Windows partitions sda1 and sda2 in Fedora, log in as root, create directories in /mnt, mount the two partitions and you will find them in your desktop folder /mnt
Code:
mkdir /mnt/sda1
mkdir /mnt/sda2
mount /dev/sda1 /mnt/sda1
mount /dev/sda2 /mnt/sda2
I believe you need to install plug-ins before some of the MP3 players can work as Fedora avoids litigation by not shipping them with the distro.

Last edited by saikee; 12-26-2006 at 08:22 PM.
 
Old 12-27-2006, 07:55 PM   #11
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
NTFS Not Recognized

Quote:
Originally Posted by saikee
I think your Windows disk has been taken over by Vista's new boot loader which I haven't used. My Vista was installed as a standalone system and I just added to my Box as the 131th OS all booted by Grub. It can boot just like a Dos or Windows system that way.

There is a free software called VistaBootPro which I have downloaded but never tried it out. May be you can have a go at it.

If you want to access your two Windows partitions sda1 and sda2 in Fedora, log in as root, create directories in /mnt, mount the two partitions and you will find them in your desktop folder /mnt
Code:
mkdir /mnt/sda1
mkdir /mnt/sda2
mount /dev/sda1 /mnt/sda1
mount /dev/sda2 /mnt/sda2
I believe you need to install plug-ins before some of the MP3 players can work as Fedora avoids litigation by not shipping them with the distro.
This didn't work for me this is the errors that I got...

[root@localhost greatone]# mkdir /mnt/sda1
[root@localhost greatone]# mkdir /mnt/sda2
[root@localhost greatone]# mount /dev/sda1 /mnt/sda1
mount: unknown filesystem type 'ntfs'
[root@localhost greatone]# mount /dev/sda2 /mnt/sda2
mount: unknown filesystem type 'ntfs'
[root@localhost greatone]#

Did I do something wrong??? I followed your instructions to a T...
 
Old 12-27-2006, 11:26 PM   #12
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Try this:
mount -t ntfs /dev/sda1 /mnt/sda1

My automatically generated fstab does not rely on auto fs detection--it specifies the filesytem for everything.

You can also make an fstab entry and then mount by just saying
mount /dev/sda1

See man mount, or man fstab for all the gory details
 
Old 12-28-2006, 01:51 AM   #13
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pixellany
Try this:
mount -t ntfs /dev/sda1 /mnt/sda1

My automatically generated fstab does not rely on auto fs detection--it specifies the filesytem for everything.

You can also make an fstab entry and then mount by just saying
mount /dev/sda1

See man mount, or man fstab for all the gory details

[root@localhost ipw3945-1.1.0]# mount -t ntfs /dev/sda1 /mnt/sda1
Error Received mount: unknown filesystem type 'ntfs'

[root@localhost ipw3945-1.1.0]# mount /dev/sda1
Error Received mount: can't find /dev/sda1 in /etc/fstab or /etc/mtab

Don't know why I keep getting the same errors... But I guess no one said it was going to be easy...
 
Old 12-28-2006, 01:55 AM   #14
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The kernel you're running doesn't have NTFS support, hence the "unknown filesystem type" error. Have a look here.
 
Old 12-28-2006, 07:54 AM   #15
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Sorry, I didn't pick this one up.

The Red Hat and Fedora are funny in this respect of not supporting ntfs partitions without additional work. Most of the other distros don't have such a hang up.

In the short time I investigated the commands in Post #10 work satisfactorily in Ubuntu, Knoppix, Mandriva, Slax, Gentoo and Slackware familes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual-booting and Multi-Booting trainee Slackware - Installation 6 06-18-2006 08:50 PM
booting Linux from an image that lost booting capabilities tgr Linux - Software 1 03-05-2006 12:28 PM
Booting into Single User on MDK 9 asks for root password instead of booting into root acadcworks Linux - General 6 01-10-2006 07:51 AM
booting new kernel. Booting new kernel dies with INIT: VFS issue, really mus335 Linux - General 0 04-21-2004 12:52 PM
Are you dual booting and Windows stopped working (booting) then here's the answer: rberry88 Linux - General 1 02-12-2004 10:05 AM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration